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Preface
This book is your guide to installing AccuRev Plug-In for Eclipse (AccuRev Plug-In). It is intended for the 
AccuRev system administrator. This book provides information specific to this release, including notes on 
platform support and a summary of changes for the current and recent releases. 

See the AccuRev Plug-In for Eclipse User’s Guide for information about using the AccuRev Plug-In within 
the Eclipse environment.

Using This Book
This book assumes you are familiar with your operating system and its commands, as well as with 
AccuRev and Eclipse. The remaining chapters in this book tell you how to prepare for and install AccuRev 
Plug-In and provide information on features, fixes, and known issues in the current and recent releases:

Typographical Conventions
This book uses the following typographical conventions:

Chapter Description

Chapter 1 Introduction Introduces the current release and describes its highlights.

Chapter 2 Installing AccuRev 
Plug-In for Eclipse

Provides background information and procedures for installing AccuRev 
Plug-In.

Chapter 3 Release Notes New features, fixes, and known issues in the current and recent releases.

Convention Description

blue sans-serif Used for sample code or output.

red monospace Used for examples.

bold Used for command names, and button names in the 
AccuSync Web user interface

light italic Used for emphasis, book titles, and for first use of important terms

blue italic Identifies a hyperlink (to a page or Web URL, for example)
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Contacting Technical Support
AccuRev offers a variety of options to meet your technical support needs as summarized in the following 
table.

When you contact AccuRev technical support, please include the following information:
• The version of AccuRev and any other AccuRev products you are using (AccuSync or GitCentric, for 

example)

• Your operating system

• The version of relevant third-party software (if you are using AccuSync, for example the version of 
your ITS)

• A brief description of the problem you are experiencing. Be sure to include which AccuRev interface 
you were using (Web user interface, Java GUI, or CLI), any error messages you received, what you 
were doing when the error occurred, whether the problem is reproducible, and so on.

• A description of any attempts you have made to resolve the issue

• A simple assessment of how the issue affects your organization

For Visit

Information about technical support services http://supportline.microfocus.com/

Information about platforms support http://supportline.microfocus.com/prodavail.aspx

Product downloads and installations http://supportline.microfocus.com/websync/
productupdatessearch.aspx

Product documentation http://supportline.microfocus.com/productdoc.aspx

SupportLine phone numbers, listed by 
country

http://www.microfocus.com/about/contact/support/
assistance.aspx
vi AccuRev® Plug-In for Eclipse Installation and Release Notes



1. Introduction
AccuRev Plug-In for Eclipse (AccuRev Plug-In) integrates AccuRev functionality with the Eclipse 
Platform IDE (Integrated Development Environment). 

This chapter describes the highlights of the current release.

Highlights of this Release
AccuRev Plug-In Version 2014.1 contains enhancements and bug fixes, including:

• New: Ignored files now show status indicators. AccuRev Plug-In 2014.1 contains a new 
decorator icon to indicate the ignored status of files. A new option, Remove from Ignore, has been 
added for (external)(ignored) files. 

• New: The Login dialog is automatically populated with the correct server name. 
AccuRev Plug-In now automatically populates the Server field of the Login dialog box with the server 
name that is appropriate to the currently selected Eclipse project.

• Filter external files in Synchronizing View perspective. You can filter out external files by 
designating them as “ignored” or by using the Commit All option.

• No need to restart Eclipse when switching from wireless to wired adapter. AccuRev 
Plug-In for Eclipse can now recover when the login session is reestablished and you do not need to 
restart Eclipse to use AccuRev options.

• Startup performance improved. Performance issues involving user access to the Eclipse 
Workbench during the AccuRev Plug-In startup process have been addressed.

What to Do Next
To install AccuRev Plug-In, see Chapter 2 Installing AccuRev Plug-In for Eclipse.

For details about the specific changes introduced in this release, see Chapter 3 Release Notes.
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2. Installing AccuRev Plug-In
for Eclipse 

Before installing AccuRev Plug-In for Eclipse (AccuRev Plug-In), ensure that you have an AccuRev client 
on the same machine that is running Eclipse. See the Installation and Release Notes document for your 
version of AccuRev for instructions on installing AccuRev.

Note: AccuRev Plug-In version 2010.1 and later provides access to the AccuRev Web Interface (Web UI). 
For instructions on configuring this option, see Configuring Access to the AccuRev Web Interface on 
page 10.

Platform Support
AccuRev Plug-in version 2014.1 has been validated with Eclipse Platform Versions 4.x, 3.7.x, 3.6.x, 3.5.x, 
3.4.x, and 3.3.x. 

AccuRev recommends Java 2 Runtime Environment 5.0 and higher; versions 1.4.2 and higher are 
supported. 

Installing on Eclipse 3.5, 3.6, 3.7, or 4.x
Use the procedures described in this section to add the AccuRev update site to the Eclipse repository and to 
install AccuRev Plug-in.

Adding the AccuRev Update Site
AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If you 
require offline or local network access to an update site for installing the plug-in, see the section titled 
Setting Up a Local Update Site on page 10.

Otherwise, follow this procedure to add the AccuRev update site to the list of sites that Eclipse can contact:

1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu.

The first page of the Install New Software wizard appears.
AccuRev® Plug-In for Eclipse Installation and Release Notes 3



3. Click Add.

The Add Repository dialog box appears.

4. In the Add Repository dialog box:

• In the Name field, enter a unique name for the AccuRev Plug-In.

• In the Location field, enter the URL of the AccuRev update site:
http://www.accurev.com/download/eclipseupdate 

5. Click OK to add the AccuRev update site to the Eclipse repository.

6. To continue installing AccuRev Plug-In, go to Step 3 in Installing AccuRev Plug-In for Eclipse on 
page 4. If you want to install AccuRev Plug-In at a later time, click Cancel to stop the Install New 
Software wizard.

Installing AccuRev Plug-In for Eclipse
Before you begin, add the AccuRev update site to the Eclipse repository if you have not done so already. 
See Adding the AccuRev Update Site on page 3.

1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu.

The first page of the Install New Software wizard appears.
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3. Select the AccuRev Plug-In site from the Work with drop-down list.

4. Select the checkbox next to AccuRev Plug-In for Eclipse and click Next.

5. Click through the wizard to review the installation and to confirm the license agreement.

Eclipse installs AccuRev Plug-In.
Note: During installation, you might receive a security warning about unsigned content. Click OK to 
acknowledge the warning and finish the installation.
When the installation finishes, Eclipse prompts you to restart the Eclipse IDE.

6. Click Restart Now to restart the Eclipse IDE and complete the installation.

When you restart Eclipse, it opens in the AccuRev perspective, as shown in the following illustration:
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Note: Buttons on the AccuRev toolbar are displayed as active only if you have selected a file in the 
Package Explorer that has been added to AccuRev.

Installing on Eclipse C/C++ Development Tooling (CDT) Installations
Installation on Eclipse CDT 3.6 requires that you first install the Java Development Tools (JDT) 3.6.1 or 
later. Once the JDT is installed, you can successfully install the Eclipse Plug-in.

To install the JDT on Eclipse CDT 3.6:
1. In Eclipse C++, select Help > Install New Software from the menu.

The Install wizard appears.
2. In the filter field following the Work with field, type java.

The table displays available Java plug-ins.
3. Select Eclipse Java Development Tools.

4. Click Next to complete the Eclipse Install wizard.

Installing on Wind River Workbench
Installation on Wind River Workbench requires that you first install the Java Development Tools (JDT) 
3.6.1 or later.

To install the JDT on Wind River Workbench:
1. Select Window > Open Perspective > Advanced Device Development from the Workbench menu to 

open the Advanced Device Development perspective.

2. Select Help > Install New Software from the Advanced Device Development perspective menu.

3. In the Preferences dialog box, select Install/Update > Available Software Sites.

4. Locate and select Eclipse Galileo Repository, click the Enable button, and then click OK.

5. In the Install dialog box, locate and select Eclipse Java Development Tools.

6. Click Next to complete the Wind River Install wizard.

Verifying the Installation
To verify that the installation of AccuRev Plug-In was successful:

1. Start the Eclipse IDE.

2. Select Help > About Eclipse from the Eclipse menu. 

3. Click Installation Details, and go to the Installed Software tab on the Eclipse SDK Installation Details 
dialog box.

4. Verify that an AccuRev Plug-In for Eclipse entry exists.

Uninstalling AccuRev Plug-In for Eclipse
1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu.
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3. Click Installation Details, and go to the Installed Software tab on the Eclipse Installation Details 
dialog box.

4. Highlight the AccuRev Plug-in for Eclipse entry.

5. Click the Uninstall... button. 

Note: If this button is disabled, you manually installed an earlier version of AccuRev Plug-In. Instead 
of using this procedure, shut down the Eclipse IDE, then search for and delete files and folders in your 
Eclipse installation directory that start with com.accurev.eclipse.

6. When the Uninstall window appears, verify that you want to uninstall the items shown, and click 
Finish to uninstall the plug-in.

Installing on Eclipse 3.4
Use the procedures described in this section to add the AccuRev update site to the Eclipse repository and to 
install AccuRev Plug-in.

Adding the AccuRev Update Site
AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If you 
require offline or local network access to an update site for installing the plug-in, see the section titled 
Setting Up a Local Update Site on page 10.

Otherwise, follow this procedure to add the update site to the list of sites that Eclipse can contact:

1. Start the Eclipse IDE.

2. Select Help > Software Updates from the Eclipse menu, and go to the Available Software tab on the 
Software Updates and Add-ons window that appears.

3. Click Add Site.

4. Fill in the AccuRev update site URL (http://www.accurev.com/download/eclipseupdate) in the 
Location field, and click OK. The new update site appears on the list of remote sites.

Installing AccuRev Plug-In for Eclipse
To install AccuRev Plug-In after creating the new remote site:

1. Select Help > Software Updates from the Eclipse menu, and go to the Available Software tab on the 
Software Updates and Add-ons window that appears.

2. Expand the AccuRev update site in the list.

3. Select the checkbox next to AccuRev Plug-in for Eclipse and click Install to proceed.

4. Click Next to confirm.

5. Accept the license agreement and click Next to proceed.

6. Click Finish to install the plug in.

7. Restart the Eclipse IDE to complete the installation.
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Verifying the Installation
AccuRev Plug-in will be loaded and enabled automatically when you restart Eclipse. To verify that the 
installation was successful:

1. Start the Eclipse IDE.

2. Select Help > Software Updates from the Eclipse menu and go to the Installed Software tab on the 
Software Updates and Add-ons window that appears.

3. Verify that an AccuRev Plug-in for Eclipse entry exists in the configuration window.

Updating AccuRev Plug-In for Eclipse
If an older version of the AccuRev Plug-In is currently included in your Eclipse configuration, you will 
need to uninstall it and add a new update site as described in Adding the AccuRev Update Site on page 7 
and Installing AccuRev Plug-In for Eclipse on page 7 to install the latest version.

Uninstalling AccuRev Plug-In for Eclipse
1. In the IDE, select Help > Software Updates from the Eclipse menu and go to the Installed Software 

tab on the Software Updates and Add-ons window that appears.

2. Highlight the AccuRev Plug-In for Eclipse entry.

3. Click the Uninstall... button. 

Note: If this button is disabled, you manually installed an earlier version of AccuRev Plug-In. Instead 
of using this procedure, shut down the Eclipse IDE, then search for and delete files and folders in your 
Eclipse installation directory that start with com.accurev.eclipse.

4. When the Uninstall window appears, verify that you want to uninstall the checked items, and click 
Finish to uninstall the plug-in.

Installing on Eclipse 3.3
Use the procedures described in this section to add the AccuRev update site to the Eclipse repository and to 
install AccuRev Plug-In.

Adding the AccuRev Update Site
AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If you 
require offline or local network access to an update site for installing the plug-in, see the section titled 
Setting Up a Local Update Site on page 10.

Otherwise, follow this procedure to add the update site to the list of sites that Eclipse can contact:

1. Start the Eclipse IDE.

2. Select Help > Software Updates > Find and Install from the Eclipse menu.

3. Select Search for new features to install on the dialog that appears, and click Next to proceed.

4. Click New Remote Site.
8 AccuRev® Plug-In for Eclipse Installation and Release Notes



5. Fill in the Name and URL of the update site on the 
New Update Site dialog, and click OK to proceed.

The new update site appears on the list of remote 
sites.

6. Click Finish to update the list of sites and search 
for features available on the new site.

An Updates dialog will display if there are new 
plug-ins or features available.

Installing AccuRev Plug-In for Eclipse
To install AccuRev Plug-In after creating the new remote site:

1. Expand the tree on the Updates dialog to show the available software.

2. Select the checkbox next to AccuRev Plug-in for Eclipse and click Next to proceed.

3. Accept the license agreement and click Next. (You may be presented with optional features; ignore this 
prompt and proceed to the next screen. These features are specific to Eclipse 3.4.)

4. Click Finish to install the plug-in.

5. Verify that you want to install an unsigned feature by clicking Install All.

6. Restart the Eclipse IDE to complete the installation.

Verifying the Installation
The AccuRev Plug-In will be loaded and enabled automatically when you restart Eclipse. To verify 
successful installation:

1. Start the Eclipse IDE.

2. Select Help > Software Updates > Manage Configuration from the Eclipse menu, then expand the 
entry that indicates the pathname of your Eclipse installation.

3. Verify that an AccuRev Plug-In for Eclipse entry exists in the configuration window.

Updating AccuRev Plug-In for Eclipse
If an older version of AccuRev Plug-In is currently included in your Eclipse configuration, you will need 
to uninstall it and add a new update site as described in Adding the AccuRev Update Site on page 8 to 
install the latest version.

The Updates dialog will display to install the new plug-in. Follow the prompts to finish the installation.

Disabling and Uninstalling AccuRev Plug-In for Eclipse
A plug-in to Eclipse can be disabled, which prevents the feature from being used, but leaves the feature 
installed on your machine. Once it has been disabled, a plug-in can be uninstalled.

Disabling AccuRev Plug-In for Eclipse
1. Select Help > Software Updates > Manage Configuration from the Eclipse menu, to display the 

Product Configuration window.
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2. Expand the entry that indicates the pathname of your Eclipse installation.

3. Select the AccuRev Plug-In for Eclipse subentry.

4. Click the Disable task link, and click OK in the confirmation dialog.

5. Click Yes in the dialog that offers to restart Eclipse.

Uninstalling AccuRev Plug-In for Eclipse
1. Disable AccuRev Plug-In, as described in Disabling AccuRev Plug-In for Eclipse.

2. Select Help > Software Updates > Manage Configuration from the 
Eclipse menu, to display the Product Configuration window.

3. Click the Show Disabled Features toolbar button.

4. Expand the entry that indicates the pathname of your Eclipse installation.

5. Select the AccuRev Plug-In for Eclipse subentry.

6. Click the Uninstall task link, and click OK in the confirmation dialog.

7. Click Yes in the dialog that offers to restart Eclipse.

Setting Up a Local Update Site
If your organization’s IT policies do not allow regular Eclipse plug-in updates using a remote update site, 
you can create an update site on your local network instead. 

To create a local update site:

1. Create a directory on a network accessible machine called AccuRevPlugIn_update or something 
similar.

2. Using a Web browser, access the AccuRev Plug-In download page: 

http://www.accurev.com/customer-support-resources/downloads/integration-packages 
3. Download the .zip file for the AccuRev Plug-In (AccuRevPlugIn_Eclipse_2014_1.zip, for example) 

to the local AccuRevPlugIn_update directory you created in Step 1.

4. Extract the .zip file contents to the AccuRevPlugIn_update directory.

5. Distribute the location of the AccuRevPlugIn_update directory to the AccuRev Plug-In users in your 
organization. They can then define a new update site using the AccuRevPlugIn_update directory. 
(Eclipse 3.3 users must specify a New Local Site.)

Configuring Access to the AccuRev Web Interface
Version 2010.1 and later of AccuRev Plug-in provide access to the AccuRev Web Interface (Web UI). This 
section describes how to configure the AccuRev Web UI to work with Eclipse.

Features Available through the Web UI
When you configure access to the AccuRev Web UI, you make the following features available to your 
users:

• Version Browser
10 AccuRev® Plug-In for Eclipse Installation and Release Notes
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• StreamBrowser™

• Annotate

• Create New Issue

• Open Issue Queries

Before You Begin
Before performing the configuration procedure, obtain the URL used to access the Web UI. For example, 
http://localhost:8080/accurev. You will need this URL to complete the configuration procedure.

How to Configure the AccuRev Web UI
To configure the AccuRev Web UI to work with Eclipse, you need to modify the AccuRev Server 
settings.xml file as described in the following procedure:

1. Shut down Eclipse.

2. Create a file called settings.xml and add these lines:
<settings>

<webui url="http://webui-host:port/accurev"/>

</settings>

Where webui-host:port is the server name and port of the server hosting the AccuRev 
Web UI -- localhost:8080, for example.

3. On the AccuRev Server, save settings.xml in the storage\site_slice\dispatch\config directory where 
you installed AccuRev.

4. If you are using AccuRev replica servers, create and save settings.xml to the 
storage\site_slice\dispatch\config directories on those machines as well.

5. Restart Eclipse.

Several new buttons appear on the AccuRev perspective toolbar as shown in the following illustration:

The highlighted groups of buttons are for features that are accessible only after access to the 
Web UI has been configured:
• Version Browser

• Annotate

• Open the Web UI

• Open the StreamBrowser™

• Create New Issue

• Open Issue Queries

6. Click the Open Web UI button to start the AccuRev Web UI within the Eclipse framework. 
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Note: If you are not already logged in to AccuRev, you are prompted to do so. See Logging In to 
AccuRev in the Eclipse Plug-in for AccuRev User’s Guide for more information.

Adding AccuRev Executables to the PATH (Mac OS X 
Only)
To ensure that all AccuRev executables are on your system’s PATH, create the following files as "sudo":

• /etc/paths.d/AccuRev. For example: 
sudo echo "/Applications/AccuRev/bin" > /etc/paths.d/AccuRev

• /etc/paths.d/Acdiffgui. For example:
sudo echo "/Applications/AccuRev/bin/acdiffgui.app/Contents/MacOS" > 
/etc/paths.d/Acdiffgui

• /etc/paths.d/Acgui. For example:
sudo echo "/Applications/AccuRev/bin/acgui.app/Contents/MacOS" > /etc/paths.d/Acgui

Enabling the AccuRev Diff Tool to Work as a 
Standalone (Mac OS X Only)
To enable the AccuRev diff GUI tool (acdiffgui) to work stand-alone as well as from an IDE integration 
such as Eclipse, do the following:

1. Make a backup copy of acdiffgui:

cd /Applications/AccuRev/bin/acdiffgui.app/Contents/MacOS
mv acdiffgui acdiffgui.orig

2. Create a new acdiffgui file with the following content:

#!/usr/bin/perl
$cmd = "java -Duser.dir=/Applications/AccuRev/bin -Xms32M -Xmx512M 
-classpath \"/Applications/AccuRev/bin/oro.jar:/Applications/AccuRev/bin/
xercesImpl.jar:/Applications/AccuRev/bin/xml-apis.jar:/Applications/
AccuRev/bin/fw.jar:/Applications/AccuRev/bin/werken.opt.jar:/Applications/
AccuRev/bin/diff.jar\" diff.DiffApp ";
foreach $arg(@ARGV){
 $cmd .= "\"$arg\" ";
}
system ($cmd);

3. Close any shells.

4. Open a new shell.

Running acdiffgui should now bring up the AccuRev graphical diff tool, and it should also work from 
within any integrated IDE.
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The AccuRev Diff Tool Must be on Your PATH (Linux/
Unix Only) 
The Merge and Diff Against commands in the AccuRev perspective rely on access to the acdiffgui 
executable (which is part of the AccuRev product installation). If the acdiffgui executable or a link to it is 
not in your PATH and accessible by the currently logged-in user, these operations will fail silently.
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3. Release Notes
This chapter describes the changes to AccuRev® Plug-In for Eclipse (AccuRev Plug-In) in version 2014.1, 
as well as previous AccuRev Plug-In releases.

Version 2014.1
27585 -- New: The Login dialog is automatically populated with the correct server name

In previous releases, the Server field of the Login dialog box contained the name of the user’s default 
server. Support has been added to automatically populate this field with the server name that is 
associated with the currently selected Eclipse project. 

27888 -- Shared workspaces not recognized
In previous releases, AccuRev Plug-In for Eclipse did not recognize workspaces that are shared 
through a UNC path or a mapped drive. This problem has been corrected in the current release.

29014 -- Project Explorer hangs when AccuRev Plug-in is present
In previous releases, performing certain AccuRev operations in the Project Explorer view in Eclipse 
caused the Project Explorer to hang and rendered Eclipse unresponsive. This problem has been 
corrected in the current release.

29217 -- Error encountered when promoting from the Team Synchronization perspective 
in Eclipse

In previous releases, attempting to perform a promote operation from the Team Synchronization 
perspective in Eclipse produced the following error message: "Element is not in default group". This 
problem has been corrected in the current release.

29227 -- Eclipse restart required after switching from wireless to wired adapter
In previous releases, users who switched from a wireless to a wired adapter were required to log in to 
AccuRev again, and Team options were unavailable until Eclipse was restarted. This problem has been 
corrected in the current release.

29613 -- Label decorations too large
In previous releases, the size of the label decorations (overlay icons) used by AccuRev Plug-In for 
Eclipse was too large and sometimes hid Eclipse information. In the current release, the size of the 
overlay icons has been reduced to 7x8 pixels, in accordance with Eclipse standards.

30782 -- Promoting a file using AccuRev Plug-In for Eclipse requires an issue number
In previous releases, AccuRev Plug-In for Eclipse sometimes prompted users for issue numbers 
unnecessarily during a promote operation. This problem has been corrected in the current release.

30848 -- New: Ignored files now show status indicators when displayed within the 
AccuRev perspective

In previous releases, the status of ignored files was not displayed in the AccuRev perspective of the 
Package Explorer. To correct this problem, a new decorator icon has been added to indicate the ignored 
status of files. In addition, the Add to Ignore option is now available only for (external) files and is 
AccuRev® Plug-In for Eclipse Installation and Release Notes 15



disabled for (member) files, the Add to AccuRev Depot option is now disabled for (external)(ignored) 
files, and a Remove from Ignore option has been added for (external)(ignored) files. 

31022, 31329 -- Status icons of directories in Eclipse do not correctly reflect status of files 
in the directory

In previous releases, the directory icons in Eclipse indicated that the contents of the directory had 
changed after a promote operation.This problem has been corrected in the current release.

32262 -- Sharing an Eclipse project on a substituted drive causes a java exception
In previous releases, the AccuRev Plug-In for Eclipse produced a Null Pointer Exception if a user 
created a substituted drive to the local workspace's parent directory, imported a Java project into the 
workspace, and then selected Team > Share Project. This problem has been corrected in the current 
release.

32305 -- Login dialog not indicating incorrect port number for server
In previous releases, login would fail silently if an incorrect port number, such as 5050, was specified 
for the server. An error message explaining the cause of the failure has been added in the current 
release.

32469 -- Performing a Team > Share operation on a project in an existing AccuRev 
workspace throws an exception

In previous releases, performing a Team > Share operation on an existing AccuRev workspace caused 
a null pointer exception. This problem has been corrected in the current release.

32503 -- Delay Workbench access until Plug-In is fully started
In previous releases, AccuRev Plug-In for Eclipse was allowing user access to the Eclipse Workbench 
before the AccuRev Plug-In for Eclipse had fully started which, in some cases, caused slow 
performance or threw processing exceptions when referenced objects were null. This problem has been 
corrected in the current release.

32614 -- Issue list in the Synchronizing View in Eclipse not cleared upon completion of 
synchronize operation

In previous releases, synchronizing Eclipse with AccuRev did not clear the stale files from the issue 
list in the Synchronizing View. This problem has been corrected in the current release.

33021 -- Cannot filter external files in the Synchronizing View perspective
In previous releases, users were not able to filter out external files in the Synchronizing View 
perspective in Eclipse. In the Outgoing changes mode, having a large number of external files made it 
difficult for users to view their changes.
Two methods of filtering out external files from the Synchronizing View perspective have been added 
in the current release:
• Designating the external items as "ignored" hides these files from the Outgoing files list

• Using the Commit All option shows only modified files in the first page of the Commit All 
window: 
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and only external files in the second page:

33681 -- The Select Issue dialog box is empty during a promote operation
In previous releases, when a user performed a promote operation, it was possible for the "Select Issue" 
dialog box to contain no issues. This problem has been corrected in the current release.

34199 -- Creating a new Plug-In project in Eclipse produces an exception
In previous releases, attempting to create a Plug-In project in Eclipse using Accurev Plug-In for 
Eclipse generated a Java exception error. This problem has been corrected in the current release.
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Version 2013.5
31152 -- The Promote dialog box appears unexpectedly

In previous releases, the Promote dialog box appeared unexpectedly when the user shared a project 
under certain conditions, such as when the project status had been excluded or was external. This 
problem has been corrected in the current release.

31081 -- AccuRev Plug-In generates exceptions if the Eclipse workspace is unavailable
In previous releases, some users experienced problems when AccuRev Plug-In loaded and attempted 
to access the Eclipse workspace before it became available. This problem has been corrected in the 
current release.

31080 -- Add to Ignore option fails to handle Japanese file names correctly
In previous releases, the Team > Add to Ignore option did not work correctly when file names 
contained Japanese characters. This problem has been corrected in the current release.

31079 -- Attempting to log on in Japanese produces extraneous characters
In previous releases, Japanese characters appeared twice when users attempted to log in using the Web 
UI in Eclipse. This problem has been corrected in the current release.

30914 -- The FilteredEventReader produces an error with IBM’s JVM 6
In previous releases, using the FilteredEventReader command with IBM’s implementation of JVM 6 in 
version 8 of the IBM Rational Application Developer produced an error. This problem has been 
corrected in the current release.

30843 -- Debug information enhanced to track the servers.xml file
This release of AccuRev Plug-In contains additional debugging information related to the servers.xml 
file for the purpose of tracking the location of this file.

30794 -- Cannot promote changes if a pre-promote trigger exists
In previous releases, AccuRev Plug-In users were not able to promote changes when a pre-promote 
trigger existed, except to the Default issue. This problem has been corrected in the current release.

30780 -- Cannot promote changes if the client dispatch promote trigger is not set
In previous releases, AccuRev Plug-In users could only promote changes to an issue if the client 
dispatch promote trigger was set. This problem has been corrected in the current release. 

30587 -- The message.properties file contains duplicate entries
In previous releases, the following duplicated keys in the messages.properties file caused problems 
with some third-party tools: LOGIN, COMPARE_LABEL, ISSUES_COLUMN. These duplicated 
keys have been eliminated and this problem has been corrected in the current release.

30394 -- AccuRev Plug-In does not work with RAD 8.0.4
In previous releases, the AccuRev plug-in for Eclipse did not work correctly with IBM Rational 
Application Developer version 8.0.4. This problem has been corrected in the current release.

30236 -- The Merge/Diff tool does not handle UTF-8 characters in the filename 
In previous releases, the Merge/Diff tool would not start if a file name contained a UTF-8 character. 
This problem has been corrected in the current release.
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28779 -- Using Mylyn with AccuWork
The AccuRev Plug-In for Eclipse now supports using Mylyn with AccuWork. For more information, 
see Version 2013.4 on page 19.

27590 -- The Diff Against menu option should be moved away from Revert To option
In previous releases, the Diff Against > Backed Version menu option was adjacent to the Revert To > 
Backed Version menu option. In the current release, the Diff Against Backed Version has been 
moved adjacent to the Version Browser option.

Version 2013.4
30364, 30322 -- Improvements to cut/copy/paste and delete/remove performance

In previous releases, performing cut/copy/paste and delete/remove operations on individual files took 
longer than expected because AccuRev Plug-In was getting status on both the file’s directory and the 
workspace parent. This problem has been corrected in the current release, and AccuRev Plug-In now 
performs required operations on individual files when appropriate.

30113 -- Eclipse refresh no longer refreshes AccuRev status
In previous releases, refreshing a project using Eclipse (F5, File > Refresh, or choosing Refresh from 
the context menu in the Project Explorer) caused AccuRev Plug-In to perform a full refresh of the 
AccuRev statuses. This problem has been corrected in the current release, and AccuRev Plug-In now 
performs a complete refresh of AccuRev statuses only when using the Team > Refresh > Selected 
Projects (or All Projects) menu.

29957 -- Improvements in elink management
In previous releases, AccuRev Plug-In did not properly manage multiple elinks with the same target, 
which sometimes resulted in some elinks not getting refreshed. This problem has been corrected in the 
current release.

29899 -- AccuRev Plug-In no longer starts other jobs when refreshed
In previous releases, AccuRev Plug-In tried to resume dormant jobs started by other IDEs when it was 
refreshed. This problem has been corrected in the current release.

27589 -- Cannot promote without a default query
In previous releases, you could not promote changes against an issue unless you had defined a default 
query -- AccuRev Plug-In would display a dialog box which allowed you to promote against the 
default issue only. This problem has been corrected in the current release, and you can now select an 
issue number when promoting.

Version 2013.3
27587 -- Add to Ignore

AccuRev Plug-In has a new feature, Team > Add to Ignore, that allows you to quickly specify one or 
more files that you want AccuRev to ignore. To use this feature:
1. Locate the external files you want AccuRev to ignore (manually in the Package Explorer, or use 

Team > AccuRev Searches > External, for example).

2. Select the files you want AccuRev to ignore.
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3. Right-click, and choose Team > Add to Ignore. 

AccuRev Plug-In creates a .acignore file in that directory configured with the files you selected. If 
a .acignore file already exists in that directory, AccuRev Plug-In updates it with the names of the 
files.

28170 -- AccuRev Plug-In did not recognize existing workspaces after mapping drives
In previous releases, AccuRev Plug-In did not recognize existing workspaces if the location of the 
workspace was specified using a mapped drive. For example, imagine creating a workspace at 
c:\accurev\my_workspaces\acme and then mapping c:\accurev\my_workspaces to J:, so the 
workspace path is now J:\acme. If you subsequently tried to access the acme workspace through 
Eclipse using J:\acme (to share or create a new project, for example), AccuRev Plug-In would be 
unaware of the existing workspace. This problem has been corrected in the current release.

28745 -- AccuRev Plug-In could not get status for element-link directory structures
In previous releases, AccuRev Plug-In was not always able to determine the status of packages and 
files within an element-link (elink) directory. This problem has been corrected in the current release.

29014 -- AccuRev Plug-In hangs the Eclipse Project Explorer
In previous releases some operations performed in the Project Explorer would cause Eclipse to hang. 
This problem has been corrected in the current release.

29309 -- AccuRev servers.xml moved to user’s home directory
In previous releases, AccuRev created the servers.xml file in the AccuRev \bin directory. This file 
contained server and session information, including the session security token. If the AccuRev Plug-In 
user did not have access to or permissions for the AccuRev \bin directory, the servers.xml file did not 
get created, AccuRev Plug-In would prompt the user to log in to AccuRev each time an operation 
required a call to the server. This problem has been corrected in the current release.

29341 -- Kept Status label added to available Label Decorations
In previous releases, the Kept Status label was not available on the Label Decorations page of the 
Preferences dialog box (Team > AccuRev > Label Decorations). This problem has been corrected in 
the current release.
The new label decoration for an element with Kept status is a white check on a blue background:

29431 -- Support for IBM RAD 8.5
AccuRev Plug-In 2013.3 supports IBM Rapid Application Development (RAD) 8.5.

29716 -- Support for Eclipse Mylyn
AccuRev Plug-In 2013.3 supports Eclipse Mylyn.
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Version 2013.2
This section describes changes to AccuRev Plug-In version 2013.2.

27592 -- New label decoration icons for AccuRev statuses
AccuRev Plug-In introduces new label decoration icons to represent AccuRev statuses. The new icons 
are larger, easier to read at a glance, and easier to understand. Changes to the status icons are 
summarized in the following table:

Default text label decorators remain unchanged.
28192 -- Procedures for setting up UTF-8 in Eclipse

The User’s Guide now includes a section on setting up UTF-8 in Eclipse. See Chapter 2, Working with 
Eclipse Projects for more information.

28207 -- New Quick Start page
The download page for AccuRev Plug-In has been enhanced to get you up and running with AccuRev 
Plug-In for Eclipse. The new Quick Start page provides:
• Direct access to the AccuRev update site URL and .zip download

• Simplified procedures that describe how to install, upgrade, and use AccuRev Plug-In to add an 
Eclipse project to AccuRev, share an Eclipse project with AccuRev, and create a new workspace 
based on an Eclipse project

The new AccuRev Plug-In for Eclipse Quick Start page is here:
http://www.accurev.com/customer-support-resources/downloads/integration-
packages/quickstart-accurev-plugin-eclipse

28356 -- New: Send to Issue, Remove from Issue operations available 
AccuRev Plug-In now provides support for Send to Issue and Remove from Issue operations. These 
operations support third-party ITS keys as well as AccuWork issue numbers and are available from the 
element context menu -- right-click the element, and choose Team > Send To Issue or Remove From 
Issue.

28819 -- Multiple projects on the same AccuRev Server no longer require multiple logins
In previous releases, if you had multiple Eclipse projects associated with AccuRev workspaces on the 
same AccuRev Server, AccuRev Plug-In would prompt you to log in for each project individually. 

Status Previous Releases Version 2013.2

Modified

Backed

Member

Missing

Stale

Overlap
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This problem has been corrected in the current release -- project and workspace information is now 
grouped for the same AccuRev Server requiring only a single login when the session expires or has not 
been established.

28970 -- Single AccuRev Plug-In for Eclipse for both Eclipse and IBM RAD
In previous releases, AccuRev provided separate AccuRev Plug-In packages for Eclipse and IBM 
Rapid Application Development (RAD), an Eclipse-based IDE. As of Version 2013.2, the AccuRev 
Plug-In for Eclipse can be used on both Eclipse and IBM RAD.

29323 -- Promote uses AccuRev session established in AccuRev Plug-In
In previous releases, the Promote operation did not use the AccuRev session created by logging in to 
AccuRev through AccuRev Plug-In. Because it relied on the AccuRev session established externally -
- through the command line or AccuRev Client GUI, for example -- the Promote operation would fail 
when that session expired. This problem has been corrected in the current release.

29401 -- Diff by Transaction fails in History Browser if you are not logged in to AccuRev 
through the AccuRev Plug-In

In previous releases, the Diff by Transaction operation would fail when run from the History Browser 
unless you were logged in to AccuRev through AccuRev Plug-In (and not through the command line 
or AccuRev Client GUI). This problem has been corrected in the current release.
In addition, AccuRev Plug-In now works with the Eclipse diff tool.

Version 2013.1
This section describes changes to AccuRev Plug-In version 2013.1.

27581 -- Stream names displayed in Merge From and Patch From views.
AccuRev Plug-In now displays stream names in Merge From and Patch From views. In previous 
releases, AccuRev Plug-In displayed stream numbers in these views.

27586, 27603 -- Support for RAD 6, 7, and 8
AccuRev Plug-In version 2013.1 supports IBM RAD 6, RAD 7, and RAD 8.

27601 -- Support for Eclipse 4.2 (Juno)
AccuRev Plug-In 2013.1 supports Eclipse 4.2 (Juno).

27621 -- New: Browse button added to AccuRev page in Preferences
AccuRev Plug-In version 2013.1 adds a Browse button to the AccuRev CLI field on the AccuRev 
page in the Preferences window (Window > Preferences). This button allows you to navigate to the 
location of the AccuRev executable and capture the path. In previous releases, the value for the for the 
AccuRev CLI field had to be entered manually.

27705 -- Synchronize view shows external objects
The Eclipse Synchronize view now shows objects (files and directories) that have not been kept in 
AccuRev. (Such objects have a status of (external) in AccuRev.) For example, when you create a new 
project, objects like the .settings directory and the .project file will be displayed on the Eclipse 
Synchronize view.
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27722 -- Support for elinked directories that are outside the Eclipse project
AccuRev Plug-In now allows you to create elinks in the Eclipse project hierarchy to resources that are 
under AccuRev control. In previous releases using AccuRev Plug-In with Eclipse 3.5 (Galileo) and 
earlier, AccuRev Plug-In would throw an error when opening Eclipse projects that used elinks in this 
fashion.

27751 -- Error in procedure for setting up a local update site
In previous releases, the procedure in the section "Setting Up a Local Update Site" in the Installation 
and Release Notes incorrectly referred to the update-site.zip. This problem has been corrected in the 
current release and now refers to the .zip file for the current release 
(AccuRevPlugIn_Eclipse_2013_2.zip, for example).

27755 -- Diff for elements and transactions now supported in the History view
The History view in AccuRev Plug-in version 2013.1 supports Diff functionality for both transactions 
and elements:
• You can right-click a transaction and choose Diff Against > Other Version or Diff Against > File 

in the Workspace.

• You can right-click an element associated with the current transaction and choose Diff Against > 
Previous Transaction.

27797 -- AccuRev Plug-In version number displayed in Eclipse Preferences
The version number of the currently installed AccuRev Plug-in is now displayed in Eclipse 
Preferences. To view the version number here, Window > Preferences. The new Version Details 
group box lists:
• Version: The currently installed version

• Date: The date this version was built

• Transaction: The AccuRev transaction number associated with the version’s build

Tip: AccuRev Plug-In version information is also available from the Help menu. Choose Help > 
About Eclipse SDK, and then click either the AccuRev icon or the Installation Details button on the 
About Eclipse SDK dialog box.

28042 -- AccuRev Plug-In promote sequence matches that in AccuRev GUI
In AccuRev Plug-In version 2013.1, if you have change packages implemented at your site, AccuRev 
Plug-In now prompts you to first select an issue to associate with the changes you are promoting and 
then enter an optional comment. In previous releases, AccuRev Plug-In prompted you for the comment 
before asking you to choose an issue to promote against.

28257 -- AccuRev Plug-In supports Eclipse 4.2 (Juno) on MacOS 10.7 (Lion)
AccuRev Plug-In now supports Eclipse 4.2 (Juno) installed on the MacOS 10.7 (Lion) operating 
system.
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