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Introduction

AccuRev Plug-In for Eclipse integrates AccuRev functionality with the Eclipse Platform IDE. This document
is your guide to installing AccuRev Plug-In for Eclipse. It is intended for the AccuRev system administrator.
This book provides information specific to this release, including notes on platform support, and a summary
of changes for the current and recent releases.

See the AccuRev Plug-In for Eclipse User’s Guide for information about using the AccuRev Plug-In for
Eclipse within the Eclipse environment.

For news on this product, visit Micro Focus SupportLine: https://supportline.microfocus.com/.

About this Document

This book assumes you are familiar with your operating system and its commands, as well as with
AccuRev and Eclipse. The remaining sections in this book tell you how to prepare for and install AccuRev
Plug-In for Eclipse and provide information on features, fixes, and known issues in the current and recent
releases.

Highlights of this Release

e Support for Eclipse Photon (4.8.x)

» Utilize existing AccuRev session in Eclipse

» Auto-detect AccuRev workspace project

« Check out existing workspace from a different workstation to local
e Change AccuRev plug-in log to user home directory

* Provide warnings in AccuRev if binary is missing

AccuRev Git Feature

Progress bar for AccuRev Git fetch, pull, and clone

4 | Introduction
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Installation

Before installing AccuRev Plug-In for Eclipse, ensure that you have an AccuRev client on the same
machine that is running Eclipse. See the Installation and Release Notes document for your version of

AccuRev for instructions on installing AccuRev.

Note: AccuRev Plug-In for Eclipse version 2010.1 and later provides access to the AccuRev Web UI.
For instructions on configuring this option, see Configuring Access to the AccuRev Web Interface.

Platform Support

The AccuRev Plug-In for Eclipse supports the following versions of Eclipse.

2018.3
2018.2
2018.1
2017.1
2016.1

2014.1
2013.5

We recommend Java 2 Runtime Environment 5.0 and higher. Versions 1.4.2 and higher are supported.

GIT Feature

The GIT Plug-In bundled in AccuRev Plug-In for Eclipse supports the following versions of Eclipse.
2018.3: 4.6.x, 4.7.x, 4.8.x

2018.2: 4.5.x, 4.6.x, 4.7.X

Pre-requisites:

1. Eclipse IDE must be updated with EGit-Git integrations for Eclipse from the marketplace. Even though
version 4.5.x and 4.6.x of Eclipse comes bundled with the dependencies of EGit-Git integrations, it is
required to have it updated.

2. AccuRev 7.2 client.

4.6.X, 4.7.X, 4.8.X.
4.5.X, 4.6.X, 4.7 X.
4.5.X, 4.6.X, 4.7 X.
4.4.X, 4.5.X, 4.6.X.
4.3.X, 4.4.X, 4.5.X.

3.7.x,4.2.X, 4.3.X.
3.6.x, 3.7.x, 4.2.X.

3. Git version 2.13.x and 2.14.x. AccuRev Git Client is incompatible with some recent Git releases. See the
Known issues section for more details.

Installing on Eclipse

Note: While the AccuRev Plug-In for Eclipse on Eclipse 3.5, 3.6, 3.7, and 4.x is the same as on
Eclipse 4.8.x, you must use the plug-in version matching the Eclipse version as specified in Platform
Support matrix.

Use the procedures described in this section to add the AccuRev update site to the Eclipse repository and

to install AccuRev Plug-In for Eclipse.

Installation
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Installation

Adding the AccuRev Update Site

AccuRev provides the standard plug-in installation method for the Eclipse IDE via an update site. If you
require offline or local network access to an update site for installing the plug-in, see Setting Up a Local

Update Site.

Otherwise, follow this procedure to add the AccuRev update site to the list of sites that Eclipse can contact:

1. Start the Eclipse IDE.

2. Select Help > Install New Software from the Eclipse menu. The first page of the Install New Software

wizard appears.

i & [nstall l | = |_ﬂh]1

Available Software

Select a site or enter the location of a site.

w

Work with:” » [ add.

Find rmore software by working with the "&vailable Software Sites” preferences.
type filter text
Mame Version

[ (@) Thereis no site selected.

1 | (1]

Select Al ] [ Deselect Al

3. Click Add. The Add Repository dialog box appeatrs.

= Add Repository e

Mame: | Local...
Location:  hittp://

@

4. Fill in the fields in the Add Repository dialog box:

Name Enter a unigue name for the AccuRev Plug-In.

Location Enter the URL of the AccuRev update site: htt p: // al t d. bor | and. com updat e/
accurev/ 2018. 3/site. xm

5. Click OK to add the AccuRev update site to the Eclipse repository.

6. To continue installing, go to Installing AccuRev Plug-In for Eclipse. If you want to install AccuRev Plug-In

for Eclipse at a later time, click Cancel to stop the Install New Software wizard.




Installing AccuRev Plug-In for Eclipse

Before you begin, add the AccuRev update site to the Eclipse repository if you have not done so already.
See Adding the AccuRev Update Site.

1.
2.

Start the Eclipse IDE.

Select Help > Install New Software from the Eclipse menu. The first page of the Install New Software
wizard appears.

Select the AccuRev Pl ug-In for Ecli pse site from the Work with list.

-

= Install l | =] |ﬂh
Awvailable Software
Check the iterns that you wish to install. |
Work with:  htte:##ald.borland. comAupdate/acourey /2017 1 - Add...

e

Find more software by working with the "&vailable Software Sites” preferences,

type filter text
Mame Version

4 000 AccuRev Plug-In for Eclipse

“J‘%g AccuRev Plug-In for Eclipse 2013.1.710773
4 1 3
| SelectAll | | Deselect Al 1 item selacted
Details

Show only the |atest versions of available software [T Hide iterns that are already installed
[¥] Group itemns by category What is already installed?

[V] Contact all update sites during install te find required software

£
'\‘?J,' < Back Mext = Finizh

Select the checkbox next to AccuRev Plug-In for Eclipse and click Next.
Click through the wizard to review the installation and to confirm the license agreement. Eclipse installs
AccuRev Plug-In for Eclipse.

Note: During installation, you might receive a security warning about unsigned content. Click OK
to acknowledge the warning and finish the installation.

When the installation finishes, Eclipse prompts you to restart the Eclipse IDE.

Click Restart Now to restart the Eclipse IDE and complete the installation. When you restart Eclipse, it
opens in the AccuRev perspective, as shown in the following illustration:

Installation
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[= AccuRey - Eclipse SDK | = | 5 i
File Edit 3Source Refactor Mavigate Search Project Bun Window Help

[Coor i vrecpoxde o4 @ »

- E0 Team Synchr...

L]
$-0-Q- FO- BIF- T -T-TC o~
|2 Package Explorer &1 T T}'ptHltrﬂTEh}: EE ¥ =08 = B |[{B Help =

= blitzPrag I .
17 eclipse_dioster Related Topics

- = H

Note: Buttons on the AccuRev toolbar are displayed as active only if you have selected a file in
the Package Explorer that has been added to AccuRev.

For AccuRev GIT Users

After installing the new 2018.3 eclipse plugin follow the steps below to clone from an AccuRev stream into
your Eclipse project.

1. Creating an Eclipse Git Project by Cloning from Existing AccuRev Stream.
2. Click on option ‘Clone a Git Repository’ option.

8 | Installation




& wsl - (it - kEchipse

File Edit Mavigate Search Project Run  Windew Help
= - 2=F | | G
21l Git Repositories 3 = B

CLONE A GIT REPOSITORY

[
Select one of the following to add a repository to this view:

) Add an existing local Git repository

o] Clone a Git repository,

._P Create a new local Git repository

3. Select ‘AccuRev’ as shown below and click Next.

Installation | 9



'@} Clone Git Repositary O *

Select Repository Source GIT
Select a location of Git Repositories = ] 4

type filter text

[7] Clone URI
a AccuRev

@' < Back Mext = Finish Cancel

4. Login window pops up. Add the new server if it is not added or continue login with valid username and
password and click OK.

Select the .
server wuﬁh Server % Click this &
follow
pe rform Server: calhost:5050 ~ | | i e
logi steps to
Dgln User Name: | | add new
Password: | | server.
=

5. After a successful Login, you will see the window below that has the ‘Select Depot’ option which you
can use to choose desired stream to be cloned. Upon selecting the depot, you will see the streams

10 | Installation



listed in the selected depot. Select the depot and select particular stream which has to be cloned into
Git repository and click Next button.

i@} Clone Git Repository O x

Source AccuRev Repository GIT

Enter the location of the source repository. — 4

Select a server

localhost: 5050 ~ | | Add Server

Select Depot

MyDepot ~

v MyDepot
w Streams
MyDep

URL | accurev://localhost:5050/MyDepot \i

Upon s
the vali

':?3' < Back Mext = Finish Cancel

6. Click Next,

Installation | 11
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i@) Clone Git Repository O x
Branch 5election GIT

Select branches to clone from remote repository. Remote tracking branches = 4
will be created to track updates for these branches in the remote repository.

Branches of accurev://localhost:3050/MyDepot:

type filter text

[] 5. master
Select All | | Dieselect All
@ < Back Next » Finish Cancel

7. Select the valid directory to create the Git repository and click Finish option.




@] Clone Git Repository O X

Local Destination GIT
Configure the local storage locabion for MyDepot. = =4
L Choose the
Destination
| . directory
Directory: Cih\Users\ad mln‘xgrl‘\hl}'ﬂtpotl OWWEE .
where git
Initial branch: | master = repo to be
[ Clone submodules created

Configuration

Remote name: | ofigin

Projects
N Import all existing Eclipse projects after clone finishes

Working sets
[1Add project te working sets Mew...

\forking sets Select...

Fry) =
k?,' < Back Mext = Cancel

8. Git repository will be created as shown below and now you can continue performing supported Git
operations.

Installation | 13



E ws1 - Git - Eclipse
File Edit Mavigate Search Project Run  Window Help

Jrﬁ'ﬂlh,a,ﬂﬁ@'?ﬂ & B g £ EX5§‘|QG*|%E%J‘
@Git Repositories 1 =

Blaed| ¢ s -
» [ MyDepot [master] - C\Users\admin'git\MyDepot\.git
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@ ws1 - Git - Eclipse
File Edit Mavigate Search Project Run  Window Help

oa) Git Repositonies &3 = "

E||E_-T_| | |_|H‘}'| w Q='=l,>| B &g &
w || MyDepot [master] - ChlsershadmintgittMyDepoti.git

g Branch &5 Switch To H
fﬁi Tags
(= Referer <1 Commit... Ctrl+#
[ Remote O3 Clean...
v = Workin Stashes H
= .git

= file ‘g~ Push to Upstream

& Fetch from Upstream
4 Push Branch 'master’...

@ Pull
are  Pull.,
Remote »
T Merge...
j&" Rebase...
a5 Heset...

gig Import Projects...
Show In Alt+5Shift+W »

Ml Collect Garbage

Remowve Repository from View

-

2L Delete Repository...
Add Submedule...

Copy Path to Clipboard Ctrl+C
Paste Repositors Path or LRI Ctrl+V

To Enable Logging

Navigate to WindowPreferencesTeamGit(AccuRev) to bring up the JGit (AccuRev) preferences window. If
the logs are enabled as shown below, it will create two logs named ‘Accurev_G td i ent _Log. | og’ and
‘Accurev_G t_Log. | og’in the specified directory. Logging is not enabled by default.

Installation | 15
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i8] Preferences O =

type filter text JGit (AccuRev) Prwr>
Help "
Install/Update Use these settings to specify the directory of the AccuRev JGit and Git client log files.
Java [~] Enable Logging
Java EE

Java Persistence Log file directory | Ch\Users\admin Browse
JavaScript
J5OM

Mawen

Mylyn
Oomph
Plug-in Development
Rermote Systerns
Run/Debug
Server
w Teamn
AccuRev
File Content
Git
Ignored Resources
1Git (AccuRey)
Models
Terminal
Validation
Web W

Py T Y

Restore Defaults Apply

Installing on Eclipse C/C++ Development Tooling (CDT)
Installations

Installation on Eclipse CDT 3.6 requires that you first install the Java Development Tools (JDT) 3.6.1 or
later. Once the JDT is installed, you can successfully install the AccuRev Plug-In for Eclipse.

To install the JDT on Eclipse CDT 3.6:
In Eclipse C++, select Help > Install New Software from the menu. The Install wizard appears.

In the filter field following the Work with field, type j ava. The table displays available Java plug-ins.
Select Ecl i pse Java Devel opnment Tool s.

Hpw DR

Click Next to complete the Eclipse Install wizard.

Installing on Wind River Workbench

Installation on Wind River Workbench requires that you first install the Java Development Tools (JDT) 3.6.1
or later.

To install the JDT on Wind River Workbench:




1. Select Window > Open Perspective > Advanced Device Development from the Workbench menu to
open the Advanced Device Development perspective.

Select Help > Install New Software from the Advanced Device Development perspective menu.
In the Preferences dialog box, select Install/Update > Available Software Sites.

Locate and select Eclipse Galileo Repository, click the Enable button, and then click OK.

In the Install dialog box, locate and select Ecl i pse Java Devel opnent Tool s.

o gk wD

Click Next to complete the Wind River Install wizard.

Verifying the Installation

To verify that the installation of AccuRev Plug-In for Eclipse was successful:

1. Start the Eclipse IDE.
2. Select Help > About Eclipse from the Eclipse menu.

3. Click Installation Details, and go to the Installed Software tab on the Eclipse SDK Installation
Details dialog box.

4. Verify that an AccuRev Pl ug-1n for Ecli pse entry exists.

Upgrading AccuRev Plug-In for Eclipse

1. Perform the steps for installing the AccuRev Plug-In for Eclipse.
2. Start Eclipse with the '-clean’ argument the first time, to clean the older plug-in cache.

Uninstalling AccuRev Plug-In for Eclipse

1. Start the Eclipse IDE.

2. Click Help > Installation Details and go to the Installed Software tab on the Eclipse Installation
Details dialog box.

3. Highlight the AccuRev Pl ug-1n for Eclipse entry.
4. Click the Uninstall... button.
Note: If this button is disabled, you manually installed an earlier version of the plug-in. Instead of

using this procedure, shut down the Eclipse IDE, then search for and delete files and folders in
your Ecl i pse installation directory that start with com accur ev. ecl i pse.

5. When the Uninstall window appears, verify that you want to uninstall the items shown, and click Finish
to uninstall the plug-in.

Setting Up a Local Update Site

If your organization’s IT policies do not allow regular Eclipse plug-in updates using a remote update site,
you can create an update site on your local network instead.

To create a local update site:

1. Create a directory on a network accessible machine called AccuRevPl ugl n_updat e or something
similar.

2. Using a web browser, access the AccuRev Plug-In download page: https://supportline.microfocus.com/
websync/productupdatessearch.aspx

3. Download the .ZIP file for the AccuRev Plug-In for Eclipse (AccuRevPl ugl n_Ecl i pse_201x_x. zi p,
for example) to the local AccuRevPI ugl n_updat e directory you created in Step 1.

4. Extract the .ZIP file contents to the AccuRevPI ugl n_updat e directory.

Installation
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5. Distribute the location of the AccuRev Pl ugl n_updat e directory to the AccuRev Plug-In for Eclipse
users in your organization. They can then define a new update site using the
AccuRevPl ugl n_updat e directory.

Configuring Access to the AccuRev Web U

Version 2013.1 and later of AccuRev Plug-In for Eclipse provides access to the AccuRev Web Ul. This
section describes how to configure the AccuRev Web Ul to work with Eclipse.

Features Available through the AccuRev Web Ul

When you configure access to the AccuRev Web Ul, you make the following features available to your
users:

e \ersion Browser.

e StreamBrowser.

¢ Annotate.

¢ Create New Issue.

* Open Issue Queries.

Before You Begin

Before performing the configuration procedure, obtain the URL used to access the AccuRev Web Ul. For
example, http: / /1 ocal host : 8080/ accur ev. You will need this URL to complete the configuration
procedure.

How to Configure the AccuRev Web Ul

To configure the AccuRev Web Ul to work with Eclipse, you need to modify the AccuRev Server
settings. xnl file as described in the following procedure:

1. Shut down Eclipse.
2. Create a file called set ti ngs. xm and add these lines:

<settings>
<webui wurl="http://webui-host: port/accurev"/>
</settings>

Where webui - host : port is the server name and port of the server hosting the AccuRev Web Ul --
| ocal host : 8080, for example.

3. Onthe AccuRev Server, save settings. xm inthe storage\site_slice\di spatch\config
directory where you installed AccuRev.

4. If you are using AccuRev replica servers, create and save setti ngs. xnl to the st or age
\'site_slice\di spat ch\confi g directories on those machines as well.

5. Restart Eclipse. Several new buttons appear on the AccuRev perspective toolbar as shown in the
following illustration:

= AccuRev - Eclipse SDK
File Edit Source Refactor Mavigate Search Project Bun Window Help

4 - B [ Bl AlE X Y| BEEH

The highlighted groups of buttons are for features that are accessible only after access to the AccuRev
Web Ul has been configured:

¢ Version Browser
¢ Annotate



e Open the Web Ul
¢ Open the StreamBrowser
e Create
* New Issue
e Open Issue Queries
6. Click the Open Web Ul button to start the AccuRev Web Ul within the Eclipse framework.

Note: If you are not already logged in to AccuRev, you are prompted to do so. See Logging In to
AccuRev in the AccuRev Plug-In for Eclipse User’'s Guide for more information.

Adding AccuRev Executables to the PATH (Apple Mac
OS X only)

To ensure that all AccuRev executables are on your system’s PATH, create the following files as sudo:

1. /etc/ pat hs. d/ AccuRev. For example:
sudo echo "/ Applications/ AccuRev/ bin" > /etc/paths. d/ AccuRev
2. /etc/ paths. d/ Acdi f f gui . For example:

sudo echo "/ Applications/ AccuRev/ bi n/ acdi f f gui . app/ Cont ent s/ MacOS" > /etc/
pat hs. d/ Acdi f f gui

3. /etc/ pat hs. d/ Acgui . For example:

sudo echo "/ Applications/ AccuRev/ bi n/ acgui . app/ Cont ent s/ MacCS" > /etc/
pat hs. d/ Acgui

Enabling the AccuRev Diff Tool to Work as a
Standalone (Apple Mac OS X Only)

To enable the AccuRev diff GUI tool (acdi f f gui ) to work stand-alone as well as from an IDE integration
such as Eclipse, do the following:

1. Make a backup copy of acdi f f gui :
cd / Applications/ AccuRev/ bi n/ acdi f f gui . app/ Cont ent s/ MacOS
mv acdi ffgui acdiffgui.orig
2. Create anew acdi f f gui file with the following content:
#!/ usr/ bi n/ perl
$cnd = "java -Duser.dir=/Applications/AccuRev/bin -Xnms32M - Xnx512M -
cl asspat h
\"/ Appl i cations/ AccuRev/ bin/oro.jar:/Applications/AccuRev/ bi n/
xerceslnpl .jar:/
Appl i cati ons/ AccuRev/ bi n/ xm -api s.jar:/Applications/AccuRev/bin/fwjar:/
Appl i cati ons/ AccuRev/ bi n/ wer ken. opt . jar:/ Applications/AccuRev/bin/diff.jar
\" diff.DiffApp ";
foreach $ar g( G\RGV)

{
$cmd .= "\"S$arg\" ";

}

system ($cmd) ;
3. Close any shells.
4. Open a new shell.

Running acdi f f gui should now bring up the AccuRev graphical diff tool, and it should also work from
within any integrated IDE.

Installation
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AccuRev Diff Tool Must be on Your PATH (Linux/UNIX
Only)

The Merge and Di ff Agai nst commands in the AccuRev perspective rely on access to the acdi f f gui
executable (which is part of the AccuRev product installation). If the acdi f f gui executable or a link to it is
not in your PATH and accessible by the currently logged-in user, these operations will fail silently.
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Release Notes

This section contains topics describing the changes for each release of AccuRev Plug-In for Eclipse.

Version 2018.3

AccuRev Features

1113643, 1113646 — Provide warning if AccuRev binary is not found in the configured location

In previous releases, if the configured path to AccuRev is missing, no information was conveyed to the
user. This has been fixed in current release. Now, if the configured AccuRev binary is not available, the
user is shown an error prompt when performing Eclipse AccuRev operations.

635767 - "Send to Issue" not working when sending multiple files to multiple issues

In previous releases, the user was not able to send multiple files to multiple issues. This has been fixed in
the current release.

636039 - Provide support for Eclipse Photon (4.8.x)

In this release, the AccuRev Plug-In for Eclipse supports Eclipse Photon (4.8.x). This version is backwards-
compatible with older Eclipse versions (4.2.2 and higher).

636040 - AccuRev Search/Status page icons are missing

In the previous release, the AccuRev Search/Status tab icons for Refresh & Pin were missing. They have
been restored in the current release.

636041 - Diff against Backed & File on Disk showing blank on Linux

In the previous release, sometimes AccuRev "Diff against Backed" and "Diff against File on Disk" didn't
display the contents properly. This has been fixed in the current release.

636042 - Auto-Detect AccuRev project

In previous releases, if an existing AccuRev workspace was imported into Eclipse, it was imported as a
non-AccuRev project. In the current release, if a user imports an existing workspace into Eclipse as a
normal project, it will get automatically mapped as an AccuRev project.

636043 - Unnecessary server calls when user tries to use AccuRev Sharing wizard

In previous releases, when the user tried to share an Eclipse project to AccuReyv, it resulted in a lot of
unnecessary calls to the AccuRev server, which can result in server latency. This has been fixed in the
current release.

636044 - Checkout existing workspace from different workstation to local

In previous releases, a user wasn't allowed to import changes from a workspace in a different system. This
has been fixed in the current release. Now the user can move workspaces from another machine to the
local machine, with last kept changes.
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635981 The Underlap search option on the AccuRev Search/Status page is missing

In the previous release, when user searches for "Underlap items" from the context menu, the AccuRev
Search/Status page didn’t show items in (underlap) status, and the Underlap search was missing from
search dropdown. This has been fixed in the current release.

636046 - Migrate Eclipse AccuRev session management from server.xml to system session

In previous releases, the Eclipse AccuRev plugin maintained its own AccuRev session information in the
servers. xm file. This has been changed in the current release. Now the plugin will utilize the existing
session created by the AccuRev client or GUI.

636047 - Move AccuRev plugin log to user home directory

In the previous release, the plug-in's log file, accur ev_pl ugi n. | og, used to be created in the Eclipse
install folder. This has been changed in the current release. Now the accur ev_pl ugi n. | og will be
created in the user home directory with the new name of accurev_ecli pse_pl ugin. | og

636049 - When sharing an Eclipse project with AccuRev, should perform Add action instead of
Promote

In the previous release, when the user finished sharing a new eclipse project with AccuRev, the promote
prompt was presented. In the current release, this has been changed to “Add to Depot.”

AccuRev Git Feature

636069 - Showing progress during cloning IDE for Git operations

In the current release, when a user clones the AccuRev GitClient stream, the progress bar will reflect the
fetch, pull and cloning status accordingly.

Known issues in the AccuRev Plug-In for Eclipse

« If upgrading from an older plug-in, the user may encounter some exceptions from the Eclipse core. The
upgrade doesn’t remove the older version plug-in .jars, which might cause plugin registration issues and
initialization errors. It is recommended to do run eclipse with the “-clean” argument after upgrading. If
this error still occurs, uninstall the plug-in and do a fresh install of the new plug-in.

« If a user creates Eclipse projects with .accurev in its parent/root directory, the project will get mapped as
an AccuRev project, even if it's not a valid AccuRev workspace. If the user wants, the user can un-share
the project from AccuRev context menu to convert it into a normal Eclipse project.

Version 2018.2

Release Notes

AccuRev Feature

« RPI# 1112342- ‘Annotate and Version Browser doesn't work in Eclipse plugin’ issue is fixed in this
release.

* RPI# 1114193 - ‘Annotate and Version Browser doesn't work in Eclipse plugin’ issue is fixed in this
release.

AccuRev Git Feature

Below Git functionality is supported in this Release:

* Clone
¢ Push



e Pull

* Fetch

* Merge

e Submodule: AccuRev supports git's submodules with the caveats: One the originating repo cloned from
AccuReyv, and secondly any submodules added come from native Git repos, and not back by AccuRev.
If you need to have multiple AccuRev streams, depots, as well as content from different AccuRev server
in your repo then use git's multiple remote functionality.

« Branch: Only local branches are supported. Branches from the local Git repo that have been merged to
the main branch will be reflected in AccuRev

Known Issues in AccuRev Git

Branches functionality supported with caveats

Commits in a local branch can be pushed to the remote master(AccuRev) by configuring the push option to
point to master(AccuRev stream) for that particular branch, or they can be merged into the local master
branch then pushed from the local master branch master(AccuRev stream) AccuRev Git is incompatible
with some recent Git releases A defect/regression that was introduced in Git version 2.15 results in merge
commits being skipped during a push operation. Because of this, the AccuRev Git Client is compatible with
Git 2.13 and 2.14, but incompatible with Git 2.15.x, 2.16.x, and 2.17.0. A fix has been submitted to the Git
community and will be released in an upcoming Git patch. Please contact Customer Care for the most up-
to-date information about Git versions that are compatible with the AccuRev Git Client.

AccuReyv Git Client is incompatible with pre-10.13 versions of macOS

The AccuRev Git Client supports macOS High Sierra 10.13 and higher.
Remote tags, back to the AccuRev server, are not supported at this time.

Working with multiple AccuRev servers/depots/streams in one Git repo [Remote Clone] is not
supported in Git plugin.

Cloning for a stream which has spaces in the name fails.

Create a Project > share > to Git repo > Commit / Push is not working.
Cloning happens only at the stream level.

Import Project with or without working Set option.

Clone to a folder with Non ASCII file name.

Moving files between folders in Eclipse, on Mac OS, push those to master (AccuRev stream) and
those files will be missing from AR stream.

Version 2018.1

1107251 - Provide support for Eclipse Oxygen (4.7.0, 4.7.1)

In this release, the AccuRev Plug-In for Eclipse supports Eclipse Oxygen 4.7.x. This version is backward
compatible with older Eclipse versions (4.2.2 and higher).
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1107521 - Eclipse: On Linux Extra dialog box when running update

In previous releases, when users ran an Updat e command from the AccuRev context menu, an extra
dialog box opened that would not get dismissed automatically. This has been fixed in the current release.

632156 - Update AccuRev Plug-In for Eclipse to use Eclipse SDK 4.4

The Eclipse SDK used by the AccuRev Plug-In for Eclipse has been updated to 4.4 for better compatibility
with the newer Eclipse versions.

632157 - Update plugin to use JRE8
The JRE used for building AccuRev Plug-In for Eclipse has been updated to JRES.

632158 - Unable to perform Send/Remove issue

In previous releases, when Send/Remove issue was performed, the user was presented with the CPK
query results aslongas CPK trigger was defined, otherwise an exception was thrown in the logs.
This has been fixed. Now, the user will be presented with results from the default query (as long as it is
defined), otherwise, an input prompt is shown.

632159 - Enable reading acclient.cnf based on ACCUREV_HOME in conjuction with AccuRev 7.1

AccuRev 7.1 now reads the accl i ent . cnf file based on the ACCUREV_HOVE environment variable or
home directory if ACCUREV_HOME is not set. Please see the AccuRev Installation and Release Notes
(Version 7.1) for details.

632161 - No default path in AccuRev Wizard provided while checking out from Stream

Sometimes, the AccuRev project wizard doesn't show the default path for an AccuRev workspace while
checking out a project from an AccuRev stream. This is fixed and now the workspace is provided from the
AccuRev client property | ast SavedWspacePat h.

632162 - Terminal windows showing up for each AccuRev operation on Linux

In previous releases, while performing AccuRev operations in Eclipse on Linux like Add, Keep, Pr onot e,
and Updat e, a terminal window would remain visible even after the operation is done. This has been fixed
in current release.

Version 2017.1

Release Notes

1105967 - Support for Eclipse Neon (4.6.0, 4.6.1 and 4.6.2)

In this release, the AccuRev Plug-In for Eclipse supports Eclipse Neon 4.6.x. This AccuRev Plug-In for
Eclipse is backward compatible with older Eclipse versions (4.2.2 and higher).

1104443 - AccuRev Plug-In for Eclipse Installation and Release Notes version 2016.1 have invalid
link

The AccuRev Plug-In for Eclipse Install Release Notes 2016.1 had a few invalid links in it, the links have
been corrected in this release.

1104442 - Local Eclipse 2016.1 update site not working

AccuRev Plug-In for Eclipse can be updated using a remote update site. This site is provided with an
archived .zip file for the AccuRev Plug-In for Eclipse. One of the steps for AccuRev Plug-In for Eclipse
update requires the user to download the .zip file, extract it and then install it. In the previous release,



the .zip file for the AccuRev Plug-In for Eclipse was not installable after extraction. This problem has been
rectified in the current release.

621568 - Import/New ‘Project from AccuReV’ dialog does not close correctly

In previous releases, an attempt to import projects using the AccuRev Project wizard, at times, caused
Eclipse to hang. This issue has been resolved in the current result.

619555 - Toolbar items are not activated for AccuRev resources

In previous releases, sometimes toolbar items would not get activated for AccuRev resources. This has
been fixed in the current release.

19428652 - Unable to perform Diff from Basis

In previous releases, it was not possible to perform the Diff operation from AccuRev context menu. This
has been fixed now.

19428651- Recursive promote from folder doesn't work

In previous releases, users could not perform recursive promote from top level folder. This can be
performed now.

Version 2016.1 Hot Fix 1

18874343 - Eclipse needs restart to show newly created Depots/WorkSpace

If a user created a new depot on AccuRev Client , the depot was not visible on Eclipse Share Project
Wizard without a restart. The issue has been resolved in this release. The user can create a new depot on
AccuRev Client and on Eclipse without restarting. Additionally, user can share a project on Share Project
Wizard and then select the required server and see the newly created depot.

19004294 - Depot list not refreshing while changing severs

While user tries to share a project from Eclipse to AccuRev, the Depot list does not refresh. On the Share
Project Wizard, if there are multiple servers added to the list and the user tries to switch from one to
another, the Select Depot list does not refresh. However, the Workspace list does refresh properly as
soon as the server details changed.

The issue has been resolved in this release. The Depot list refreshes as soon as user selects the required
server.

Version 2016.1

39212 - Support for Eclipse Mars 4.5.0 and 4.5.1

In this release, the AccuRev Plug-In for Eclipse supports Eclipse Mars 4.5.0 and 4.5.1 and has been fully
tested to work with older versions of Eclipse (4.2.2 and higher).

35257 (1096105) - AccuRev functions not active within Eclipse nested project

In previous releases, AccuRev functions were not active within an Eclipse nested project. This issue has
been corrected in the current release.
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Create Patch button is disabled while doing Select All

When creating a patch with Select All > CREATE, the Create Patch button is disabled. This issue has
been fixed in the current release.

Version 2015.1

36037 - Cannot import new files into Eclipse after upgrading the AccuRev Plug-In for Eclipse

In previous releases, the process of attempting to add a new project in Eclipse failed after upgrading the
AccuRev Plug-In for Eclipse. This problem has been corrected in the current release.

36439 - Creating a project in a new Eclipse workspace generates an exception

In previous releases, attempting to create a project in a new Eclipse workspace generated a
java. |l ang. Stri ngl ndexQut Of BoundsExcept i on error. This problem has been corrected in the
current release.

36968 - Multi-job performance has been improved

The Ecl i pse Jobs API has been implemented in the current release to automate job scheduling and
improve multi-job performance.

37038 - Error creating a Gradle project using the AccuRev Plug-In for Eclipse

The AccuRev New Project wizard currently supports Java and Gener al project types directly. Some
project types, such as Gr adl e, have unique name restrictions and perform post-processing, which is not
compatible with the AccuRev project creation process. If you experience problems when creating a new
AccuRev project and specifying the additional type choice, choose General > Project and, after the
process completes, right-click the project, choose Configure, and select the desired type.

Version 2014.1

27585 - New: The Login dialog is automatically populated with the correct server name

In previous releases, the Server field of the Login dialog box contained the name of the user’s default
server. Support has been added to automatically populate this field with the server name that is associated
with the currently selected Eclipse project.

27888 - Shared workspaces not recognized

In previous releases, AccuRev Plug-In for Eclipse did not recognize workspaces that are shared through a
UNC path or a mapped drive. This problem has been corrected in the current release.

29014 - Project Explorer hangs when AccuRev Plug-In for Eclipse is present

In previous releases, performing certain AccuRev operations in the Project Explorer view in Eclipse
caused the Project Explorer to hang and rendered Eclipse unresponsive. This problem has been
corrected in the current release.

29217 - Error encountered when promoting from the Team Synchronization perspective in Eclipse

In previous releases, attempting to perform a promote operation from the Team Synchronization
perspective in Eclipse produced the following error message: El enent i s not in default group.
This problem has been corrected in the current release.
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29227 - Eclipse restart required after switching from wireless to wired adapter

In previous releases, users who switched from a wireless to a wired adapter were required to log in to
AccuRev again, and Team options were unavailable until Eclipse was restarted. This problem has been
corrected in the current release.

29613 - Label decorations too large

In previous releases, the size of the label decorations (overlay icons) used by AccuRev Plug-In for Eclipse
was too large and sometimes hid Eclipse information. In the current release, the size of the overlay icons
has been reduced to 7x8 pixels, in accordance with Eclipse standards.

30782 - Promoting a file using AccuRev Plug-In for Eclipse requires an issue number

In previous releases, AccuRev Plug-In for Eclipse sometimes prompted users for issue humbers
unnecessarily during a promote operation. This problem has been corrected in the current release.

30848 - New: Ignored files now show status indicators when displayed within the AccuRev
perspective

In previous releases, the status of ignored files was not displayed in the AccuRev perspective of the
Package Explorer. To correct this problem, a new decorator icon has been added to indicate the ignored
status of files. In addition, the Add to Ignore option is now available only for (external) files and is disabled
for (member) files, the Add to AccuRev Depot option is nhow disabled for ( ext er nal ) (i gnor ed) files,
and a Remove from Ignore option has been added for (ext ernal ) (i gnor ed) files.

31022, 31329 - Status icons of directories in Eclipse do not correctly reflect status of files in the
directory

In previous releases, the directory icons in Eclipse indicated that the contents of the directory had changed
after a promote operation. This problem has been corrected in the current release.

32262 - Sharing an Eclipse project on a substituted drive causes a java exception

In previous releases, the AccuRev Plug-In for Eclipse produced a Nul | Poi nt er Excepti on if a user
created a substituted drive to the local workspace's parent directory, imported a Java project into the
workspace, and then selected Team > Share Project. This problem has been corrected in the current
release.

32305 - Login dialog not indicating incorrect port number for server

In previous releases, login would fail silently if an incorrect port number, such as 5050, was specified for
the server. An error message explaining the cause of the failure has been added in the current release.

32469 - Performing a Team > Share operation on a project in an existing AccuRev workspace
throws an exception

In previous releases, performing a Team > Share operation on an existing AccuRev workspace caused a
null pointer exception. This problem has been corrected in the current release.

32503 - Delay Workbench access until Plug-In is fully started

In previous releases, AccuRev Plug-In for Eclipse was allowing user access to the Eclipse Workbench
before the AccuRev Plug-In for Eclipse had fully started which, in some cases, caused slow performance or
threw processing exceptions when referenced objects were null. This problem has been corrected in the
current release.

Release Notes
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32614 - Issue list in the Synchronizing View in Eclipse not cleared upon completion of synchronize
operation

In previous releases, synchronizing Eclipse with AccuRev did not clear the stale files from the issue list in
the Synchronizing View . This problem has been corrected in the current release.

33021 - Cannot filter external files in the Synchronizing View perspective

In previous releases, users were not able to filter out external files in the Synchronizing View perspective
in Eclipse. In the Outgoing changes mode, having a large number of external files made it difficult for
users to view their changes. Two methods of filtering out external files from the Synchronizing View
perspective have been added in the current release:

* Designating the external items as i gnor ed hides these files from the Outgoing files list

* Using the Commit All option shows only modified files in the first page of the Commit All window and
only external files in the second page.

33681 - The Select Issue dialog box is empty during a promote operation

In previous releases, when a user performed a promote operation, it was possible for the Select Issue
dialog box to contain no issues. This problem has been corrected in the current release.

34199 - Creating a new Plug-In project in Eclipse produces an exception

In previous releases, attempting to create a Plug-In project in Eclipse usingAccuRev Plug-In for Eclipse
generated a Java exception error. This problem has been corrected in the current release.

Version 2013.5

Release Notes

31152 - The Promote dialog box appears unexpectedly

In previous releases, the Promote dialog box appeared unexpectedly when the user shared a project
under certain conditions, such as when the project status had been excluded or was external. This problem
has been corrected in the current release.

31081 - AccuRev Plug-In for Eclipse generates exceptions if the Eclipse workspace is unavailable

In previous releases, some users experienced problems when AccuRev Plug-In for Eclipse loaded and
attempted to access the Eclipse workspace before it became available. This problem has been corrected in
the current release.

31080 - Add to Ignore option fails to handle Japanese file names correctly

In previous releases, the Team > Add to Ignore option did not work correctly when file names contained
Japanese characters. This problem has been corrected in the current release.

31079 - Attempting to log on in Japanese produces extraneous characters

In previous releases, Japanese characters appeared twice when users attempted to log in using the Web
Ul in Eclipse. This problem has been corrected in the current release.

30914 - The FilteredEventReader produces an error with IBM’s JVM 6

In previous releases, using the Fi | t er edEvent Reader command with IBM’s implementation of JVM 6 in
version 8 of the IBM Rational Application Developer produced an error. This problem has been corrected in
the current release.



30843 - Debug information enhanced to track the servers.xml file

This release of AccuRev Plug-In for Eclipse contains additional debugging information related to the
servers. xm file for the purpose of tracking the location of this file.

30794 - Cannot promote changes if a pre-promote trigger exists

In previous releases, AccuRev Plug-In for Eclipse users were not able to promote changes when a pre-
promote trigger existed, except to the Default issue. This problem has been corrected in the current
release.

30780 - Cannot promote changes if the client dispatch promote trigger is not set

In previous releases, AccuRev Plug-In for Eclipse users could only promote changes to an issue if the
client dispatch promote trigger was set. This problem has been corrected in the current release.

30587 - The message.properties file contains duplicate entries

In previous releases, the following duplicated keys in the nessages. properti es file caused problems

with some third-party tools: LOG N, COMPARE_LABEL, | SSUES_COLUMN. These duplicated keys have been

eliminated and this problem has been corrected in the current release.

30394 - AccuRev Plug-In for Eclipse does not work with RAD 8.0.4

In previous releases, the AccuRev Plug-In for Eclipse did not work correctly with IBM Rational Application
Developer version 8.0.4. This problem has been corrected in the current release.

30236 - The Merge/Diff tool does not handle UTF-8 characters in the filename

In previous releases, the Merge/Diff tool would not start if a file name contained a UTF-8 character. This
problem has been corrected in the current release.

28779 - Using Mylyn with AccuWork

The AccuRev Plug-In for Eclipse now supports using Mylyn with AccuWork. For more information, see
Integration with Mylyn.

27590 - The Diff Against menu option should be moved away from Revert To option

In previous releases, the Diff Against > Backed Version menu option was adjacent to the Revert To >
Backed Version menu option. In the current release, the Diff Against Backed Version has been moved
adjacent to the Version Browser option.

Integration with Mylyn

AccuRev Plug-In for Eclipse supports an integration between AccuWork and Mylyn. The Mylyn Plug-In for
Eclipse manages user tasks. You can use the AccuRev Plug-In for Eclipse integration with Mylyn to
perform AccuWork procedures within the Eclipse interface, such as creating and managing AccuWork
queries and issues.

Note: The Mylyn Plug-In for Eclipse is not included when you install AccuRev Plug-In for Eclipse. If
you want to use the integration between AccuWork and Mylyn, you must separately install the Mylyn
Plug-In for Eclipse.

When you install AccuRev Plug-In for Eclipse version 2013.5 or later, the integration with Mylyn is
automatically active if the Mylyn Plug-In for Eclipse has been installed. The procedures described in the
following sections assume that you have installed the Mylyn Plug-In for Eclipse.

Release Notes
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Adding an AccuWork Task Repository

Before using the AccuRev Plug-In for Eclipse integration with Mylyn, you must add an AccuWork task
repository.

To add an AccuWork task repository:

1. In Eclipse, open the Mylyn view by selecting Window > Show View > Other > Mylyn > Task
Repositories. The Task Repositories tab is active.

2.
Click the Add Task Repaository button o . The Select a task repository type page of the Add Task
Repository wizard appears:

& Add Task Repository... l | =] |_i2_
Select a task repository type i
You can connect to an existing account using one of the installed connectors,

0 AccuWork Repository
& 'Bugzilla (supports 3.6 and later)
2 Gerrit Code Review (supports 24 and later)
a Mock Repository (for unit tests)
8 Trac (supports 0.12 and later through Web and XML-RPC)

’ & Install Maore Connectors...

< Back Next > T

3. Select the AccuWr k Reposi t ory option and click Next. The AccuWork Repository Settings page
of the Add Task Repository wizard appears:

e
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[ @ Add Task Repository.. |

=,

AccuWork Repository Settings -
Enter a valid server url, U
Server: *
Label: [] Disconnected

User ID:
Password: ] Save Password

b Task Editor Settings

[ % Validate Settings‘ | < Back Mext =

nisl Cancel

I
]
-

b

4. Specify the following:

Server

Label
Disconnected
User ID
Password

Save Password

Your AccuRev Server. The server information you enter should take the
following form: <ser ver _nane>: <port _nunber >.

Note: The server must be one of the AccuRev Servers that is already
available to you through the AccuRev Plug-In for Eclipse.

A name you designate for your AccuRev Server.

The default state of the AccuRev Server is disconnected.
Your AccuRev user name.

Your AccuRev password.

Indicates that you want Eclipse to remember your password between sessions.

Task Editor Settings Optional settings that specify the look and feel of the Task Editor.

5. Click Validate Settings to confirm the accuracy of the AccuRev Server settings.
6. Click Finish to apply the current settings and dismiss the dialog box.

Logging In to an AccuWork Task Repository

You must be connected to an AccuWork task repository before you can create and run AccuWork queries.

To log in to an AccuWork Task repository:

1. In Eclipse, open the Mylyn view by selecting Window > Show View > Other > Mylyn > Task
Repositories. The Task Repositories tab is active.

2. Right-click the name of your AccuRev Task repository and select Properties. The Properties for Task
Repository window appears:

Release Notes | 31



32

Release Notes

=,

[ @ Add Task Repository.. |

AccuWork Repository Settings -
Enter a valid server url, U
Server: *
Label: Disconnected

User ID:
Password: Save Password

b Task Editor Settings

Cancel

[ % Validate Settings | | < Back |

m

[
I

-]

-

b

Make sure your connection settings are valid.
3. Click Validate Settings to confirm the accuracy of the AccuRev Server settings.
4. Click Finish to validate the settings and log in.

Removing an AccuWork Task Repository from Your Mylyn View

If you are no longer using an AccuWork task repository, you can remove it from your Mylyn view. Note that
the following procedure only removes the repository from your view. The repository still exists and you can
reconnect to it at a later time. See Adding an AccuWork Task Repository for more information.

To remove an AccuWork task repository from your Mylyn view:

1. In Eclipse, open the Mylyn view by selecting Window > Show View > Other > Mylyn > Task
Repositories. The Task Repositories tab is active.

2. Right-click the name of the AccuWork task repository and select Delete.

Working with AccuWork Queries

The following sections contain information about creating, running, and editing AccuWork queries when
using Mylyn tasks.

Before running AccuWork queries in a Mylyn view, you must specify a default query in the AccuWork
Query Browser by right-clicking an existing query and selecting Set as Default from the context menu.

Note: The query results represent the AccuWork issues returned by both your Mylyn query and your
AccuWork default query.
Creating an AccuWork Query

You can create and run AccuWork queries from within your Eclipse development environment by using the
AccuRev Plug-In for Eclipse integration with Mylyn.



Note: Before running AccuWork queries in a Mylyn view, you must specify a default query in the
AccuWork Query Browser by right-clicking an existing query and selecting Set as Default from the

context menu.
To create an AccuWork query:

1. In Eclipse, open the Mylyn view by selecting Window > Show View > Other > Mylyn > Task List. The
Task List tab is active.

2. On the Mylyn Task List tab, click the New Task option list and select New Query. The New Query
dialog box appears:

r@ Mew Query I. (=] |i-“'h]1

-

Select a repository -
If a repository is missing it does not support the requested operation,

'1 Eclipse.org
ﬂ your_AccuRev_server

’ [f Add Task Repository... ] [ & Install More Connectors...

7"\ -
- < DackK i Finis ance
@ o [me] [ o

3. Select the name of your AccuRev Server and click Next. The Edit Query dialog box appears:
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[ 5@} Edit Query BN

Select query parameters

AccuWork search query parameters -

Query Title:

T}rpe:’ ,.]|:|Ir|c|uu:|e Completed

Gwner:’ ,] Depu:ut:[ -

Meut = Einish ] ’ Cancel

e

4. Specify settings in the Edit Query dialog box

Query Title A name for your new query.

Type The kind of query you want to construct, such as: defect, task, enhancement,
story, or requirement.

Include Indicates that you want the query to return defects, tasks, enhancements, stories,

Completed or requirements that have already been completed.

Owner The owner of the query. Typically, you would select your own user name, unless

you are assigning queries to other users.
Depot The name of the AccuRev depot that you are querying.

5. Click Finish. The new query appears in the Task List tab in your Mylyn view, followed by the name of
your AccuRev Server.

Editing an AccuWork Query
To edit an AccuWork query:
1. In Eclipse, open the Mylyn view by selecting Window > Show View > Other > Mylyn > Task List. The

Task List tab is active.

2. On the Mylyn Task List tab, right-click the name of the query and select Properties from the context
menu. The Edit Query dialog box appears:



[ 5@} Edit Query )

Select query parameters

AccuWork search query parameters =

Query Title:
T}fF'EI’ 1|I.]|:|Ir'|r:||_|rc:|v.=_- Completed
Owner: ’ ,] Depot: [ -

@

Next > Finish || Cancel

3. Change the settings to edit the query.
4. Click Finish to commit your changes.

Running an AccuWork Query
To run an AccuWork query in a Mylyn view:

1. In Eclipse, open the Mylyn view by selecting Window > Show View > Other > Mylyn > Task List. The
Task List tab is active.

2. Select the query you want to run and press Ent er , or double-click the name of the query. If the query
conditions are satisfied, the results of the query appear in the Mylyn Task List tab beneath the query:

B3 AccuRev C.. B8 AccuRevSe.. [ History £ Synchronize <" Search [E] TaskList i [fj) Task Reposi.. = B
Fr-iEelelxal9 ~
Find S|k AP Activate..

i g L queryl [your_AccuRev_server]
- B L queryd  [your_AccuRev_server]
- B L query?  [your_AccuRev_server]

3. You can open any item that is returned by your query by selecting the item and pressing Ent er or by
double-clicking the item. You can also right-click the item and select an option from the context menu to
perform a Mylyn task operation.
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Version 2013.4

30364, 30322 - Improvements to cut/copy/paste and delete/remove performance

In previous releases, performing cut/copy/paste and delete/remove operations on individual files took
longer than expected because AccuRev Plug-In for Eclipse was getting status on both the file's directory
and the workspace parent. This problem has been corrected in the current release, and AccuRev Plug-In
for Eclipse now performs required operations on individual files when appropriate.

30113 - Eclipse refresh no longer refreshes AccuRev status

In previous releases, refreshing a project using Eclipse (F5, File > Refresh, or choosing Refresh from the
context menu in the Project Explorer) caused AccuRev Plug-In for Eclipse to perform a full refresh of the
AccuRev statuses. This problem has been corrected in the current release, and AccuRev Plug-In for
Eclipse now performs a complete refresh of AccuRev statuses only when using the Team > Refresh >
Selected Projects (or All Projects) menu.

29957 - Improvements in elink management

In previous releases, AccuRev Plug-In for Eclipse did not properly manage multiple elinks with the same
target, which sometimes resulted in some elinks not getting refreshed. This problem has been corrected in
the current release.

29899 - AccuRev Plug-In for Eclipse no longer starts other jobs when refreshed

In previous releases, AccuRev Plug-In for Eclipse tried to resume dormant jobs started by other IDEs when
it was refreshed. This problem has been corrected in the current release.

27589 - Cannot promote without a default query

In previous releases, you could not promote changes against an issue unless you had defined a default
query.AccuRev Plug-In for Eclipse would display a dialog box which allowed you to promote against the
default issue only. This problem has been corrected in the current release, and you can now select an
issue number when promoting.

Version 2013.3

Release Notes

27587 - Add to Ignore

AccuRev Plug-In for Eclipse has a new feature, Team > Add to Ignore, that allows you to quickly specify
one or more files that you want AccuRev to ignore. To use this feature:

1. Locate the external files you want AccuRev to ignore (manually in the Package Explorer, or use Team
> AccuRev Searches > External, for example).

2. Select the files you want AccuRev to ignore.

3. Right-click, and choose Team > Add to Ignore.

AccuRev Plug-In for Eclipse creates a . aci gnor e file in that directory configured with the files you
selected. If a . aci gnor e file already exists in that directory, AccuRev Plug-In for Eclipse updates it with
the names of the files.

28170 - AccuRev Plug-In for Eclipse did not recognize existing workspaces after mapping drives

In previous releases, AccuRev Plug-In for Eclipse did not recognize existing workspaces if the location of
the workspace was specified using a mapped drive. For example, imagine creating a workspace at c:



\'accur ev\ my_wor kspaces\ acrne and then mapping c: \ accur ev\ my_wor kspaces to J: , so the
workspace path is now J: \ acre. If you subsequently tried to access the acne workspace through Eclipse
using J: \ acrre (to share or create a new project, for example), AccuRev Command Line Interface would
be unaware of the existing workspace. This problem has been corrected in the current release.

28745 - AccuRev Plug-In for Eclipse could not get status for element-link directory structures

In previous releases, AccuRev Command Line Interface was not always able to determine the status of
packages and files within an element-link (elink) directory. This problem has been corrected in the current
release.

29014 - AccuRev Plug-In for Eclipse hangs the Eclipse Project Explorer

In previous releases some operations performed in the Project Explorer would cause Eclipse to hang.
This problem has been corrected in the current release.

29309 - AccuRev servers.xml moved to user’s home directory

In previous releases, AccuRev created the ser vers. xm file in the AccuRev \ bi n directory. This file
contained server and session information, including the session security token. If the AccuRev Plug-In for
Eclipse user did not have access to or permissions for the AccuRev \ bi n directory, the servers. xnl file
did not get created, AccuRev Plug-In for Eclipse would prompt the user to log in to AccuRev each time an
operation required a call to the server. This problem has been corrected in the current release.

29341 - Kept Status label added to available Label Decorations

In previous releases, the Kept Status label was not available on the Label Decorations page of the
Preferences dialog box (Team > AccuRev > Label Decorations). This problem has been corrected in the
current release.

The new label decoration for an element with Kept status is a white check on a blue background.

Version 2013.2

This section describes changes to AccuRev Plug-In for Eclipse version 2013.2.
27592 - New label decoration icons for AccuRev statuses

AccuRev Plug-In for Eclipse introduces new label decoration icons to represent AccuRev statuses. The
new icons are larger, easier to read at a glance, and easier to understand. Changes to the status icons are
summarized in the following table:

Status Previous Releases Version 2013.2
Modified - a
Backed . ﬂ
Member 1 .
Missing b O
Stale 0
Overlap @
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Default text label decorators remain unchanged.

28192 - Procedures for setting up UTF-8 in Eclipse

The User’s Guide now includes a section on setting up UTF-8 in Eclipse. See Working with Eclipse
Projects for more information.

28207 - New Quick Start page

The download page for AccuRev Plug-In for Eclipse has been enhanced to get you up and running with
AccuRev Plug-In for Eclipse. The new Quick Start page provides:

» Direct access to the AccuRev update site URL and .zip download.

« Simplified procedures that describe how to install, upgrade, and use AccuRev Plug-In for Eclipse to add
an Eclipse project to AccuRev, share an Eclipse project with AccuRev, and create a new workspace
based on an Eclipse project.

28356 - New: Send to Issue, Remove from Issue operations available

AccuRev Plug-In for Eclipse now provides support for Send to Issue and Remove from Issue operations.
These operations support third-party ITS keys as well as AccuWork issue numbers and are available from

the element context menu, right-click the element, and choose Team > Send To Issue or Team > Remove
From Issue.

28819 - Multiple projects on the same AccuRev Server no longer require multiple logins

In previous releases, if you had multiple Eclipse projects associated with AccuRev workspaces on the
same AccuRev Server, AccuRev Plug-In for Eclipse would prompt you to log in for each project individually.

This problem has been corrected in the current release, project and workspace information is now grouped
for the same AccuRev Server requiring only a single login when the session expires or has not been
established.

28970 - Single Plug-In for both Eclipse and IBM RAD

In previous releases, AccuRev provided separate AccuRev Plug-In for Eclipse packages for Eclipse and
IBM Rapid Application Development (RAD), an Eclipse-based IDE. As of Version 2013.2, the AccuRev
Plug-In for Eclipse can be used on both Eclipse and IBM RAD.

29323 - Promote uses AccuRev session established in AccuRev Plug-In for Eclipse

In previous releases, the Pr onpt e operation did not use the AccuRev session created by logging in to
AccuRev through AccuRev Plug-In for Eclipse. Because it relied on the AccuRev session established
externally - through the AccuRev Command Line Interface or AccuRev Client, for example - the Promote
operation would fail when that session expired. This problem has been corrected in the current release.

29401 - Diff by Transaction fails in History Browser if you are not logged in to AccuRev through the

AccuRev Plug-In for Eclipse

In previous releases, the Diff by Transaction operation would fail when run from the History Browser
unless you were logged in to AccuRev through AccuRev Plug-In for Eclipse (and not through the AccuRev
Command Line Interface or AccuRev Client). This problem has been corrected in the current release.

In addition, AccuRev Plug-In for Eclipse now works with the Eclipse diff tool.

Version 2013.1

This section describes changes to AccuRev Plug-In for Eclipse version 2013.1.
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27581 - Stream names displayed in Merge From and Patch From views

AccuRev Plug-In for Eclipse now displays stream names in Merge From and Patch From views. In
previous releases, AccuRev Plug-In for Eclipse displayed stream numbers in these views.

27586, 27603 - Support for RAD 6, 7, and 8
AccuRev Plug-In for Eclipse version 2013.1 supports IBM RAD 6, RAD 7, and RAD 8.

27601 - Support for Eclipse 4.2 (Juno)
AccuRev Plug-In for Eclipse 2013.1 supports Eclipse 4.2 (Juno).

27621 - New: Browse button added to AccuRev page in Preferences

AccuRev Plug-In for Eclipse version 2013.1 adds a Browse button to the AccuRev CLI field on the
AccuRev page in the Preferences window (Window > Preferences). This button allows you to navigate to
the location of the AccuRev executable and capture the path. In previous releases, the value for the for the
AccuRev CLI field had to be entered manually.

27705 - Synchronize view shows external objects

The Eclipse Synchronize view now shows objects (files and directories) that have not been kept in
AccuRev. (Such objects have a status of ( ext er nal ) in AccuRev.) For example, when you create a new
project, objects like the . set t i ngs directory and the . pr oj ect file will be displayed on the Eclipse
Synchronize view.

27722 - Support for elinked directories that are outside the Eclipse project

AccuRev Plug-In for Eclipse now allows you to create elinks in the Eclipse project hierarchy to resources
that are under AccuRev control. In previous releases using AccuRev Plug-In for Eclipse with Eclipse 3.5
(Galileo) and earlier, AccuRev Plug-In for Eclipse would throw an error when opening Eclipse projects that
used elinks in this fashion.

27751 - Error in procedure for setting up a local update site

In previous releases, the procedure in the section Setting Up a Local Update Site in the this guide
incorrectly referred to the updat e- si t e. zi p. This problem has been corrected in the current release and
now refers to the .zip file for the current release (AccuRevPl ugl n_Ecl i pse_2013_2. zi p, for example).

27755 - Diff for elements and transactions now supported in the History view

The History view in AccuRev Plug-In for Eclipse version 2013.1 supports Diff functionality for both
transactions and elements:

* You can right-click a transaction and choose Diff Against > Other Version or Diff Against > File in the
Workspace.

* You can right-click an element associated with the current transaction and choose Diff Against >
Previous Transaction.

27797 - AccuRev Plug-In for Eclipse version number displayed in Eclipse Preferences

The version number of the currently installed AccuRev Plug-In for Eclipse is now displayed in Eclipse
Preferences. To view the version number here, Window > Preferences. The new Version Details group
box lists:

Version The currently installed version.

Date The date this version was built.
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Transaction The AccuRev transaction number associated with the version’s build.

| Tip: AccuRev Plug-In for Eclipse version information is also available from the Help menu. Choose
~  Help > About Eclipse SDK, and then click either the AccuRev icon or the Installation Details

button on the About Eclipse SDK dialog box.

28042 - AccuRev Plug-In for Eclipse promote sequence matches that in AccuRev GUI

In AccuRev Plug-In for Eclipse version 2013.1, if you have change packages implemented at your site,
AccuRev Plug-In for Eclipse how prompts you to first select an issue to associate with the changes you are
promoting and then enter an optional comment. In previous releases, AccuRev Plug-In for Eclipse
prompted you for the comment before asking you to choose an issue to promote against.

28257 - AccuRev Plug-In for Eclipse supports Eclipse 4.2 (Juno) on MacOS 10.7 (Lion)

AccuRev Plug-In for Eclipse now supports Eclipse 4.2 (Juno) installed on the MacOS 10.7 (Lion) operating
system.



Contacting Micro Focus

Micro Focus is committed to providing world-class technical support and consulting services. Micro Focus
provides worldwide support, delivering timely, reliable service to ensure every customer's business
success.

All customers who are under a maintenance and support contract, as well as prospective customers who
are evaluating products, are eligible for customer support. Our highly trained staff respond to your requests
as quickly and professionally as possible.

Visit http://supportline.microfocus.com/assistedservices.asp to communicate directly with Micro Focus
SupportLine to resolve your issues, or email supportline@microfocus.com.

Visit Micro Focus SupportLine at http://supportline.microfocus.com for up-to-date support news and access
to other support information. First time users may be required to register to the site.

Information Needed by Micro Focus SupportLine

When contacting Micro Focus SupportLine, please include the following information if possible. The more
information you can give, the better Micro Focus SupportLine can help you.

« The name and version number of all products that you think might be causing an issue.

e Your computer make and model.

« System information such as operating system name and version, processors, and memory details.
* Any detailed description of the issue, including steps to reproduce the issue.

» Exact wording of any error messages involved.

* Your serial number or works order (WO) number.

To find out these numbers, look in the subject line and body of your Electronic Product Delivery Notice
email that you received from Micro Focus, or on the box in which the product was supplied, and on the red
card supplied in the DVD case .
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