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Introduction

This book is your guide to installing the AccuRev Plug-In for Visual Studio PE. It is intended for AccuRev
and Visual Studio system administrators.

AccuRev Plug-In for Visual Studio PE is referred to as AccuRev Visual Studio Plug-In the Market Place.

What is AccuRev Plug-In for Visual Studio PE?

AccuRev Plug-In for Visual Studio PE is the integration between AccuRev and the following Visual Studio
products:

¢ Visual Studio 2013.
¢ Visual Studio 2015.
¢ Visual Studio 2017.

AccuRev Plug-In for Visual Studio PE supports all versions of these Visual Studio products except the
Express version.

AccuRev Plug-In for Visual Studio PE implements the SCC provider interfaces that are part of the Visual
Studio Package Technology (VSPT) instead of using the Microsoft Common Source Code Control Interface
(MCSCCI). This enables the integration to provide better access to AccuRev’s unique software
configuration management features.

Note: AccuRev Plug-In for Visual Studio PE is referred to as AccuRev Visual Studio Plug-in in the
Mar ket Pl ace.

Contacting Technical Support

Micro Focus offers a variety of options to meet your technical support needs as summarized in the

following

table.
For Visit
Information about technical support services http://supportline.microfocus.com/
Information about platforms support http://supportline.microfocus.com/prodavail.aspx
Product downloads and installations http://supportline.microfocus.com/websync/

productupdatessearch.aspx

Product documentation https://www.microfocus.com/documentation/accurev/
Micro Focus SupportLine phone numbers, listed by http://www.microfocus.com/about/contact/support/
country

When you contact technical support, please include the following information:

* The version of AccuRev and any other AccuRev products you are using (AccuSync or GitCentric, for
example).

* Your operating system.

e The version of the third-party software.

« A brief description of the problem you are experiencing, any error messages you received, what you
were doing when the error occurred, whether the problem is reproducible, and so on.
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» A description of any attempts you have made to resolve the issue.
* A simple assessment of how the issue affects your organization.

Highlights of this Release

AccuRev Plug-In for Visual Studio PE Version 2018.2 includes the following enhancements:

e Support for Send to Issue and Remove from Issue
« Logging configuration from AccuRev plugin option
« Automatic inclusion of acignore file into Visual Studio solution
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Installation Notes

This section describes how to install and configure AccuRev Plug-In for Visual Studio PE. It provides
information on system requirements and prerequisites. The procedure for installing AccuRev Plug-In for
Visual Studio PE are summarized in the following tables:

For plugin versions prior to 2017.1

1. Uninstall existing version of the AccuRev Plug-In for Visual Studio PE. See Uninstalling AccuRev Plug-
in for Visual Studio PE.

2. Download and install the AccuRev Plug-In for Visual Studio PE. See Downloading plug-in.
3. Configure the AccuRev Plug-In for Visual Studio PE as the source control plug-in. See Configuring

Visual Studio to Use AccuRev Plug-In.
For plugin version 2017.1 or later

1. Goto Tools > Extensions and Updates and click the Updates tab and select Product Updates >
AccuReyv Visual Studio Plugin then click Update.

2. Configure the AccuRev Plug-In for Visual Studio PE as the source control plug-in. See Configuring
Visual Studio to Use AccuRev Plug-In.

System Requirements

AccuRev Plug-In for Visual Studio PE is currently supported on the following operating systems:

* Microsoft Windows 10
* Microsoft Windows 8.1
* Microsoft Windows 7

Note: Micro Focus recommends that you install the appropriate operating system service packs
before installing AccuRev Plug-In for Visual Studio PE, for the plug-in to function perfectly.

Prerequisites

The following applications must be installed on your machine before you install the plug-In:

e AccuRev Version 6.2.0 or higher
* One of the following Microsoft Visual Studio products:

¢ Visual Studio 2013
¢ Visual Studio 2015
* Visual Studio 2017

Downloading plug-in

You can download the AccuRev Plug-In for Visual Studio PE from the Market Place or from the
Supportline.
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Downloading and Installing plug-in (from the Market
Place)

Note: The AccuRev Plug-In for Visual Studio PE is referred to as the AccuRev Visual Studio Plug-in
in the Mar ket Pl ace.

To download and install the AccuRev Plug-In for Visual Studio PE from the Market Place:

1.

w N

N o g &

Navigate to Visual Studio > Tools > Extensions and Updates. The Extension and Updates window
is displayed.
Click Online on the left panel of the Extension and Updates window.

In the Search Installed (Ctrl+E) field, type AccuRev, AccuRev Visual Studio Plug-In is listed in the
middle panel of the Extension and Updates window.

Click Downl oad, download begins.

Exit Visual Studio once the download is complete.

Select Modi fy in the VSI X. i nst al | er window.

Restart Visual Studio and select Yes in the User Account Control window.

Downloading and Installing plug-in (from the Supportline)

To download and install theAccuRev Plug-In for Visual Studio PE from the Micro Focus Supportline :

1.

a s~ DN

o

Navigate to the Micro Focus Supportline : http:/supportline.microfocus.com/websync/
productupdatessearch.aspx

Locate and download the ZIP file (.7z format) for this product.
Unpack the ZIP file (using 7-Zip application) to any location.
Close all open Visual Studio applications.

Execute the accpkgvsi nst al | er-2018. 2. vsi x file. VSIX Installer window will list the installed
Visual Studio versions (Professional and Enterprise editions only) compatible for the plug-in.

Select the required version(s) of Visual Studio and click | nst al | to proceed.

AccuRev Plug-In for Visual Studio PE is installed in the <Ext ensi ons> folder of selected Visual Studio
version(s).

Configuring Visual Studio to Use AccuRev Plug-In

1.

In Visual Studio, select Tools > Options to open the Options dialog box.

2. Expand the Source Control entry in the navigation pane and choose Plug-in Selection.

In the content pane, open the Current source control plug-in list and select AccuRev Plug-In for
Visual Studio PE.

4. Select Yes when prompted in the User Account Control window.

In the navigation pane, select AccuRev Options Page, select the Configuration tab in the content
pane and verify that the path to your accur ev. exe file in the AccuRev Executable field is accurate.
The path to the accur ev. exe file generally takes the following form: <accurev_i nstal | _dir>\bin
\'accurev. exe.

Click OK to save your selections and close the dialog.

Installation Notes
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When you have successfully configured Visual Studio PE to use AccuRev, the following changes
become apparent in the Visual Studio PE interface:

e The AccuRev - Searches window appears
* The AccuRev toolbar appears
¢ An AccuRev pane in the Output window is available

Uninstalling AccuRev Plug-In for Visual Studio PE

You can uninstall AccuRev Plug-In for Visual Studio PE in two ways :

To uninstall AccuRev Plug-In for Visual Studio PE (versions earlier than 2017.1):

1.
2. Press W ndows icon and the key R at the same time.

3.

4. Select AccuRev Plug-In for Visual Studio PE from the list of installed programs as appropriate and click

Close all instances of Microsoft Visual Studio.

Type appwi z. cpl in the Run window and click OK.

Uninstall.

To uninstall AccuRev Plug-In for Visual Studio PE from the Market Place:

1.

Navigate to Microsoft Visual Studio > Tools > Extensions and Updates .

The Extensions and updates window is displayed.

Click Installed on the left panel of the Extensions and Updates window.

Type AccuRev Plug-In for Visual Studi o PEinthe Search Installed (Ctrl+E) box. AccuRev
Plug-In for Visual Studio PEis displayed with an Uninstall button below.

Click Uninstall.

Close and exit Visual Studio

Multiple Versions of Visual Studio in the same system

You can install one or more versions of Visual Studio . Each time you must perform the following tasks:

1.
2.
3.

Download AccuRev Plug-In for Visual Studio PE
Install the plug-in
Configuring Visual Studio to use the plug-in

For more information, see Installation Notes
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Release Notes

This section describes new features and issues fixed in the current version. It also identifies known issues,
if any.

Version 2018.2

636584 - Send to Issue for solution items

In current release, user will be able to associate issues to Visual Studio solution items from the AccuRev
context menu.

636585 - Remove from Issue for solution items

In current release, user will be able to remove issues associated to Visual Studio solution items from the
AccuRev context menu.

636586 - Remove from Ignore for solution items

In current release, functionality is added to allow user to remove item in ignored status from the .acignore
file.

112329 - Issues with AccuRev 7.1 Web interface with VS Plugin

In previous release, when user did AccuRev Annotate or Version browser from Visual Studio, the
embedded browser used to throw "Browser version not supported”. This has been fixed in current release.

636595 - Update AccuRev icons

In previous release, old AccuRev icons used to show up intermittently for AccuRev prompts. This has been
fixed in current release.

636596 - Automatic include acignore in VS solution

In current release, if user creates/modifies .acignore file, by “Add to Ignore” or “Remove from Ignore”
action, it will automatically get added into the Visual Studio solution. This will enable user to

include .acignore file from AccuRev plugin itself. This functionality can be disabled from AccuRev plugin
settings.

632839 - Add Info & Debug logging capability

In current release, support for Info & Debug logging level has been added.

636597 - Provide option to set logging level from GUI

In previous release, logging level change could be done only by manually modifying configuration file. This
has been changed in current release. Now user can set various logging level from AccuRev plugin settings.

Release Notes | 9
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Version 2018.1

Release Notes

631940, 632830, 632838, 632833 - Fixes for Diff in Visual Studio

In the previous releases, the Diff functionality was not working as expected. In the current release, the fixes
include displaying proper version description and version number on Diff GUI. Additionally, Diff uses the file
in the workspace instead of copying it to temporary folder.

632832 - Add options to Diff with Beyond Compare V3 and V4

In the current release, Diff support for Beyond Compare V3 and V4 was added.

632831,632834 - Fixes for the Merge functionalities in Visual Studio

In previous releases, Merge and Update with merge functionalities were not working as expected. This has
been corrected in the current release, along with the display of version number for the merged files.

632829 - Product version update in AccuRev Options screen

In the current release, AccuRev Configuration page displays the latest plugin version.

632835 - Annotate functionality hitting invalid Web Ul URL

In previous releases, when user tried to use Annotate functionality in Visual Studio, an error may have
appeared stating "The webpage cannot be found.". This has been fixed in current release.

632837 — Removal of “New Query” functionality

In the current release, New Query option has been deprecated. Use the Web Ul options from the Visual
Studio AccuRev File menu.

632842 - AccuRev Web Ul showing unsupported Browser message

In previous releases, the plugin was unable to display Web Ul from the latest AccuRev version and
presented “Browser version not supported” message. This was due to limitations of the internal Visual
Studio browser. In the current release, the plugin addresses this by opening Web Ul tasks in the default
external browser. This is the default behavior, which can be toggled from the AccuRev plugin configuration.

632843 - Version browser option hitting invalid URL

In previous releases, if you tried to open Version browser for the solution file, it opened an invalid URL. This
has been fixed in the current release.

632844 - Cancel operation on login window lands on "New Workspace"

In previous releases, if you cancelled the login prompt while creating a new solution with Add to Source
Control option, the New Workspace page with blank depot and stream information displayed. This has
been fixed in the current release.

1112378 - Useless error message generated as a result of incorrect path

In previous releases, the error prompt for incorrect AccuRev path was not proper. This has been corrected
in the current release.



632845 - File getting added to Ignore list when AccuRev is logged out

In the previous release, if user was not logged in into AccuRev, the ignore option used to show up in the
AccuRev context menu. This has been fixed in current release.

634210 - Plugin dialogs displaying old AccuRev icons

In previous release, the plugin used to display older AccuRev icon set. This has been fixed in current
release, by using the icons from latest AccuRev version.

Version 2017.2

1109337 - Currently AccuRev Plug-In for Visual Studio PE does not work with Microsoft Visual
Studio 2017

AccuRev Plug-In for Visual Studio PE now supports Microsoft Visual Studio 2017.

1110953 (47232) - AccuRev Plug-In for Visual Studio PE fails to connect to AccuRev post multiple
installation and uninstallation

After AccuRev Plug-In for Visual Studio PE is installed and uninstalled multiple times, AccuRev Plug-In for
Visual Studio PE fails to connect with AccuRev preventing the AccuRev options from appearing in the
Microsoft Visual Studio GUI. This issue has been rectified now.

47584 - Implementation of acclient.cnf file related changes
AccuRev Plug-In for Visual Studio PE now implements the accl i ent . cnf changes in the same way as
AccuRev implements it.

1106219 (42847) - Installation of AccuRev Plug-In for Visual Studio PE failed on x64 bit machine

In previous release, AccuRev Plug-In for Visual Studio PE installed on x64 bit machine, looked for AccuRev
in a location where x32 bit version of AccuRev generally resides, hence the plug-in failed to detect
AccuRev, which caused the installation to fail. With the change in installer type (from .msi to .vsix), this
issue has been rectified and the plug-in now looks for AccuRev Plug-In for Visual Studio PE in the correct
location, which results into successful installation of the AccuRev Plug-In for Visual Studio PE.

47406 - AccuRev Plug-In for Visual Studio PE implements generation of Error Logs

Error logs are now generated for AccuRev Plug-In for Visual Studio PE error, making trouble shooting
easier.

Version 2017.1

41219 (1104461) - RFE AccuRev Plug-In for Visual Studio PE does not respect the Visual
Experience Color Theme

When using the dark color theme within Visual Studio, the sharp contrast presented by the AccuRev Plug-
In for Visual Studio PE screens may be distracting. The AccuRev Plug-In for Visual Studio PE now
respects the selected color theme.

41176 (1104401) - AccuRev Plug-In for Visual Studio PE 2016.1 with VS2015 - AC status icons not
being displayed in Visual Studio

There was a defect with the prior release of the AccuRev Plug-In for Visual Studio PE 2016.1 running with
Visual Studio 2015 where the AccuRev status icons were not properly displayed. This defect had no effect
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on the AccuRev commands as they still performed properly. However, the status icons were not displayed.
This has now been corrected.

41218 (1104459) - In the prior release of the AccuRev Plug-In for Visual Studio PE 2016.1 did not
work properly with the pending changes filter

In the prior release of the AccuRev Plug-In for Visual Studio PE 2016.1, users would see misleading
information where Visual Studio reported that all items have been filtered from view in the Solutions
Explorer tab. This would happen when the Pending Changes filter was turned on and AccuReyv files were
in a nodi fi ed state. The functionality expected has been taken care of with the help of a new AccuRev
option introduced in the GUI.

29580 (1103415) - AccuRev Plug-In for Visual Studio PE disappeared on any extension change

The AccuRev Plug-In for Visual Studio PE would disappear in Visual Studio 2012 if an extension was
installed. This has been rectified in this release.

Version 2016.1

Release Notes

32561 (1102978) - AccuRev Plug-In for Visual Studio PE not appearing after administrator installs
the plug-in

After the plugin was installed by a user with administrator privileges on a multi-user system with remote
desktop logins, a user from a remote desktop logged in to this machine and they had to run the installer
again to make it visible as a plug-in in Visual Studio. This issue has been resolved in the current release.

36935 (1098589) - Visual Studio right click menu, items are disabled that should be active

When using the right-click menu within the solution, many items appear grey when they should be active.
This doesn't appear when opening from Explore. This issue has been resolved in the current release.

39441 (1102890) - AccuRev Plug-In for Visual Studio PE installer fails to find Visual Studio

The AccuRev Plug-In for Visual Studio PE installer is not finding Visual Studio on the system, even though
it is installed. Is appears that the installer is looking for the wrong registry. This issue has been resolved in
the current release.

39653 - AccuRev Executable path available on AccuRev option Page by default

The AccuRev Executable path available on the AccuRev option page by default (Tools > Options >
Source Control) is not correct. This issue has been resolved in the current release.

39662 - Server details not displaying when logging in for the first time

Server IP addresses do not display in Login dialog box. The issue has been resolved in the current
release.

(1100817) - Support for Visual Studio 2015
With this release, AccuRev supports Visual Studio 2015.



Version 2014.3

28048 - Unable to add files to AccuRev that are in the Visual Studio solution but not in the project

In previous releases, if a file was in a AccuBridge for Visual Studio PE solution but not in a AccuBridge for
Visual Studio PE project that was under AccuRev source control, users were unable to add the file to
AccuRev source control. This problem has been fixed in the current release.

32653 - Performance degrades when promoting by issue

In previous releases, performance degraded when users attempted to promote by issue if the number of
issues returned by the AccuWork query that populates the Select Issue (Change Package) dialog box
was large (for example, 20,000 or more). This problem has been fixed in the current release.

33531 - Performance degrades when searching for modified files in large workspaces

In previous releases, the performance experienced by users who were searching for modified files in a
large workspace (> 1GB) was degraded in the AccuRev Plug-In for Visual Studio PE. This problem has
been fixed in the current release.

34651 - Restarting AccuBridge for Visual Studio PE required after changing to a wired adapter

In previous releases, users who switched from a wireless internet connection to a wired adapter had to
restart AccuBridge for Visual Studio PE. This problem has been fixed in the current release.

Version 2014.2

27625 - New: AccuRev Window options have been added to the Visual Studio View menu

The AccuRev Status, History, and Synchronize windows are now available in the Visual Studio View >
Other Windows menu options.

27756 - New: The ability to perform diff operations from an element history

When viewing the history of an element, users can select a transaction and perform a diff operation against
another version or against the version currently in the workspace.

33136 - Element link status in AccuRev becomes corrupt when the file is modified in Visual Studio

In previous releases, creating an element link (elink) to a file and then editing that file in Visual Studio
produced an elink status of ( backed) (el i nk) (corrupt ed) instead of (backed) (el i nk)
(rodi fi ed-target). This problem has been fixed in the current release.

33525 - New: The ability to perform keep and promote operations in the Workspace Explorer

Users can perform AccuRev keep and pr onot e operations from the Outgoing view of the AccuRev
Workspace Explorer.

33526 - New: The ability to promote non-overlapped files in the Stream Explorer

Users can perform AccuRev pr onot e operations from the AccuRev Stream Explorer on files that do not
have an Over | ap status.
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33569, 33587 - Unable to log in to AccuRev when using AccuRev Plug-In for Visual Studio PE
version 2014.1

After installing AccuRev Plug-In for Visual Studio PE version 2014.1, users could not successfully log in to
AccuRev. This problem has been fixed in the current release.

Version 2014.1

28297 - New: Open Visual Studio by double-clicking the .sln file

Users can launch Visual Studio from within the AccuRev GUI by double-clicking a Visual Studio solution
definition file (*. sl n).

32552 - New: Added support for log4net capabilities
Support for Apache log4net logging capabilities has been added in the current release.
To configure Apache log4net to log transactions between AccuRev and Visual Studio:

1. Navigate to the <AccuRev-i nstal | ati on-di r >\ bi n directory.
2. Open the App. confi g file and specify the log file location in the file value parameter, as shown in the
following example:
<appender nane="LogFi | eAppender"
type="1 og4net . Appender. Rol | i ngFi | eAppender " >
<file value="C:\ MyLog\ AccuRevLog. | og"/>
<appendToFi |l e val ue="true"/>
<rol lingStyl e val ue="Si ze"/ >
<maxSi zeRol | Backups val ue="5"/>
<mexi mun¥i | eSi ze val ue="10MB"/ >
<staticlLogFi |l eNane val ue="true"/>
<l ayout type="I| og4net. Layout. PatternLayout">
<conversionPattern value="% [%] %5p % %tmn"/>
</l ayout >
</ appender >

3. Import the following lines into a class:
usi ng | og4net. Confi g;

usi ng | og4net;
32555 - New: Open the file view for the current workspace

A new option called AccuRev Workspace Explorer has been added to the View menu. You can use the
Workspace Explorer option to view the folders and files in the current workspace in a tree view.

Version 2013.6

28544 - New: the Query Editor

A New Query icon has been added to the AccuRev tool bar. The New Query icon opens the Query
Editor. You can use the Query Editor to construct and run queries of AccuWork issues.

28545 - New: View files and versions associated with AccuWork issues

You can use the Query Editor to view files and versions associated with specific AccuWork issues that are
returned by AccuWork queries, and you can also perform diff operations on these files.
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28550 - Shelve AccuWork issues returned by queries

You can use the Query Editor to shelve AccuWork issues that are returned by AccuWork queries. To
shelve an issue means that changes you have made to files that are associated with the issue are purged
from your workspace.

28551 - Editing AccuWork issues returned by queries

You can use the Query Editor to edit AccuWork issues that are returned by AccuWork queries.

31832, 32057 - Support for Visual Studio 2013
AccuRev Plug-In for Visual Studio PE version 2013.6 supports Visual Studio 2013.

Version 2013.5

27947 - New: simplified process for adding a new project to a new AccuRev workspace

In previous releases, you could add new Visual Studio projects to AccuRev only if the project’s physical
location was in an existing AccuRev workspace. This is no longer required, and you can create a new
AccuRev workspace for new Visual Studio projects as described in the following procedure:

1. In Visual Studio, click File > New > Project.
2. In the New Project dialog box:

» Select the template you want to use to create the project.

* In the Name field, enter the project name. (Visual Studio uses this value for the Solution name, but
you can change that if you want.)

« If the Solution field is displayed, leave the value as Create new solution.

* Inthe Location field, optionally change where you want to create the AccuRev workspace for the
new project.

* Make sure the Add Solution to AccuRev check box is selected.
3. Click OK. The New Workspace wizard appears.

You use the first page of the New Workspace wizard to specify the depot and backing stream for the
new workspace, as well as whether or not you want to append the workspace name to its location.

4. Click Next to continue. The next page of the New Workspace wizard appears.

You use this page to specify the characteristics and initial content of the new workspace. By default, it
will contain all project files as well as all files from the AccuRev stream you chose as the basis stream. If
you want to choose specific directories and files from the basis stream, choose the Pick and choose
from basis stream option.

5. Click Finish. The new workspace is created with characteristics and content you specified.

27958 - New: ability to ignore directories and files in AccuRev

AccuRev allows you to exclude external files and directories from various operations to enhance
performance and reduce visual clutter. For example, if you never put program-generated executables under
AccuRev control, you can tell AccuRev to ignore such files. In AccuRev Plug-In for Visual Studio PE
Release 2013.5, you can specify the files and directories you want AccuReyv to ignore directly from the
Solution Explorer.

f Note: A directory or file must belong to the Visual Studio project before you can ignore it in AccuRev.

To specify directories and/or files you want AccuRev to ignore:

1. In Visual Studio, open the Solution Explorer.
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2. Choose the directories and/or files you want AccuRev to ignore.

Tip: Use Ctrl + cli ck to select multiple objects.
3. Right-click and choose AccuRev > Ignore in AccuRev from the shortcut menu.

A . aci gnor e file appears in the same directory as the file; if you selected a directory, the . aci gnor e
file appears in the parent directory.

28823 - New: improved usability for AccuRev Options Page
The AccuRev Options page (Tools > Options > Source Control > AccuRev Options Page) has been
reorganized to improve usability.

* The Web Ul tab has been renamed Conf i gur at i on to better reflect the broader range of settings and
information provided on the tab.

* In addition to existing configuration settings for the Web Ul, the Configuration tab also includes a new
field, AccuRev Executable, that lets you specify the path of the AccuRev executable. You can enter the
path manually, or use the Browse... button to navigate to the executable’s location. If this field is left
blank, AccuRev Plug-In for Visual Studio PE uses the value in your system PATH.

* Version Details information has moved from the General Options tab to the renamed Configuration
tab.

28869 - New: File View in the Depot Explorer

AccuRev Plug-In for Visual Studio PE Release 2013.3 introduced the Depot Explorer, a dockable window
that allows you to create and view a navigable list of depots. A new File View has been added to the
Depot Explorer for Release 2013.1 that displays the files associated with a selected stream or workspace.
To display the File View:

1. In the Depot Explorer, navigate to the stream or workspace whose files you wish to view.
2. Right click the stream or workspace, and choose Open File View from the shortcut menu.

The File View appears on a new tab in the Depot Explorer.

29472 - New: ability to add existing solutions and projects to AccuRev

You can now add an existing Visual Studio solution or project to AccuRev. Just right-click the solution or
project and choose AccuRev > Add to AccuRev. When you do, AccuRev starts the New Workspace
wizard, which lets you create a workspace using the solution or project name and lets you specify the
depot and basis stream for the workspace.

30048 - Refresh no longer required to see new workspaces in Depot Explorer

In the previous release, you needed to manually refresh the Depot Explorer in order to see newly created
workspaces. This problem has been corrected in the current release, and the Depot Explorer now
refreshes automatically.

Version 2013.4

Release Notes

28873 - Depot Explorer enhancements

The Depot Explorer, introduced in Release 2013.3, has been enhanced to support new functionality:

» Creating streams and workspaces.
e Changing streams.
« Reparenting streams and workspaces.

Note that depot explorer trees are not saved when you close Visual Studio.



Version 2013.3

28868 - New: Depot Explorer

The new Depot Explorer is a dockable window that allows you to create a read-only navigable list of
depots.

Version 2013.2

27626 - New method for working with solutions in AccuRev

The Open from AccuRev menu option is a quick and simple way to create a new AccuRev workspace on
your system for a solution that is already known to AccuRev. You might want to use this feature, for
example, so you can contribute to a solution being developed by a colleague who is developing the solution
in his or her own workspace. The Open from AccuRev command is available from the File > AccuRev
and File > New menus in Visual Studio.

27638 - AccuRev Plug-In for Visual Studio PE connects to AccuRev Server only when necessary

In previous releases, AccuRev Plug-In for Visual Studio PE attempted to connect to the AccuRev Server
when starting Visual Studio with an active AccuRev Plug-In for Visual Studio PE, even if there were no
solutions or projects open in Visual Studio. If your AccuRev Server was not accessible, this would appear
to cause Visual Studio to hang. This problem has been corrected in the current release, and AccuRev
Plug-In for Visual Studio PE attempts to connect to the AccuRev Server only when necessary.

29083 - Login menu choice removed after login

In previous releases, the Login menu (AccuRev > Login, for example) would remain displayed and
enabled even after successfully logging in to the AccuRev Server. This problem has been corrected in the
current release, and the AccuRev menu will now display Login or Logout as appropriate.

29144 - New label decorations for AccuRev statuses

AccuRev Plug-In for Visual Studio PE introduces new label decoration icons to represent AccuRev
statuses. The new icons are larger, easier to read, and easier to understand.

29306 - Login menu choice no longer requires a solution to be open

In previous releases, the Login menu (AccuRev > Login, for example) was available only if a solution was
already open in Visual Studio. As of this release, you can log in to AccuRev regardless of whether or not a
solution is open in Visual Studio.

Version 2013.1

27572 - Defunct action displayed on context menus

The Defunct action is now displayed on the context menu that is displayed when you right-click on
elements in a workspace.

Release Notes | 17
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Release Notes

27573 - Update and Update Preview button icons are different

In previous releases, users who customized the AccuReyV toolbar in Visual Studio discovered that the
same icon was used for both Update and Update Preview actions. This problem has been corrected in the
current release.

27574 - Output window cleared with each new AccuRev command

In previous releases, the Output window would collect all the AccuRev commands that were executed
during a session. Over time, the Output window could become cluttered, making it difficult to locate
relevant information. This problem has been corrected in the current release, and AccuRev Plug-In for
Visual Studio PE now clears the Output window each time a command is executed.

27576 - Support for third-party issue keys

AccuRev Plug-In for Visual Studio PE now supports the use of third-party issue tracking system keys. If
you have enabled change packages at your site, you can now specify third-party issue keys instead of
AccuWork issue numbers when promoting changes, for example.

27623 - AccuRev splash screen removed from setting source control preference

In previous releases, the AccuRev splash screen appeared after you selected AccuRev Plug-In on the
Plug-In Selections page of the Visual Studio Preferences dialog box. The AccuRev splash screen no
longer appears, and the option allowing you to hide the splash screen is no longer available.

27639 - Workspace information displayed in new dialog box

In previous AccuRev Plug-In for Visual Studio PE releases, choosing AccuRev > Workspace Information
from the context menu of a solution file displayed information in the Output window, which was easy to
overlook. Workspace information such as the AccuRev Server host name and version, and depot and
workspace name is now displayed in the AccuRev Workspace Information dialog box.

27645 - AccuRev Plug-In for Visual Studio PE promote sequence matches that in AccuRev GUI

In AccuRev Plug-In for Visual Studio PE version 2013.1, if you have change packages implemented at your
site, the plug-in now prompts you to first select an issue to associate with the changes you are promoting
and then enter an optional comment. In previous releases, it prompted you for the comment before asking
you to choose an issue to promote against.

27654 - Support for Visual Studio 2012
AccuRev Plug-In for Visual Studio PE version 2013.1 supports Visual Studio 2012.

27796 - Plug-In version number displayed in Visual Studio Options

The version number of the currently installed plug-in is now displayed on the General Options tab of the
AccuRev Options Page in the Visual Studio Options dialog box. To view the version number click, Tools
> Options > Source Control > AccuRev Options Page. The new Version Details group box lists:

¢ Version: The currently installed version
« Date: The date this version was built
« Transaction: The AccuRev transaction number associated with the version’s build

29923 - Support for Microsoft .NET Framework 4.0

AccuRev Plug-In for Visual Studio PE can now be installed on the Microsoft Windows machines running
Microsoft .NET Framework 4.0.



Known Issues for Visual Studio 2015

Files and Folder Decorators for AccuRev aren't available in Visual Studio 2015

IVisual Studio 2015 decorators have changed or have been broken. After you install AccuRev Plug-In for
Visual Studio PE, the decorators won't be visible

Known Issues in AccuRev Plug-In for Visual Studio PE

The following issue has been identified in AccuRev Plug-In for Visual Studio PE.

31104

In AccuRev 6.0 and 5.7, the executable for the AccuRev Diff tool, acdi f f gui . exe, did not list all of the jar
files needed to run the AccuRev Diff tool from within AccuRev Plug-In for Visual Studio PE. This prevented
users with AccuRev 6.0 or 5.7 from using the AccuRev Diff and Merge tools from AccuRev Plug-In for

Visual Studio PE. This problem has been corrected in AccuRev 6.0.1. If you recently upgraded to AccuRev

6.0, you should upgrade to 6.0.1. If you are using either 6.0 or 5.7 and do not plan to upgrade, contact
Micro Focus SupportLine.
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