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Overview T—

This guide gets you acquainted, quickly and easily, with AccuRev® — the new generation software

configuration management software with integrated issue management (AccuWork ") — from
AccuRey, Inc.

You will first learn how to populate a repository of files under AccuRev version control. You will then
go through typical Developer and Release Engineer experiences using AccuRev configuration
management, followed by setup of AccuWork, AccuRev’s integrated issue management system.

This guide does not attempt to provide exhaustive explanations of product features. For full details,
see the AccuRev documentation set, which you can download from Attp:/ /www.accurev.com. The
manuals are in PDF format, and can be viewed using Acrobat Reader. AccuRev’s graphical user
interface has a context-sensitive help system.

Before You Begin

Perform a full product installation (client and server) of AccuRev as described in the AccuRev
Installation and Release Notes prior to using this guide.

Getting Help

Your AccuReyv installation includes a complete set of user documentation (including this guide) and
online help. PDF and HTML documentation is installed in the \doc folder where you install

AccuRev. You can get online help at any time by pressing F1 or clicking the Help button ( © ) in the
AccuRev toolbar.

The support team at AccuRev, Inc. is also available to help you at any time as you get acquainted with
our software. So please e-mail us with any questions and/or comments at support@accurev.com.

Graphical Conventions

Throughout this guide, the > symbol denotes navigation in a menu, such as the main AccuRev menu,
or a context menu that you display by right-clicking an object in the AccuRev GUI display. For
example: Admin > Depots indicates that you should select the Admin menu and then select the
Depots command from the menu.

This guide omits some trivial steps, such as clicking the Ok or Close button in message or status
windows.

Getting Acquainted with AccuRev 1



Setting up AccuRev® | T—

In this section, you will use AccuRev’s “Quick Setup Wizard” for initial data setup. If you prefer the
do-it-yourself approach, using individual AccuRev commands, please follow the procedure in Initial
Setup without Using the Quick Setup Wizard on page 21.

Before You Begin

Use a file browser to find a directory that contains files that want to place under version control. The
directory you choose can have subdirectories. The data in these directories will not be modified — the
Wizard makes a copy of it. Note the pathname of this directory for use in the procedure, Using the
Quick Setup Wizard on page 4.

Starting the AccuRev® Graphical User Interface

To start AccuRev:

* Double-click the AccuRev shortcut () on your desktop, or
* Ina Command Prompt window, enter acgui

If this is the first time you are starting AccuRev, the AccuRev Quick Setup Wizard appears:

Quick Setup Wizard X

Welcome to the Quick Setup Wizard.
This wizard is intended to be used for initial setup of AccuRev.
It will talee you through the following steps:
A Create an AccuRev username and password

# Create a new depot to store everyone's work

2] Create a new warkspace to store your personal work
Optionally impart files into your workspace

1 Add initial files to the depot

At the end of the process everyone in your team will be able to use
the files from the depot.

<pack || Next> | | Cancel

Getting Acquainted with AccuRev 3



See Using the Quick Setup Wizard on page 4 for more information. Otherwise, see The Developer

Experience on page 5 to get started using AccuRev.

Using the Quick Setup Wizard

This section describes how to use the AccuRev Quick Setup Wizard to quickly get files under
AccuRev control.

1.

2
3.
4

In the Quick Setup Wizard click the Next button to start the wizard. Then:

Create an AccuRev username.

Create a new storage repository (depot).

Create a workspace for yourself, and copy data files to the workspace. Make these choices when
prompted by the wizard:

L]

Select Yes when asked “Do you have files that you would like to import into AccuRev?”
Select Yes when asked “Do you want to create a workspace in a new location ...?”

When prompted “Where are the files stored ...” specify the directory you chose in Before You
Begin on page 3.

Accept AccuRev’s suggestion for the location of the new workspace.

5. Add the files in your workspace to the depo by clicking Promote in the Promote window.

What Next?

After completing the initial setup, you can proceed to use any or all of the remaining three sections of
this guide:

L]

L]

The Developer Experience on page 5

The Release Engineer Experience on page 9

Issue Management with AcculWork™ on page 17

Getting Acquainted with AccuRev
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The Developer Experience =

The Developer experience includes accessing workspaces, creating new versions of files (edit/keep/
promote), updating workspaces, and merging two versions of a file.

Going to Your Workspace

Perform this step if your workspace is not already open in the AccuRev GUL
1. Select File > Open Workspace.

2. Select the workspace that you created in Step 4 in Using the Quick Setup Wizard on page 4.

All of the files in your workspace have a status of (backed). This means that you have not yet modified these

files.

Editing Your Source Files

1. If necessary, navigate through folders in the Folders pane (upper left); then select a file to edit.
2. Right-click and choose Edit from the context menu.

3. Make some changes to your source file.

4. Save the file, and close the editor.

You did not have to “check out” the file before editing it. The status of the file is now (modified).

Keeping Your Modified Files

The “Keep” operation is a “private checkin”. It makes a copy of your modified file in secure storage maintained by
the AccuRev Server process. It also records the creation of a new version of the file in the AccuRev database.
Keeping new versions in the workspace enables you to checkpoint and back up your own code, while preventing
your changes from being seen by other developers.

1. Select the file you modified.
2. Right-click and choose Keep from the context menu.
Enter a comment, and click Ok.

Note: The status of the file now includes the indicator (kept).

Sharinge Changes with the Rest of the Group

The “Promote” operation allows you to share your changed file with other users.
1. Select the file you just modified and kept.

2. Right-click and choose Promote from the context menu.

Getting Acquainted with AccuRev 5



3.

Enter a comment, and click Promote.

Promote makes the version that you created with “Keep” available to be copied into other users’ workspaces.
The status of the file is once again (backed).

Creating a Second Workspace

~

S Uk w b=

Select File > New > Workspace from the AccuRev main menu.

From the List of depots, select your depot.

As the Basis stream, select the stream with the same name as the depot.
Click Next.

As the Name of workspace to create, enter a new name (example: acme2).

As the Location for the new workspace, choose an existing directory (example: C:\Documents
and Settings\Derek or /usr/home/derek).

Make sure the Append workspace name to its location checkbox is checked.
Click Finish.

The new workspace is created, and Update is invoked to copy the files you placed under version control to the
workspace.

Working on Files in the Second Workspace

You can perform a search to list all the files that you are currently working on.

X 0 N o ok Wb

Select a text file to edit in your second workspace.
Right-Click Edit.

Make some changes to your text file.

Save the file, and close the editor.

Repeat steps 1-4 on one or more additional files.

Select the # Pending search in the Searches pane (lower-left).
Select the file(s) you modified.

Right-click a file and choose Keep from the context menu.

Select the same file(s).

10. Right-click and choose Promote from the context menu.

Switching Back to Your First Workspace

1. Click the tab in the GUI window that contains your first workspace.
If you have closed that tab, re-open the workspace using:
File > Open Workspace
6 Getting Acquainted with AccuRev



2.

Click the Update toolbar button.

t"l: Basis: hawk_dwt

ks
-2 Folders

{3 dac

E= m

This brings the changes you promoted while working in your second workspace into your first workspace.

Merging Two Versions of a File

S A

10.
11.

12.

In your first workspace, select a file to edit.

Right-click and choose Edit from the context menu.

Make some changes to your text file, save the file, and close the editor.
Select the file.

Right-click and choose Keep from the context menu.

Select the file.

Right-click and choose Promote from the context menu.

Switch to your second workspace, and click the edited file’s folder in the Folders pane. Don’t
perform an Update.

The file’s status now includes the indicator (stale).
Edit the same file in the second workspace.

The file’s status now includes the indicator (overlap). The yellow highlight emphasizes this status. This
means that someone else has promoted a version before you did. In this case, the “someone else” is you,
working in your first workspace. The file in your second workspace requires a merge before you can promote it.

Select the file.

Right-click and choose Merge from the context menu.

Proceed to merge the file, using the graphical Merge tool. Use the up (<% ) and down (< ) toolbar

buttons to navigate from conflict to conflict; use the left (%) and right ('L ) buttons to resolve the
current conflict by selecting text from one of the versions. You finish the Merge by preserving the
merged file, selecting Keep & Exit when all the conflicts have been resolved.

g All conflicts have been resolved

&ll conflicting changes have been resolved,

¥ou can Keep the result and Exit the Merge session now,
or o can return ko the Merge session to

Review and Edit the changes.,

Review ] [ Help ]

See the topic “The AccuRev Merge Tool” in the AccuRev online help (in your AccuRev install directory under
doc/ WebHelp / Merge_Tool_AccuRev.htm ).

Getting Acquainted with AccuRev



13. Select the file.
14. Right-Click Promote.
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The Release Engineer Experience =

The AccuRev experience for a Release Engineer or Quality Engineer includes working with the
StreamBrowser™, creating new streams and snapshots, comparing streams, and rearranging the
stream hierarchy.

Launching the StreamBrowser

The StreamBrowser allows you to easily see and control your development stream hierarchy graphically.
1. Select View > Streams from the AccuRev main menu.
2. Ifnecessary, select your depot from a list of depots in a pop-up window.

The StreamBrowser tab appears, showing the streams in your depot.

3. In the filter at the bottom of the StreamBrowser tab, make sure that All Workspaces or Current
User is selected in the drop-down field. These settings include your “private” workspace streams
in the display.

Currently, there’s only one "public" development stream: the depot’s “base stream” or “root stream”. It has
the same name as the depot.

Creating a Snapshot Stream to Capture the Current
State of Development

Select the depot’s base stream.

Right-click and select New Snapshot from the context menu.

1
2
3. Give the new snapshot a name (example: acme_1.0).
4. Leave the Basis Time set to Now.

5

Click Ok.

The newly created snapshot stream appears in the StreamBrowser.

Creating an Integration Stream Based on the Base
Stream

Now, rather than having to promote directly into the base stream you can promote to an integration stream below
the base stream.

1. Select the base stream.
2. Right-click and select New Stream from the context menu.

3. Give the new stream a name (example: acme_int).

Getting Acquainted with AccuRev 9



4. Leave the Stream Type set to Dynamic stream.
Leave the Basis Time set to None.

6. Click Ok.

The newly created integration stream appears in the StreamBrowser, as a direct “child” of the base stream.

Reparenting Your Workspaces

You can easily “reparent” your workspaces within the StreamBrowser, so that they are based on the integration
stream rather than the base stream (example: reparent them from acme to acme_int).

1. Drag-and-drop one of your workspaces onto the integration stream.
2. Drag-and-drop the other workspace onto the integration stream.

The StreamBrowser shows that your workspace streams are now based on the integration stream.

Updating Your Workspace

Execute the following steps for each workspace that you have just reparented. Work with different
files in the two workspaces.

1. Double-click the workspace to open it.

2. Click the Update toolbar button ( ¥ ).

An Update is always required after reparenting a workspace.
Select a file in your workspace.

Right-click and select Edit from the context menu.

Right-click and select Keep from the context menu.

AN N

Right-click and select Promote from the context menu.

This promotes the new version of the file to the integration stream. The process remains the same no matter
which stream the workspace is based on: > Edit; > Keep; > Promote.

7. (optional) Edit/Keep/Promote additional files.

Promoting Your Changes from the Integration
Stream to the Base Stream

1. Switch back to the StreamBrowser tab (example: k- acme).

2. Click the Show Active Files button (#2) under the integration stream (example: acme_int).

This opens a subwindow showing the files you just promoted to the integration stream.
3. Select all of the files.

4. Right-click and select Promote from the context menu.

The files have now been promoted from the integration stream to the base stream.

10 Getting Acquainted with AccuRev



Creating a Second Snapshot of the Base Stream

1
2
3.
4
5

Select the base stream.

Right-click and select New Snapshot from the context menu.
Give the second snapshot stream a name (example: acme_2.0).
Leave the Basis Time set to Now.

Click Ok.

The newly created snapshot stream appears in the StreamBrowser.

Comparing the Contents of the Two Snapshot

Streams

1. Select the first snapshot stream (example: acme_1.0).

2. Right-click and select Show Diff By Files from the context menu.
A “show difference” icon is added to the mouse pointer.

3. Click on the second snapshot stream (example: acme_2.0).

A list appears, containing the files you promoted above.

Observing the Differences Between Snapshots at the
Individual File Level

1.
2.

Select a file from the differences list you just generated.

Right-click and select Show Difference from the context menu.

Seeing Inheritance in the Stream Hierarchy

1.
2.

Go to the StreamBrowser tab (example: T acme).

Drag-and-drop one workspace from its current parent, the integration stream, to the base stream.
(Leave the other workspace under the integration stream.)

Double-click the workspace you just “reparented” to open it, then click the Update toolbar button
(%)

Note the version-ID of some file in the workspace (example: acme/1). The direction of the
separator character varies with the operating system.

Modify that file (right-click and choose Edit from the context menu).
Select the same file, then right-click and choose Promote from the context menu.
This is a shortcut—the Promote command in the GUI performs an automatic Keep on the modified file.

Switch back to the StreamBrowser tab.

Getting Acquainted with AccuRev 11



10.
11.

12.
13.

14.

Double-click the base stream to open it, then navigate to the file that you just promoted.
Note the new version of the file in the stream (example: acme/2).
Switch back to the StreamBrowser tab.

Double-click the integration stream to open it, then navigate to the file that you just promoted to
the base stream.

The version of the file in the integration stream (example: acme/2) is the same as the version in the base
stream. This version has been automatically inherited from the base stream.

Switch back to the StreamBrowser tab.

Double-click the second workspace (the one that is still under the integration stream) to open it,
and navigate to the same file.

The version-ID of the file in this workspace is not the same as in its parent, the integration stream. This fact is
reflected in the file’s (stale) status indicator. Inheritance by workspaces is not automatic, but occurs only when
you Update the workspace.

Click the Update toolbar button ( ¥ ).

The same file version (example: acme/2) has now been loaded into the workspace. The file’s status no longer
includes the (stale) indicator.

Using a Basis Time to Block Inheritance

1. Go to the StreamBrowser tab (example: = acme).

2. Select the integration stream.

3. Right-click and select Change Stream from the context menu.

4. Select a Basis Time of Now, then click Ok.

5. Double-click the workspace below the base stream to open it.

6. Modify a file in the workspace (right-click and select Edit from the context menu).

7. Select the same file, then right-click and select Promote from the context menu.

8. Switch back to the StreamBrowser tab.

9. Double-click the base stream to open it, then navigate to the file that you just promoted.
Note the version of the file in the stream (example: acme/ 3).

10. Switch back to the StreamBrowser tab.

11. Double-click the integration stream to open it, then navigate to the file that you just promoted to
the base stream.
The version of the file in the integration stream is not the same as the version in the base stream. The basis
time prevents automatic inheritance from the base stream.

12. Switch back to the StreamBrowser tab.

13. Double-click the workspace below the integration stream to open it.

12 Getting Acquainted with AccuRev



14.

15.
16.
17.
18.
19.

20.

Click the Update toolbar button ( # ). Then click View Full Log.

No new file versions are loaded into the workspace.

Switch back to the StreamBrowser tab.

Select the integration stream.

Right-click then select Change Stream from the context menu.

Select a Basis Time of None (cancelling the basis time setting), then click OKk.

Double-click the integration stream to open it, then navigate to the file that you just promoted to
the base stream.

The version of the file in the integration stream (example: acme/8) is the same as the version in the base
stream. As soon as the basis time is removed from the integration stream, it inherits the new file version from
the base stream.

Double-click the workspace below the integration stream, then click the Update toolbar button
( % ). Then click View Full Log.

The new file version is loaded into the workspace.

Viewing the History of a Stream

1
2
3.
4

“

Go to the StreamBrowser tab (example: & acme).

Select the base stream.

Right-click then select Show History from the context menu.

Select the most recent promote transaction.

The file versions involved in the transaction appear in the bottom pane of the History Browser.
Experiment with changing the transaction range, searching for a comment string, etc.

Locate the oldest promote transaction, and note the timestamp for use in the next operation.

Using a Time-based Stream to Reproduce a Previous
Configuration

1
2
3.
4
5

Go to the StreamBrowser tab (example: T acme).

Select the base stream.

Right-click then select New Stream from the context menu.
Specify the stream name (example: acme_old_config).

Specify the basis time by clicking the Specified radio button, then entering a time just after that of
the base stream’s first promote transaction (the time you noted above). Then click Ok.

Drag-and-drop the workspace from the integration stream to the newly created stream.

Getting Acquainted with AccuRev
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7. Double-click the workspace to open it, then click the Update toolbar button ( % ). Then click
View Full Log.

Older versions of files are loaded into the workspace.

8. Drag-and-drop the workspace from the newly created stream back to the integration stream.

9. Double-click the workspace to open it, then click the Update toolbar button ( ¥ ).

Newer versions of files are loaded into the workspace.

Making Fixes to a Previous Release

Go to the StreamBrowser tab (example: T acme).
Select the second snapshot created (example: acme_2.0).

1

2

3. Right-click then select New Stream from the context menu.

4. Enter a name for the new maintenance stream (example: acme_2.0_maint) and click Ok.
5

Drag-and-drop the workspace from the base stream to the new maintenance stream.

6. Double-click the workspace to open it, then click the Update toolbar button ( ¥ ).

Modify some files in the workspace.

8. Select the # madfied search in the Searches pane.

All files in the workspace with (modified) status appear in the Details pane.
9. Select all the modified files.
10. Right-click then select Promote from the context menu.

11. Switch back to the StreamBrowser tab.
A default group icon 52 appears below the new maintenance stream.

12. Click the g button to display the versions that were promoted to the maintenance stream.

13. Click the icon again to close this display.

Promoting Changes from the Maintenance Stream to
the Integration Stream

1. Drag-and-drop the #& icon below the maintenance stream to the integration stream.
A Change Palette tab opens.

2. If any files in the Change Palette have (overlap) status (yellow highlight), select them and right-
click and select Merge from the context menu. Click Ok in the pop-up window.

Proceed to merge the files, using the graphical Merge tool (just as in Merging Two Versions of a File
on page 7).

14 Getting Acquainted with AccuRev



3. Select all the files in the Change Palette tab, and right-click and select Promote from the context
menu.

If you merged one or more files, they are displayed in a separate pane at the bottom of the Change Palette tab.
You must Promote these files separately from the files in the upper pane, which did not need to be merged.

4. Close the Change Palette tab.

5. Once again, drag-and-drop the 28 icon the maintenance stream to the integration stream.

No files are displayed in the Change Palette tab, showing that all the changes in the maintenance stream have
already been promoted to the integration stream.

6. Close the Change Palette tab.

Getting Acquainted with AccuRev 15
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Issue Management with =
AccuWork™

The AccuWork experience includes setting up an issues database format (‘“schema’), creating issue
records, querying the issues database, and using the “change package” integration between
configuration management and issue management.

Setting up the Default Schema

1.
2.
3.
4.
5.

Select Admin > Schema Editor from the AccuRev main toolbar.

If necessary, select your depot from a list of depots in a pop-up window.
Click Yes ("Do you want to use the default schema?”).

Click Ok (“Please note ...).

Click Save (lower right-corner of Schema Editor tab).

Creating a Few New Issues

1.
2.

AR

Select Issues > New Issue from the AccuRev main toolbar.
Enter data in all of the required fields (red labels).

Experiment with how the different types of fields manage various types of data.

Click the Save and Close button ( *'x ) to save the issue record and close the tab.

Repeat this process a few times so you have a few issues to work with.

Creating a Query and Making it Your Default Query

1.
2.

w

NS Uk

Select Issues > Queries from the AccuRev main toolbar.

Click the New Query button ( []) to create an empty new query.

Give your query a name by clicking its name "New Query 1" twice (with a short pause in
between) and then typing the name (for example, All Defects).

Click Click here to add....
Set the first choice box value to issueNum.
Set the second choice box value to greater than or equal to.

Enter the number 1 in the third query box.

Getting Acquainted with AccuRev 17



8. Click Ok.

The name of the new query appears in the left (Query List) pane, which lists all the queries that you have
created. The right (Query Results) pane shows the results of running the query against the issues database.

9. Inthe Query List pane, with the query you just created ...right-click and select Set as Default
from the context menu.

10. Click the Setup Columns button (5% ) in the Query Results pane.
11. Select additional fields to appear in the Query Results pane:
a. Select a field from the Available list (Example: shortDescription).
b. Click the right-arrow button (}») to move the field to the Selected list.
c. Repeat the steps above for all of the fields you wish to add to the query results output.
d. Click Ok.

12. Click the Save All Queries button ( '=' ) above the left pane to save your query.
13. Close the query tab.
14. Reopen a query tab by selecting Issues > Queries from the AccuRev main toolbar.

The query you just created runs automatically, because you set it as your default query.

Enabling the Built-in Integration Between AccuRev
Configuration Management and AccuWork Issue
Management

1. Select Admin > Schema Editor from the AccuRev main menu (or return to the existing Schema
Editor tab).
2. Go to the Change Packages tab.

In the Change Package Results section (top part), click the Setup Columns button (5%).

4. Select some fields from the Available list (Example: issueNum, shortDescription), and click the
right-arrow button (}) to move the fields to the Selected list.

5. Click Ok.

6. Inthe Change Package Triggers section (bottom part), click New Trigger button ([ ) in the
toolbar.

A new window opens, in which you specify a condition, along with a query to be performed if that condition
is satisfied when the integration is invoked.

7. In the Condition section (top part), click Click here to add....
8. Use the three choice boxes to form this condition:
PROMOTE_DEST_STREAM is in hierarchy <depot>.
... where <depot> is the name of your depot.

9. In the Query section (bottom part), click Click here to add....
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10.

11.
12.
13.
14.
15.

16.
17.
18.

19.

Use the choice boxes and the text field to form this condition:
issueNum greater than 0

This query selects all issue records.

Click Ok.

Click Save (lower right-corner of Schema Editor tab).

Open a workspace (or go to one that is already open).

Edit and Keep several files.

Promote all those files.

The integration evaluates the condition you defined in Step 8 (it is TRUE), then runs the query you defined
in Step10. The selected records are presented as a list of issues to choose from.

Select the issue that you want to associate the promoted files with, and click Ok.
Select Issues > Look Up from the AccuRev main menu.

Enter the number of the issue you chose when prompted by the integration (Step 16), and click
Ok.

The issue appears in an edit form.
(Go to the Changes tab.

The files that you promoted are listed on this tab. The specific versions that you promoted are listed in the
Version column.

Turning Off the Integration Between Configuration
Management and Issue Management

1.

Select Admin > Schema Editor from the AccuRev main menu (or return to the existing Schema
Editor tab)

In the Change Packages tab, click the condition/query pair to select it.
Click the Delete Trigger button ().
Click Save (lower right-corner of Schema Editor tab).

With no query to be invoked at Promote time, the integration is effectively disabled.
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I |
Initial Setup without Using =
the Quick Setup Wizard

Create an AccuRev Username and Password

1.

A e B

Select Admin > Security from the AccuRev main menu.

Click the Add User button ( %) to create a new user.
Enter a username, but do not enter the optional password.
Click Ok.

Select Tools > Login from the AccuRev main menu.

Select your newly created user.

Click Ok.

Create a New Storage Depot

1.
2.
3.

Select File > New > Depot from the AccuRev main menu.
Give the depot a name (example: widget).

Click Ok (and continue to the next operation).

Create a Workspace to Store Your Work

© N kW

Click Yes (“Do you want to create a workspace for the depot?”).

Click Next to select your newly created depot, and the stream that has the same name as the
depot.

Click Next to accept the default name for the workspace.

Click Next to accept defaults for the new workspace.

Choose a physical location for the workspace (example: C:\ws\widget).
Click Next.

Select the pathname you prefer from the two pathnames offered.

Click Finish.

Import Files into Your Workspace

Use operating system commands to copy some sample files into workspace. For example:
xcopy /E /Y c:\myfiles\src\* c:\ws\acme)
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Add the Files in Your Workspace to the Depot

If your newly created workspace is not already open in the AccuRev GUI, open it by selecting
File > Open Workspace from the AccuRev main menu.

1. Select the External Search button (# External ) in the Searches pane (lower-left).
2. Select one of the files in the search results.
3. Select Edit > Select All from the AccuRev main menu.
4. Right-click then select Add to Depot from the context menu.
5. (optional) Enter a comment string.
6. Click Ok.
7. Select the Pending filter.
8. As above, select all the files listed in the details pane.
9. Right-click then select Promote from the context menu.
10. (optional) Enter a comment string.
11. Click Promote.
12. Click the Update button ( # ) to update your workspace.
Updating often greatly improves workspace-search performance.
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