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Preface

Preface

Contacting Micro Focus Fortify Customer Support

If you have questions or comments about using this product, contact Micro Focus Fortify Customer
Support using one of the following options.

To Manage Your Support Cases, Acquire Licenses, and Manage Your Account
https://softwaresupport.softwaregrp.com

To Call Support

1.844.260.7219

For More Information

For more information about Fortify software products:
https://software.microfocus.com/solutions/application-security

About the Documentation Set

The Fortify Software documentation set contains installation, user, and deployment guides for all
Fortify Software products and components. In addition, you will find technical notes and release notes
that describe new features, known issues, and last-minute updates. You can access the latest versions of
these documents from the following Micro Focus Product Documentation website:

https://www.microfocus.com/support-and-services/documentation
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Change Log

Change Log

The following table lists changes made to this document. Revisions to this document are published
between software releases only if the changes made affect product functionality.

Software Release /

Document Version Changes
18.20 Updated: Minor edits
18.10 Updated:

« Minor edits to incorporate branding changes

e "About Updating Security Content" on page 58 - Clarified how you
import security content manually and how to import custom rules

17.20 Updated:

¢ "Grouping Issues" on page 26 - Expanded the section to include all
grouping option descriptions

¢ "Search Modifiers" on page 29 - Expanded the section to include
additional search modifier descriptions
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Chapter 1: Introduction

This guide describes how to use the Fortify Extension for Visual Studio to scan and analyze your project
source code to uncover security vulnerabilities (issues), which you can then evaluate and remediate.

This section contains the following topics:

Fortify Extension for Visual Studio ... o 8
Fortify Security CoONTeNT 8
INSTal At ON L 9
U GradeS o 9
Related DOCUMENTS 9

Fortify Extension for Visual Studio

The Fortify Extension for Visual Studio works with the Visual Studio integrated development
environment (IDE). The extension integrates into the Visual Studio IDE as a software extension.

Software security analysis typically consists of the following phases:

¢ Analysis—Scan a codebase for vulnerabilities
o Auditing—Review the analysis results o eliminate false positives and prioritize remediation efforts
o Remediation—Fix and eliminate security vulnerabilities in your code

The Fortify Extension for Visual Studio uses Micro Focus Fortify Static Code Analyzer (Fortify Static
Code Analyzer) and Fortify Secure Coding Rulepacks to locate security vulnerabilities in your solutions
and projects (includes support for the following languages: C/C++, C#, VB.NET, and ASP.NET). The
scan results are displayed in Visual Studio and includes a list of issues uncovered, descriptions of the
type of vulnerability each issue represents, and suggestions on how to fix them.

Your organization can also use the Fortify Extension for Visual Studio with Micro Focus Fortify
Software Security Center to manage applications and assign specific issues to developers.

You can connect with Fortify Software Security Center to review the reported vulnerabilities and
implement appropriate solutions from Visual Studio.

Fortify Security Content

Micro Focus Fortify Static Code Analyzer uses a knowledge base of rules to enforce secure coding
standards applicable to the codebase for static analysis. Fortify Security Content (security content)
consists of Secure Coding Rulepacks and external metadata:

¢ Secure Coding Rulepacks describe general secure coding idioms for popular languages and public
APIs
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« External metadata includes mappings from the Fortify categories to alternative categories (such as
CWE, OWASP Top 10, and PCI DSS)

Fortify provides the ability to write custom rules that add to the functionality of Fortify Static Code
Analyzer and the Secure Coding Rulepacks. For example, you might need to enforce proprietary
security guidelines or analyze a project that uses third-party libraries or other pre-compiled binaries that
are not already covered by the Secure Coding Rulepacks. You can also customize the external metadata
to map Fortify issues to different taxonomies, such as internal application security standards or
additional compliance obligations. For instructions on how to create your own custom rules or custom
external metadata, see the Micro Focus Fortify Static Code Analyzer Custom Rules Guide. Be sure that
any custom rules or external metadata changes are also made in Fortify Software Security Center.

Installation

You install the Fortify Extension for Visual Studio by selecting the extension during the Micro Focus
Fortify Static Code Analyzer and Applications installation (which includes Audit Workbench and other
plugins that you can install). For installation instructions, see the Micro Focus Fortify Static Code
Analyzer Installation Guide.

During the Fortify Static Code Analyzer installation, make sure that you select the extension that
corresponds to the Visual Studio version installed on your system.

If you plan to scan your code from Visual Studio, make sure that you select the Update security
content after installation? check box at the end of the installation unless your administrator has set
up an alternative way to deliver Fortify Security Content to you.

Upgrades

After you install the Fortify Extension for Visual Studio, when you subsequently upgrade Micro Focus
Fortify Static Code Analyzer and select to also install the Fortify Extension for Visual Studio, the new
version of the extension is automatically upgraded. You can upgrade Fortify Static Code Analyzer
(along with Audit Workbench and any plugins you have installed) manually or automatically from Audit
Workbench. For instructions, see the Micro Focus Fortify Audit Workbench User Guide.

Related Documents

This topic describes documents that provide information about Micro Focus Fortify software products.

Note: You can find the Micro Focus Fortify Product Documentation at
https://www.microfocus.com/support-and-services/documentation.
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All Products

The following documents provide general information for all products. Unless otherwise noted, these
documents are available on the Micro Focus Product Documentation website.

Document / File Name

About Micro Focus Fortify Product
Software Documentation

About_Fortify_Docs_<version>.pdf

Micro Focus Fortify Software System
Requirements

Fortify_Sys_Reqs_<version>.pdf

Fortify_Sys_Reqs_Help_<version>

Micro Focus Fortify Software Release
Noftes

FortifySW_RN_<version>.txt
What’s New in Micro Focus Fortify
Software <version>
Fortify_Whats_New_<version>.pdf

Fortify_Whats_New_Help_<version>

Micro Focus Fortify Open Source and
Third-Party License Agreements

Fortify_OpenSrc_<version>.pdf

Fortify_OpenSrc_<version>

Description

This paper provides information about how to access Micro
Focus Fortify product documentation.

Note: This document is included only with the product
download.

This document provides the details about the
environments and products supported for this version of
Fortify Software.

This document provides an overview of the changes made
to Fortify Software for this release and important
information not included elsewhere in the product
documentation.

This document describes the new features in Fortify
Software products.

This document provides open source and third-party
software license agreements for software components used
in Fortify Software.

Micro Focus Fortify Software Security Center

The following documents provide information about Fortify Software Security Center. Unless otherwise
noted, these documents are available on the Micro Focus Product Documentation website.

Document / File Name

Micro Focus Fortify Software Security
Center User Guide

SSC_Guide_<version>.pdf

Micro Focus Fortify Extension for Visual Studio (18.20)

Description

This document provides Fortify Software Security Center
users with detailed information about how to deploy and
use Software Security Center. It provides all of the
information you need to acquire, install, configure, and use
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Document / File Name

SSC_Help_<version>

Description

Software Security Center.

It is intended for use by system and instance
administrators, database administrators (DBAs), enterprise
security leads, development team managers, and
developers. Software Security Center provides security
team leads with a high-level overview of the history and
current status of a project.

Micro Focus Fortify Static Code Analyzer

The following documents provide information about Fortify Static Code Analyzer. Unless otherwise
noted, these documents are available on the Micro Focus Product Documentation website.

Document / File Name

Micro Focus Fortify Static Code
Analyzer Installation Guide

SCA _Install_<version>.pdf

SCA _Install_Help_<version>

Micro Focus Fortify Static Code
Analyzer User Guide

SCA_Guide_<version>.pdf

SCA _Help_<version>

Micro Focus Fortify Static Code
Analyzer Performance Guide

SCA_Perf_Guide_<version>.pdf

SCA_Perf_Help_<version>

Micro Focus Fortify Static Code
Analyzer Custom Rules Guide

SCA_Cust_Rules_Guide_<version>.zip

SCA_Cust_Rules_Help_<version>

Micro Focus Fortify Extension for Visual Studio (18.20)

Description

This document contains installation instructions for Fortify
Static Code Analyzer and Applications.

This document describes how to use Fortify Static Code
Analyzer to scan code on many of the major programming
platforms. It is intfended for people responsible for security
audits and secure coding.

This document provides guidelines for selecting hardware
to scan different types of codebases and offers tips for
optimizing memory usage and performance.

This document provides the information that you need to
create custom rules for Fortify Static Code Analyzer. This
guide includes examples that apply rule-writing concepts to
real-world security issues.

Note: This document is included only with the product
download.
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Chapter 2: Using the Fortify Extension for
Visual Studio

Use the Fortify Extension for Visual Studio to perform Micro Focus Fortify Static Code Analyzer scans,
review and audit analysis results, and remediate issues in Visual Studio.

This section contains the following topics:

ScanNiNg SOlUTIONS L 12
Configuring Scan SettiNgs ..o 13
Synchronizing with Fortify Software Security Center ... . L 15
Analysis Results WINdOW . . 16
AUuditing SCan ReSUNS 34
AboUT IsSUE TeMPIateS . L 36
Configuring Custom Tags for AUuditing ... 38
Creating a Filter Set _ L 40
Managing Folders .o L 42
Scan ResUNS RePOIT S 45
Working with Audit Projects .. 55
About Updating Security Content . L 58
Integrating with a Bug Tracker Application .. 60
Using the Debug OptioNn .o L 61

Scanning Solutions

You analyze the source code from Visual Studio at the solution or project level. A security analysis
(scan) performs the following tasks:
e Cleans up old intfermediate files used for source code analysis

o Translates all .NET files and other existing supported files, such as T-SQL, in the solution into
intfermediate files

o Performs the security analysis
o Displays the results

Fortify strongly recommends that you periodically update the security content, which contains Fortify
Secure Coding Rulepacks and external metadata. For information about how to update the security
content, see "About Updating Security Content" on page 58.
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To scan a solution:

1
2.

Open a solution in Visual Studio.
Verify the Visual Studio configuration as follows:
o Set the configuration to debug.

o For Visual C++ solutions, verify that all of the project files (* . vcxpro3j) are modifiable.
Start the scan in one of the following ways:
o To scan at the solution level, select Fortify > Analyze Solution.

o To scan at the project level, select a project, and then select Fortify > Analyze Project.

Note: The Analyze Project command is not available for web site projects. To analyze a
web site project, choose Analyze Solution to scan the project.

After the scan has finished, the Fortify Extension for Visual Studio displays the results in the
auditing interface.

Audit the results.

For information, see "Auditing Issues" on page 35.

If the codebase has been audited before, results from the previous audit are automatically integrated
with the new analysis results.

Note: Micro Focus Fortify Static Code Analyzer scans are invoked with the server Java Virtual
Machine.

Configuring Scan Settings

The source code analysis settings configure different Rulepacks and determine the amount of memory
to use during the scan to modify what Micro Focus Fortify Static Code Analyzer looks for as it scans.

To configure the analysis settings:

1

Select Fortify > Options.

The Options dialog box opens.

Select Project Settings on the left.

The Project Settings dialog box opens to show the Analysis Configuration tab.

To specify the scope of the settings, do one of the following:

o To customize the settings for the projects in the open solution only, select Enable Project
Specific Settings.

¢ To change the default scan settings for all projects scanned from this Visual Studio instance,
click Configure Defaults.

By default, Fortify Static Code Analyzer treats SQL files T-SQL. If your files use PL/SQL, from the
SQL Type list, select PL/SQL.
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Note: The SQL Type setting notifies Fortify Static Code Analyzer about the SQL type that the
project uses. SQL code is only scanned if it is included in the project.

5. To specify the amount of memory to use for the scan, enter the integer in the Memory (MB) box.

Note: Do not allocate more than two thirds of the available physical memory.

6. To customize the security content you want to use, clear the Use all installed security content
check box and select the Secure Coding Rulepacks and any custom Rulepacks you want to use.

7. Click OK.

Using Quick Scan Mode

Quick Scan mode provides a way to quickly scan your projects for major issues. However, although the
scan in Quick Scan mode is significantly faster, it does not provide a robust result set.

When you enable Quick Scan mode, Micro Focus Fortify Static Code Analyzer scans your project using

the fortify-sca-quickscan.properties file, rather than the standard fortify-
sca.properties file. By default, this scan searches for high-confidence, high-severity issues. You can
edit the fortify-sca-quickscan.properties file to specify other properties to use. This file is
located in <sca_1install_dir>\Core\config directory.

To perform a quick scan:
1. Open asolution.
2. Select Fortify > Options.
The Options dialog box opens.
3. Select Project Settings.

4. Do one of the following:

o To configure quick scans for the projects in the open solution, select the Enable Project
Specific Settings check box.

o To configure quick scans for by default for all projects scanned from this Visual Studio instance,
select the Configure Defaults link.

5. On the Advanced Scan Options fab, select the Enable quick scan mode check box.

The Analysis Results window displays the scan results.

Configuring Advanced Scan Options

You can specify advanced Micro Focus Fortify Static Code Analyzer scan and translation options. For
information on the available options and syntax, see the Micro Focus Fortify Static Code Analyzer
User Guide.

To change the advanced scan options:

1. Select Fortify > Options.
The Options dialog box opens.
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2. Select Project Settings.
3. Click the Advanced Scan Options tab.
4. To specify the scope of the settings, do one of the following:
o To customize the settings for the projects in the open solution only, select Enable Project
Specific Settings.

o To change the default scan settings for all projects scanned from this Visual Studio instance,
click Configure Defaults.

5. Select Use Additional SCA Arguments and enter command-line options for either the translation
or scan phase.
6. Click OK.
The changes to the advanced scan options are saved.

Synchronizing with Fortify Software Security Center

The Fortify Extension for Visual Studio supports the ability fo synchronize the local version of your
project with the corresponding application version on the Micro Focus Fortify Software Security Center
server. With synchronization to the server enabled, each time you load, merge, scan, or save your project
locally on your system, the extension automatically uploads your changes to the version of your project
on the server. This automatic synchronization prevents work loss during a power outage and enables
you to work locally and synchronize your work when you connect at a later time.

Note: The Fortify Extension for Visual Studio supports synchronization between the local version
of your project and the corresponding application version on the server.

To enable synchronization to the server:

1. Performone of the following tasks on your project: scan, partial scan, save, or merge.

A dialog box opens, and prompts you to specify whether you want to auto-synchronize your
project with the server after a load, merge, save, or scan.

2. Click OK.
To disable synchronization to the server (if already enabled):

1. Select Fortify > Options.
The Options dialog box opens.
2. Select Project Settings.
3. Click the Synchronization Options tab.
4, Clear the Auto Synchronize all Projects with Server Application check box.
You can customize which action synchronizes your local version project with the server. For instance,
you can customize so that synchronization occurs only when you merge or scan a project.

To customize when synchronization occurs:

1. Select Fortify > Options.
The Options dialog box opens.
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2. Select Project Settings.
3. Select the Synchronization Options tab.
A check box list is displayed.
4, Select any action to exclude from automatic synchronization, and then click OK.

Analysis Results Window

The Analysis Results window enables you to group, filter, and select the issues you want to audit.

Analysis Results > 0 x

i & E = -

Filter Set | Security Auditor View v
r (3 (o [2 [s | |
Group by [Eate.-gur'_f T]

E-] 5QL Injection - [0/ 2]
-] Unreleased Resource: Database - [0 /1]

PUELGTLY W Solution Ex.. Team Expl.. Class View

Filter Sets

The selected filter set controls which issues the Analysis Results window displays. The filter set
determines the number and types of containers (folders) and how and where issues are displayed.

Each project can have unique sets because the filter sets are saved in an audit project results file.

The filter sets sort the issues info Critical, High, Medium, and Low folders, based on potential severity.
All default filter sets have the same sorting mechanism.

The Fortify Extension for Visual Studio provides the following filter sets:

o Quick View: This is the default filter set for new projects. The Quick View filter set provides a view
only of issues in the Critical folder (these have a potentially high impact and a high likelihood of
occurring) and the High folder (these have a potentially high impact and a low likelihood of
occurring). The Quick View filter set provides a useful first look at results that enables you to quickly
address the most serious issues.

o Security Auditor View: This view reveals a broad set of security issues to be audited. The Security
Auditor View filter contains no visibility filters, so all issues are shown.
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If you open an FPR file that contains no custom filtertemplate.xml file or if you open an FVDL file
orawebinspect.xml file, the audit project results open with the Quick View filter set selected.

For information about how to create your own filter sets, see "Creating a Filter Set" on page 40.

Folders (Tabs)

The tabs on the Analysis Results window are called folders. You can customize the folders and their
settings. The number of folders, names, colors, and the issue list can vary between filter sets and audit
projects. For information about how to create your own folders, see "Creating a Folder" on page 42.

Each folder contains a list of issues. An issue is sorted into a folder if its attributes match the folder filter

conditions. One folder in each filter set is the default folder, indicated by (default) in the folder name.
If an issue does not match any of the folder filters, the issue is listed in the default folder.

Note: To show or hide suppressed, hidden, and removed issues, use the Visibility menu = For
more information, see "Customizing the Issues Display" below.

Group By List

The Group By option sorts the issue list into subfolders. The selected option is applied to all visible
folders. Use the <none> option to list all issues in the folder without any groups. The Group By settings
are for the application instance. You can apply the Group By option to any audit project opened with
that instance of the application.

You can customize the existing groups by changing which attributes the groups are sorted by, adding
or removing the attributes to create sub-groupings, and adding your own group options.

Customizing the Issues Display

You can customize the issues displayed in the Analysis Results window. Determine which issues it
displays by using the Visibility menu Ein the Analysis Results toolbar.

The visibility options are as follows:

o Show Removed Issues: Shows all of the issues you have removed. If you have merged audit data
into your current audit project, shows all of the issues that were removed since the previous analysis.

o Show Suppressed Issues: Shows all of the issues that you have suppressed.

o Show Hidden Issues: Shows all of the issues that have been hidden.

« Show My Issues: Shows only your issues.

o Use Short File Names: References the issues in the Issues view by file name only, instead of by
relative path. This option is enabled by default.
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Analysis Evidence Window

When you select an issue, the Analysis Evidence window displays the trace that the analyzer used to
produce the issue. This trace is presented in sequential order. For dataflow issues, this trace is a
presentation of the path that the tainted data follows from the source function to the sink function.

For example, when you select an issue that is related to potentially tainted data flow, the Analysis
Evidence window shows the direction of the data flow in this section of the source code.

The Analysis Evidence window uses the icons described in the following table to show how the data
flow moves in this section of the source code or execution order:

Icon Description

= Data is assigned to a field or variable

'3 Information is read from a source external to the code (HTML form, URL, and so on)
)] Data is assigned to a globally scoped field or variable

h34 A comparison is made

() The function call receives tainted data

&) The function call returns tainted data

) Passthrough, tainted data passes from one parameter to another in a function call
[ An alias is created for a memory location

&0 Datais read from a variable

&0 Data is read from a global variable

Py Tainted data is returned from a function

& A pointer is created

e A pointer is dereferenced

) The scope of a variable ends

~x The execution jumps

A branch is taken in the codes execution
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Icon

oo

+

Description

A branch is not taken in the codes execution
Generic
A runtime source, sink, or validation step

Taint change

The Analysis Evidence window can contain inductions. Inductions provide supporting evidence for their
parent nodes. Inductions consist of:

o A fext node, displayed in italics as a child of the trace node. This text node is expanded by default.

o Aninduction trace, displayed as a child of the text node.
To display the induction reference information for that induction, click it.

Viewing Project Summary Information

The Project Summary window provides detailed information about the scan.

To open the Project Summary dialog box:

1. Open an audit project file (FPR, FVDL, or XML)
2. Select Fortify > Project Summary.

Micro Focus Fortify Extension for Visual Studio (18.20)
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Micro Focus
Fortify Static Code Analyzer

MICRDO"
I:IFEIELIE

rﬁJ Project Summary @
Summary | Certification | Build Information | Anahysis Information
Build 1D Sample1 Scanned: 3iles, 14 lines of code
Code Scanned: February 01, 2018 Total Issues: 13
Wamings: MNone Certification: Results Certification Valid

—

The following table describes the information provided on the Project Summary tabs.

Tab
Summary

Certification

Build Information

Analysis Information

Description
Displays high level audit project information.

Displays the result certification status. Results certification is a check fo make
sure that the analysis has not been altered since Fortify Static Code Analyzer
produced it.

Displays the following scan information:

o Build details such as the build ID, number of files scanned, lines of code,
and the date of the scan, which might be different than the date the files
were franslated

o List of files scanned with file sizes and timestamps

o Libraries referenced for the scan

Displays the Fortify Static Code Analyzer version, computer details, and the
name of the user who performed the scan. The Analysis Information subtabs
contain the following information:

o Security Content—Lists information about the Rulepacks used to scan the
source code, including the Rulepack name, version, ID, and SKU.
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Tab

Code Editor

Description

Properties—Displays the Micro Focus Fortify Static Code Analyzer
properties files settings

Commandline Arguments—Displays the command-line options used to
analyze the project

Warnings—Lists all errors and warnings that occurred during the analysis.
To view more information about an item, click it.

The Code Editor shows the section of code related to the issue selected in the Analysis Results window.
When multiple nodes represent an issue in the Analysis Evidence window, the Code Editor shows the
code associated with the selected node.

Issue Auditing Window

The Issue Auditing window displays detailed information about each issue on the following tabs:

« The Summary tab displays the following information about the selected issue. Security auditors can
add comments and custom tag values to issues from this tab.

Summary

Classl.cxc23

Anabvmis.

Suppress | File Bug

= 0 x

Insecure Transport:
Database

(Security Features.
Semantic)

The application is v:-cnfigl.m:d
Lo communicate with its
database server in plainbet
over unencrypted channels,
l'r'lﬂhll‘lg the commsnscated
data vulnerable to
interception vis man-in-the-
* middie (MiTR) attacks.

Chck to append comment [Ctr+Enter to save)

More Informaton
H TS !

Output EPLEFELA Diagram Details History Filters Recommendations

The following table describes the elements of the Summary tab.

Element

Issue

Analysis

<custom_
tagname>

Description

Displays the issue location, including the file name and line number.

Lists values that the auditor can use to assess the issue. Valid values for the
Analysis tag are Not an Issue, Reliability Issue, Bad Practice, Suspicious, and
Exploitable.

Displays any custom tags if defined for the audit project.

If the audit results have been submitted to Audit Assistant in Micro Focus
Fortify Software Security Center, then in addition to any other custom tags,
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Element Description

the tab displays the following tags:

o AA_Prediction—Exploitability level that Audit Assistant assigned to the
issue. You cannot modify this tag value.

o AA_Confidence—Confidence level from Audit Assistant for the accuracy
of its AA_Prediction value. This is a percentage, expressed in values that
range from 0.000 to 1.000. For example, a value of 0.982 indicates a
confidence level of 98.2 percent. You cannot modify this tag value.

o AA_Training—Whether to include or exclude the issue from Audit
Assistant training. You can modify this value.

For more information about Audit Assistant, see the Micro Focus Fortify
Software Security Center User Guide.

Suppress Suppresses the issue.

File Bug Provides access to a supported bug tracking system, such as Bugzilla or
Team Foundation Server.

See the Micro Focus Fortify Software System Requirements document for a
list of supported bug tracking systems.

Comments Appends additional information about the issue to the comment field.

Rule Information Shows information, such as the category and kingdom that describes the
issue.

More Information = Opens the Details tab.
Recommendations = Opens the Recommendations tab.

For information about auditing, see "Auditing Issues" on page 35.
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o The Details tab provides a detailed description of the selected issue and offers guidelines to address
it.

Details * 0 x
Abstract: -

The application is configured to communicate with its database server in plaintext over unencrypted
channels, making the communicated data vulnerable to interception via man-in-the-middle (MiTM)

attacks.

Explanation:

The application communicates with its database senver over unencrypted channels and may pose a
significant security risk to the company and users of that application. In this case, an attacker can modify
the user entered data or even execute arbitrary 5QL commands against the database server.

Example 1: The following code causes the application to communicate with its database server over
unencrypted channels:

Diagram WM& History  Filters  Recommendations

Each description includes some or all of the sections described in the following table.

Element Description
Abstract/Custom Provides a summary description of the issue, including custom abstracts
Abstract defined by your organization.

Explanation/Custom = Provides description of the conditions in which this type of issue occurs.

Explanation Includes a discussion of the vulnerability, the constructs typically
associated with it, how it can be exploited, and the potential ramifications
of an attack.

This element also provides custom explanations defined by your
organization.

Instance ID Provides a unique identifier for the issue.
Primary Rule ID Identifies the primary rule that found the issue.
Priority Metadata Includes IMPACT and LIKELIHOOD.

Values

Legacy Priority Includes SEVERITY and CONFIDENCE.

Metadata Values

« The Recommendations tab provides the following information, which includes suggestions and
examples of how to secure the vulnerability or remedy the bad practice.

Element Description

Recommendations/Custom | Provides recommendations for this type of issue, including
Recommendations examples, as well as custom recommendations defined by your
organization.
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Element Description

Tips/Custom Tips Provides tips for this type of issue, including any custom tips defined
by your organization.

References/Custom Provides reference information, including any custom reference

References defined by your organization.

« The History tab shows a complete list of audit actions, including details such as the time and date,
and the name of the user who modified the issue.

« The Diagram tab presents a graphical representation of the node execution order, call depth, and
expression type of the issue selected in the Analysis Results window. The tab displays information
relevant to the rule type. The vertical axis shows the execution order.

Diagram -1 X
Class1.cs:28

| Sample1Main() |

G[] SqlDatasdapter() 253]

Output  Summary ENEBICIGN Details History Filters Recommendations

For dataflow issues, the trace starts with the first function to call the taint source, then traces the calls
to the source (blue node), and ends the trace at the sink (red node). In the diagram, the source (src)
and sink nodes are also labeled. A red X on a vertical axis indicates that the function called finished
executing.

The horizontal axis shows the call depth. A line shows the direction that control is passed. If control
passes with tainted data traveling through a variable the line is red, and when it is without tainted
data, the line is black.

The icons used for the expression type of each node in the diagram are the same icons used in the
Analysis Evidence window. To see the icons and the descriptions, see "Analysis Evidence Window" on
page 18.
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o The Filters tab displays all the filters in the selected filter seft.

Filters
Filters: (applied in order shown) If
-} Visibility Filters

I impact is not in range [2.5, 5.0] Then hide ssue
If likefihood is not in range (1.0, 5.0] Then hide issue
Folder Filters
H [fortify priority order] containg critical Then set folder to Critical
¥ [fortrf'_h,r prio rit:" Drdl_"I'I contains high Then set folder to High
If [fortify priority order] contains medium Then set folder to Medium
If [fortify priority order] contains low Then set folder to Low

. Then

Output Summary Diagram Details History JELEH) Recommendations

The following table describes the elements of the Filters tab.

Element Description

Filters Displays a list of the visibility and folder filters configured in the selected filter set

where:
o Visibility Filters show or hide issues

o Folder Filters sort the issues into the folder tabs in the Analysis Results window

Right-click a filter to show issues that match the filter or to enable, disable, copy, or

delete it.

If Displays the filters conditions.

The first list displays issue attributes, the second list specifies how to match the

attribute, and third list shows the value the filter matches.

Then Displays the filter type, where Hide Issue is a visibility filter and Set Folder to is a

folder filter.

For more information about creating filters, see "Creatfing a Filter from the Filters Tab" on page 41.

Using the Audit Guide to Filter Issues

The Audit Guide wizard provides filtering of results.
To use the Audit Guide:

1. Select Fortify > Audit Guide.

The Audit Guide wizard opens.
2. Select the settings for the types of issues you want to display.
3. To use the advanced filtering options, click the Advanced tab.

o In the Audit Guide Filters list, select the types of issues to filter out.

Click an issue type to see a description on the right side.

Micro Focus Fortify Extension for Visual Studio (18.20)
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As you select items in the Audit Guide Filters list, the Fortify Extension for Visual Studio
displays the filter details for this issue type below the Audit Guide Filters list and shows the
number of issues found by each filter.

4, Click OK to apply your filtering selections.

Grouping Issues

The items visible in the navigation tree vary according to which grouping option is selected in the
Analysis Results window. The value you select from the Group By list sorts issues in all visible folders

into subfolders.

To list all issues in a folder without any grouping, select <none>.

You can view issues using any of the Group By options, and you can create and edit customized groups.
The Group By options enable you to group and view the issues in different ways. In practice, you might
switch frequently between various groupings. The following table lists descriptions of the standard

Group By options.

Option

Analysis

Analysis Type

Analyzer

App Defender Protected

Category
Category Analyzer
File Name

Fortify Priority Order

Kingdom

New Issue

<metadata_listname>

Micro Focus Fortify Extension for Visual Studio (18.20)

Description

Groups issues by the audit analysis, such as Suspicious, Exploitable, and
Not an Issue.

Groups issues by analyzer product, such as SCA, WEBINSPECT, and
SECURITYSCOPE (Weblnspect Agent).

Groups issues by analyzer group, such as Control Flow, Data Flow,
Semantic, and Structural.

Groups issues by whether or not Application Defender can protect the
vulnerability category.

Groups issues by vulnerability category. This is the default setting.
A custom group that groups issues by category and then analyzer.
Groups issues by file name.

Groups issues as Critical, High, Medium, and Low based on the combined
values of Micro Focus Fortify Static Code Analyzer impact and likelihood.

Groups issues by the Seven Pernicious Kingdoms classification.

Shows which issues are new since the last scan. For example, if you run a
new scan, any issues that are new display in the tree under the New
Issues group and the others are displayed in the Issue Updated group.
Issues not found in the latest scan are displayed in the Removed list.

Groups issues using the alternative metadata external list names (for
example, OWASP Top 10 <year>, CWE, PCI <version>, STIG <version>,
and so on).
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Option Description

Package Groups issues by package or namespace. Does not appear for projects for

which this option is not applicable, such as C projects.

Priority by Category A custom group that groups issues by Fortify Priority Order and then by
category.

Sink Groups issues that share the same data flow sink function.

Source Groups issues that share the same data flow source functions.

Taint Flag Groups issues by the taint flags that they contain.

<none> Displays a flat view without grouping.

<Edit> Use to create a custom grouping option.

Note: This option is not available when you remediate an audit
project on Micro Focus Fortify Software Security Cenfter.

Creating a Custom Group By Option

You can create a custom Group By option that groups issues in a hierarchical format in sequential order
based on specific options.

To create a new Group By option:

1

From the Group by list, select <Edit>.
The Edit Custom Groupings dialog box opens.

To create a grouping from a provided set of group types, select a grouping type from the
Grouping Types list.

For example, selecting Category Analyzer group type creates a list that has top-level nodes that
contain the category of the issue, such as Buffer Overflow, with the issues grouped below by
analyzer, such as semantic, or dataflow, followed by the issues.

-Buffer Overflow [0/2]
--DataFlow [0/1]
----Main.cs:234
-+Semantic [0/1]

To create a custom group by option, select Create New from the Grouping Types list, and then do
the following:

a. Inthe Create New dialog box, enter a group name, and then click OK.

b. From the list on the left, select a grouping type, and then click the right arrow to move the
option to the Grouping Order column.

¢. Repeat to select additional grouping types.
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Searching for Issues

You can use the search box located below the issue tree to find specific issues and to limit the issues
displayed in a folder. After you type a search term, the label next to the folder name changes to indicate

the number of issues that match the search as a subset of the total.

To indicate the type of comparison to perform, wrap the search terms with delimiters. The following

table shows the syntax to use for the search string.

Comparison Description

contains Searches for a term without any qualifying delimiters

equals Searches for an exact match if the term is wrapped in quotation marks (" ")

regex Searches for values that match a Java-style regular expression delimited by a
forward slash (/)

Example, /eas.+?/

Note: This search comparison is not available when you remediate audit results

stored on Micro Focus Fortify Software Security Cenfer.

number range

not equals

Searches for a range of numbers using the standard mathematical interval notation
of parentheses and/or brackets to indicate whether the endpoints are excluded or
included respectively.

Example: (2,4] indicates greater than two and less than or equal to four

Excludes issues specified by the string by preceding the string with an exclamation

character ()

Example, file: !Main. java returns all issues that are not in Main. java.

You can further qualify search terms with modifiers. For more information, see "Search Modifiers" on the

next page. The syntax for using a modifierismodifier:<search_term>.

A search string can contain multiple modifiers and search terms. If you specify more than one modifier,

the search returns only issues that match all the modified search terms. For example,

file:ApplicationContext.java category:SQL Injection returnsonly SQL injection issues

foundin ApplicationContext.java.

If you use the same modifier more than once in a search string, then the search terms qualified by those

modifiers are treated as an OR comparison. For example, file:ApplicationContext.java
category:SQL Injection category:Cross-Site ScriptingreturnsSQL injection issuesand

cross-site scripting issues found in ApplicationContext. java.

For complex searches, you can also insert the AND or the OR keyword between your search queries.

Note that AND and OR operations have the same priority in searches.

Micro Focus Fortify Extension for Visual Studio (18.20)
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Search Modifiers

You can use a search modifier to specify to which issue attribute the search term should apply.

Note: To use a modifier that contains a space in the name, such as the name of the custom tag, you
must enclose the modifier in brackets. For example, to search for issues that are new, type [issue

age]:new.

A search that is not qualified by a modifier matches the search string on the following attributes:
kingdom, primary rule id, analyzer, filename, severity, class name, function name, instance id, package,
confidence, type, subtype, taint flags, category, sink, and source.

e To apply the search to all modifiers, enter a string, such as control flow. This searches all of the
modifiers and returns any results that contain the string “control flow”.

o To apply the search to a specific modifier, type the modifier name and the string as follows:

analyzer:control flow. Thisreturns all results with the analyzer “control flow”.

The following table lists descriptions of the search modifiers. A few modifiers have a shortened modifier
name indicated in parentheses in the Modifier column. You can use either modifier name.

Modifier

accuracy

analysis

[analysis type]

analyzer

[app defender protected]
(def)

audience

audited

category (cat)

class

Micro Focus Fortify Extension for Visual Studio (18.20)

Description

Searches for issues based on the accuracy value specified (0.1
through 5.0).

Searches for issues that have the specified audit analysis value
such asexploitable, not an issue,andsoon.

Searches for issues by analyzer product such as SCA and
WEBINSPECT.

Searches the issues for the specified analyzer such as control
flow,data flow, structural,andsoon.

Searches for issues based on whether or not Application Defender
can protect the vulnerability category (protected O not

protected):

Searches for issues based on intended audience such as dev,
targeted, medium, broad, and so on.

Searches the issues to find true if the primary custom tag is set
and false if the primary custom tag is not set. The default
primary tag is the Analysis tag.

Searches for the given category or category substring.

Searches for issues based on the specified class name.
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Modifier Description
comments Searches the comments submitted on the issue.

(comment, com)

commentuser Searches for issues with comments from a specified user.

confidence (con) Searches for issues that have the specified confidence value. Micro
Focus Fortify Static Code Analyzer calculates the confidence value
based on the number of assumptions made in code analysis. The
more assumptions made, the lower the confidence value.

dynamic Searches for issues that have the specified dynamic hot spot
ranking value.

file Searches for issues where the primary location or sink node
function call occurs in the specified file.

[fortify priority order] Searchesforissues that have a priority level that matches the
specified priority determined by the Fortify analyzers. Valid values

are critical, high, medium, and low, based on the expected
impact and likelihood of exploitation.

The impact value indicates the potential damage that might result
if an issue is successfully exploited. The likelihood value is a
combination of confidence, accuracy of the rule, and probability
that and attacker can exploit the issue.

Issues are grouped into folders based on the four priority values
(critical, high, medium, and low) by default.

historyuser Searches for issues that have audit data modified by the specified
user.
impact Searches for issues based on the impact value specified (0.1

through 5.0).

[instance id] Searches for an issue based on the specified instance ID.

[issue age] Searches for the issue age, which is new, updated,
reintroduced, or removed.

[issue state] Searches for audited issues based on whether or not the issue is
an open issue or not an issue (determined by the level of analysis
set for the primary tag).

kingdom Searches for all issues in the specified kingdom.

likelihood Searches for issues based on the specified likelihood value (0.1

through 5.0).
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Modifier

line

maxconf

minconf

package

[primary context]

primary

primaryrule (rule)

probability

[remediation effort]

ruleid

severity (sev)

sink

source

[source context]

Description

Searches for issues on the primary location line number. For
dataflow issues, the value is the sink line number. Also see
"sourceline" on the next page.

Searches for all issues that have a confidence value up to and
including the number specified as the search term.

Searches for all issues that have a confidence greater than or
equal to the specified value.

Searches for issues where the primary location occurs in the
specified package or namespace. (For dataflow issues, the primary
location is the sink function.)

Searches for issues where the primary location or sink node
function call occurs in the specified code context. Also see "sink"
below and "[source context]" below.

Searches for issues that have the specified primary tag value. By
default, the primary tag is the Analysis tag.

Searches for all issues related to the specified sink rule.

Searches for issues based on the probability value specified (1.0
through 5.0).

Searches for issues based on the remediation effort value
specified. The valid values are whole numbers from 1.0 to 12.0.

Searches for all issues reported by the specified rule IDs used to
generate the issue source, sink and all passthroughs.

Note: This search modifier is not available when you
remediate audit results that are stored on Micro Focus Fortify
Software Security Center.

Searches for issues based on the specified severity value (legacy
metadata).

Searches for issues that have the specified sink function name.
Also see "[primary context]" above.

Searches for dataflow issues that have the specified source
function name. Also see "[source context]" below.

Searches for dataflow issues that have the source function call
contained in the specified code context.

Also see "source" above and "[primary context]" above.
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Modifier Description

sourcefile Searches for data flow issues with the source function call that the
specified file contains.

Also see "file" on page 30

sourceline Searches for dataflow issues having taint source entering the flow
on the specified line. Also see "line" on the previous page.

status Searches issues that have the status reviewed, unreviewed, or
under review.

suppressed Searches for suppressed issues.

taint Searches for issues that have the specified taint flag.

trace Searches for issues that have the specified string in the dataflow
trace.

Note: This search modifier is not available when you
remediate audit results that are stored on Fortify Software
Security Center.

tracenode Enables you to search on the nodes within an issue’s analysis
trace. Each tracenode search value is a concatenation of the
tracenode’s file path, line number, and additional information.

Note: This search modifier is not available when you

remediate audit results that are stored on Fortify Software
Security Center.

tracenodeallpaths Searches for the specified value in all the steps of analysis
evidence.

Note: This search modifier is not available in the remediation

plugin.
url Searches for issues based on the specified URL.
user Searches for issues assigned to the specified user.
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Modifier Description

<custom_tagname> Searches the specified custom tag.

You can search a list-type custom tag using a range of values. The
values of a list-type custom tag are an enumerated list where the
first value is O, the second is 1, and so on. You can use the search
syntax for a range of numbers to search for ranges of list-type

custom tag values. For example, analysis: [0, 2] returns the
issues that have the values of the first three analysis values, 9, 1,
and 2 (Not an Issue, Reliability Issue, and Bad Practice).

To search a date-type custom tag, specify the date in the format:
yyyy-mm-dd.

<metadata_Listname> Searches the specified metadata external list. Metadata external
listsinclude [owasp top ten 2017], [sans top 25 2011],
[pci 3.2],andothers.

Search Query Examples

Consider the following search query examples:

e To search for all privacy violations in file names that contain jsp with getSSN() as a source, type the
following:
category:"privacy violation" source:getssn file:jsp

e To search for all file names that contain com/fortify/awb, type the following:
file:com/fortify/awb

o To search for all paths that contain traces with mydbcode.sqlcleanse as part of the name, type
the following:

trace:mydbcode.sqglcleanse

e To search for all paths that contain traces with cleanse as part of the name, type the following:
trace:cleanse

e To search for allissues that contain cleanse as part of any modifier, type the following:
cleanse

o To search for all suppressed vulnerabilities with asdf in the comments, type the following:
suppressed:true comments:asdf

o To search for all categories except for SQL Injection, type the following:

category:!SQL Injection

Performing Simple Searches

To use the search box to perform a simple search, do one of the following:

e Type asearch query in the search box and then press Enter.

& e
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Alternatively,

o To select a search term you used previously (during the current session), click the arrow in the search
box, and then select a search term from the list. (After you exit the IDE, saved search terms are
discarded.)

The Analysis Results window lists the query results (if any).

Performing Advanced Searches

You can use the advanced search feature to build complex search strings.

Note: Advanced search is not available when you remediate audit results that are stored on Micro
Focus Fortify Software Security Center.

To use the advanced search feature:

1. To theright of the search box, click the Advanced Search icon ﬂ
The Advanced Search dialog box opens.
2. From the first list on the left select a modifier.
If you plan to specify an unqualified search term, select Any Attribute from the modifier list.
3. From the middle list, select a comparison term.
4. Inthe combo box on the right, either type a search term, or select one from the list.

The search term list includes the known values in the current scan for the specified attribute.
However, you can type any value into this field.

To add an AND or OR row to the query, click the Add Criteria icon.
To set the operator, click either the AND or OR button.
Specify the modifier, comparison term, and search term.

Add as many rows as you need for the search query.

0 © N o U

To remove a row, to the right of the row, click Delete X
10. Toremove all rows, at the bottom of the dialog box, click Clear.

11. To submit your completed search query, click Find.

Note: The Find button is only enabled after you create a complete search query.

Auditing Scan Results

The security team examines Fortify Project Results (FPR) and assigns values to custom tags associated
with audit project issues during a code audit. The development team can then use these tag values to
determine which issues to address and in what order.

To enable project auditing out of the box, Micro Focus Fortify Software Security Center provides a
single default tag named Analysis. Valid values for the Analysis tag are Not an Issue, Reliability Issue,
Bad Practice, Suspicious, and Exploitable. You can modify the Analysis tag attributes, revise the tag
values, or add new values based on your auditing needs.
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To refine your audit process, you can define your own custom tags. For example, you could create a
custom tag to track the sign-off process for an issue. After a developer audits his own issues, a security
expert can review those same issues and mark each as “approved” or “not approved.” For more
information, see "Configuring Custom Tags for Auditing" on page 38.

You can also define custom tags from Fortify Software Security Center, either directly with issue
template uploads through Fortify Software Security Center, or through issue templates in audit project

files.

Note: Although you can add new custom tags as you audit a project, if these custom tags are not
defined in Fortify Software Security Center for the issue template associated with the application
version, then the new fags are lost if you upload the audit project (FPR) to Fortify Software
Security Center.

Auditing Issues

To evaluate and assign audit values to an issue or group of issues:

1

Select the issue or group of issues in the Analysis Results window.
For information about the Analysis Results window, see "Analysis Results Window" on page 16.

Read the abstract on the Summary tab, which provides high-level information about the issue,
such as the analyzer that found the issue.

For example, “Command Injection (Input Validation and Representation, data flow)” indicates that
this issue, detected by the Dataflow Analyzer, is a Command Injection issue in the Input Validation
and Representation kingdom.

Click the More Information link or the Details tab to get more details about the issue.

4. On the Summary tab, assign an Analysis value to the issue to represent your evaluation.

Specify values for any custom tags as required by your organization.

To enter a date in a date-type custom tag, click Select Date "/~ to select a date from a calendar.

If the audit results have been submitted to Audit Assistant in Micro Focus Fortify Software
Security Center, then you can specify whether to include or exclude the issue from Audit Assistant
training from the AA_Training list.

Note: If you select a different value for Analysis than the AA_Prediction value set by Audit
Assistant, and you select Include from the AA_Training list, then the next time the data is
submitted to Audit Assistant, it updates the information used to predict whether or not an
issue represents a true vulnerability. For more information about Audit Assistant, see the
Micro Focus Fortify Software Security Center User Guide.

(Optional) In the Comments box, add any comments relevant to the issue and your evaluation.
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Suppressing Issues

You can suppress issues that are either fixed or issues that you do not plan to fix.
To suppress an issue, do one of the following:

o Select the issue in the Analysis Results window, and then click Suppress icon on the Summary tab.

¢ Right-click the issue in the Analysis Results window, and then select Suppress.

Viewing Suppressed Issues
To review results that have been suppressed:

« On the Analysis Results toolbar, select the Visibility menu [l and then click Show Suppressed
Issues.

Submitting an Issue as a Bug

You can submit issues to your bug tracking application if integration between the applications has been
configured.

To submit an issue as a bug:

1. Inthe Analysis Results window, select an issue.
2. Inthelssue Auditing window, click the Summary tab, and then click File Bug.

If this is the first time you are submitting a bug, the Select Bugtracker Integration dialog box opens.
Select the bug tracking application, and then click Select.

3. Specify the values if changes are needed and review the issue description.
Depending on the integration and your bug fracking application, the values include items such as
product name, severity level, summary, and version.

4. Click File Bug.

You must already be logged on before you can file a bug through the user interface for bug tracking
systems that require a logon. The issue is submitted as a bug in the bug tracking application.

About Issue Templates

Micro Focus Fortify Static Code Analyzer produces comprehensive results for source code analysis. On
large codebases, these results can be overwhelming. Issue templates provide features to sort and filter
the results in ways that best suit your needs. The filtering and sorting mechanisms appropriate during a
given phase in the development process can change depending on the phase of development. Similarly,
the filtering and sorting mechanisms might vary depending on the role of the user.

You can sort issues by grouping issues into folders, which are logically defined sets of issues presented
in the tabs on the Analysis Results window. You can further customize the sorting by providing custom
definitions for the folders into which the issues are sorted. You can provide definitions for any number
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of folders, whose contents are then defined by filters. Filters can either alter the visibility of an issue or
place it into a folder. When used to sort issues info folders, you can define the nature of the issues that
appear in the customized folders.

You group filters into filter sets and then use the filter sets to sort and filter the issues displayed. An
issue template can contain definitions for multiple filter sets. Using multiple filter sets in an audit project
enables you to quickly change the sorting and visibility of the issues you are auditing. For example, the
default issue template used in the interface provides two filter sets. These filter sets provide an
increasingly restrictive view of security-related issues. Defining multiple filter sets for an audit project
enables different users different views, and a customized view does not affect any other views.

In addition to providing sorting and filtering mechanisms, you can also customize the auditing process
by defining custom tags in the issue template. Auditors associate custom tags with issues during the
audit. For example, you can use custom tags to track impact, severity, or priority of an issue using the
same names and values used to track these attributes in other systems, such as a bug tracking system.

Issue templates contain the following settings:

o Folder filters—Conftrol how issues are sorted into the folders

o Visibility filters—Control which issues are shown and hidden

o Filter sets—Group folder and visibility filters

o Folder properties—Name, color, and the filter set in which it is active

o Custom tags—Specify which audit fields are displayed and the values for each
The issue template applied to a project uses the following order of preference:

1. Thetemplate that exists in the audit project.

N

The template <sca_install dir>\Core\config\filters\defaulttemplate.xml

W

The template <sca_install_dir>\Core\config\rules\defaulttemplate.xml
The embedded Fortify default template

&

Saving Issue Templates

Once an issue template is associated with an audit project, all changes made to that template, such as
the addition of folders, custom tags, filter sets, or filters, apply to the audit project, and the issue
template is stored in the FPR when the project is saved. For information about how o change the issue
template associated with an audit project, see "Importing Issue Templates" on the next page.

Exporting Issue Templates

Exporting an issue template creates a file that contains the filter sets and custom tags for the current
audit project. This is useful if you want to import the issue template into another audit project file.

To export an issue template:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.
2. Click the Filter Sets tab.
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3. Click Export Issue Template.
4. Browse to the location where you want to save the file.
5. Type a file name without an extension, and then click Save.

The template settings are saved to the new XML file.

Importing Issue Templates

Importing an issue template overwrites the project configuration settings. The filter sets and custom
tags are replaced with the ones in the issue template.

To import an issue template:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.

2. Click the Filter Sets tab.

3. Click Import Issue Template.

4. Select the issue template file to import.

The filter sets and custom tags are updated.

To revert to the default issue template settings, click Reset Issue Template to Default.

Configuring Custom Tags for Auditing

Custom tags enable auditors to set additional attributes that describe the issue. You can use custom tag
values to filter and find issues.

The Analysis tag is configured by default and when you apply the Analysis tag to an issue, the icon in
the Analysis Results issue list indicates the analysis status.

To refine your auditing process, you can define your own custom tags. You can create the following
types of custom tags: list, decimal, string, and date. For example, you could create a list-type custom tag
to track the sign-off process for an issue. After a developer audits his own issues, a security expert can
review those same issues and mark each as “approved” or “not approved.”

After you define a custom tag, the Summary tab displays it below the Analysis tag, which enables you
to specify values as they relate to specific issues. The tag is also available in other areas of the interface,
such as in the Group By list as a way to group issues in a folder, in the search field as a search modifier
(similarly available as a modifier for filters), and in the project summary graph as an attribute by which to
graphically sort issues.
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Creating a Custom Tag

You can create custom tags to use when you audit results. Custom tags are saved as part of an issue
template.

To create a custom tag:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.
2. Click the Custom Tags tab.

3. Next to Tags, click Create Tag " ..

Note: Previously deleted tags are listed, and you can re-enable them. To create a new tag, click
Create New.

4. Inthe Create New dialog box, type a name for the tag.
5. From the Type list, select the type of tag. The following tag types are available:

o List—Accepts selection from a list of values that you specify for the tag
o Date—Accepts a calendar date
o Decimal—Accepts a number with a precision of up to 18 (up to 9 decimal places)

o Text—Accepts a string with up to 500 characters (HTML/XML tags and newlines are not
allowed)
6. Click OK.
The Tags list now includes the new tag.
7. To add avalue for a list-type tag, do the following:
a. Fromthe Tags list, select the tag.

b. Next to Values, click Add Value '~ .
¢. Inthe Add Value dialog box, type a value, and then click OK.
d. To use this value as the default for the new tag, select Default.
If no default is selected, the default value is empty.
e. To add adescription for the value, enter it in the Description box.

f. Repeat steps a through e until you have added all the tag values.

Deleting a Custom Tag
If you delete a custom tag, it is no longer available on the Summary tab and from the filter options.

Warning: If you delete a custom tag that was set for any issues, that tag and values are removed
from the issue.
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To delete a custom tag:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.

2. Click the Custom Tags tab.

3. Select the tag from the Tags list.

4. Next to Tags, click Delete Tag " ..

If you delete a tag that has an associated filter, you are prompted to also delete the filter.

Creating a Filter Set

To create a new filter set, copy an existing set and modify the settings.
To create a new filter set:

1. Select Fortify > Project Configuration.
2. Click the Filter Sets tab.

r

"3, Project Configuration Tl =

Fiter Sets | Folders ] Custom Tags

Filter Sets: (-] [+]] Neme:
Security Auditor View
Quick View Description:
Reset lssue Template to Default | | Impor Issue Template.. | | Bxport Issue Template. .

OK

Next to Filter Sets, click Create Filter Set .* .
In the Create New Filter Set dialog box, enter a name for the new filter set.

Select an existing filter set to copy, and then click OK.

o U & W

To change the description of the new filter set, select it in the Filter Sets list, and then edit the text
in the Description box on the right.

A new filter set with the same folders, visibility filters, and folder filters as the copied filter set is created.

Creating a Filter from the Analysis Results Window

If you find an issue in a folder list that you want to hide or direct to another folder, you can create a new
filter with the filter wizard. The wizard displays all the attributes that match the filter conditions.
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Note: To find the filter that directed the issue to the folder, right-click the issue, and select Why is
this issue here? To find the filter that hid an issue, right-click the issue, and then select Why is
this issue hidden?

To create a new filter from an issue:

1.
2.

In the Analysis Results window, select a filter set from the Filter Set list.
Right-click an issue, and then select Generate Filter from the shortcut menu.
The Create Filter dialog box opens and displays a list of suggested conditions.

To expand the conditions list, click More Choices.

4, Select the conditions to use in the filter. You can fine tune the filter later from the Filter tab.

7.

To specify the type of filter you want to create, do one of the following:

o To create a visibility filter, select Hide Issue.

o To create a folder filter, select Set Folder to, and then select the folder name or select Create
New fo create a new folder.
A new folder is displayed only in this filter seft.

Click Create Filter.

The new filter is placed at the end of the filter list. For folder filters, this gives the new filter the
highest priority. Issues matching the new folder filter appear in the targeted folder.

To change the priority of a folder filter, drag the filter higher in the folder filter list.

Note: The filter is created only in the selected filter set.

Creating a Filter from the Filters Tab

Use the Filters tab option to create general filters for the attributes and values you want to filter. The
filter is created in the selected filter set only.

Folder filters are applied in order and the issue is directed to the last folder filter it matches in the list.
The wizard places your new filter at the end of the list.

To create a new filter on the Filters tab:

1.
2.

From the Filter Set list, select a filter set.

Right-click Visibility Filter or Folder Filter, and then select Create New Filter from the shortcut
menu.

From the first list, select an issue attribute.

4. From the second list, select a value to specify how to match the value.

The third list automatically displays the attribute values.

5. From the third list, select a value or specify a range as instructed in the If line.

6. Set Then to one of the following options:

o To create a visibility filter, select Hide Issue.

e To create a folder filter, select Set Folder to, and then select the folder name or select Create
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New fo create a new folder.

The new filter displays at the end of the list. For folder filters, this gives the new filter the highest
priority. Issues that match the new folder filter are displayed in the targeted folder.
7. To change the priority, drag the filter higher in the folder filter list.
The issues are sorted based on the new filter.

Note: The filter is created in the selected filter set only.

Copying a Filter to Another Filter Set

Filter settings are local to the filter set. However, you can copy the filter to another filter set in the
project. If you copy a folder filter to another filter set and that folder is not already active in the filter set,
the folder is automatically added.

To copy a filter:

1. FromtheFilter Set list, select a filter set.

2. On theFilters tab, right-click a filter, and then select Copy Filter To from the shortcut menu.
The Select a Filter Set dialog box lists the filter sets.

3. Select afilter set, and then click OK.
The filter is added to the destination filter set in the last position.

4, To change the order of the folder filters, drag and drop the filters in the list.

Managing Folders

Folders are logical sets of issues that are defined by the filters in the active filter set. Even though a
folder can appear in more than one filter set, the contents might differ depending on the filters in that
filter set that target the folder. To accommodate filter sets that attempt to provide sorting mechanisms
that have little overlap, it is possible to have filter sets with different folders. Folders are defined without
any relation to the filter sets in which they might appear.

Creating a Folder

You can add a new folder to a filter set so that you can display a group of issues you have filtered to the
folder.

To create a folder:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.
2. Click the Folders tab.

Currently defined folders are listed on the left. Fields that indicate the name, color, and description
of the selected folder are on the right.
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-

"3, Project Configuration L%l z=
| Fiter Sets | Folders | Custom Tags|

Folders for Flter Set: | (A Folders) v
Folders: [+ ]| Name: ] Defauit Folder
Citical Crtical
High Color:
Mecium | Citical Changs Cobr ..
Low (default) Description:

This folder provides a comprehensive list of issues in the
application with a high impact and high likelihood.

OK

3. To associate the new folder with an existing filter set, select a filter set from the Folders for Filter
Set list.
This selection updates the Folders list to display folders associated with the selected filter set.

4. To add afolder:

a. Next to Folders, click Create Folder . .
The Create New Folder dialog box opens.
b. Enter a unique name for the new folder, select a folder color, and then click OK.
The folder is added to the bottom of the Folders list.
5. To sort allissues that do not match a folder filter into this folder, select Default Folder.
6. Click OK.

The new folder is added to the local issue template. The folder displays as a tab with the other folders in
the Analysis Results window.

Note: To display issues in this folder, create a folder filter that targets the new folder (see "Creating
a Filter from the Analysis Results Window" on page 40 and "Creating a Filter from the Filters Tab"
on page 41).

Adding a Folder to a Filter Set

This section describes how to enable an existing folder in a filter set. Create a new folder that only
appears in the selected filter set using the instructions in "Creating a Folder" on the previous page. To
display issues in this folder, create a folder filter that targets the new folder.
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To add a folder to a filter set:

1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.

2. Click the Folders tab.

3. Fromthe Folder for Filter Set list, select a filter set to which you want to add an existing folder.
This selection updates the Folders list to display folders associated with the selected filter set.

4, Next to Folders, click +.*

The Enable New Folder to the Filter Set dialog box opens. If all folders are already associated with
the selected filter set, the Create New Folder dialog box opens.

5. Select the folder to add, and then click Select.
The selected folder is listed.
6. Click OK.
The folder is displayed as a tab with the other folders in the Analysis Results window.

Renaming a Folder

You can rename a folder. Modifying the name of a folder is a global change reflected in all filter sets.
To rename a folder:
1. Select Fortify > Project Configuration.
The Project Configuration dialog box opens.
2. Click the Folders tab.
3. Fromthe Folders for Filter Set list, select a filter set that displays the folder you want to rename.
4. Select the folder in the Folders list.
The folder properties are displayed on the right.
5. In the Name box, type the new folder name.
6. Click OK.

The tab displays the new folder name.

Removing a Folder

You can remove a folder from a filter set without removing it from the other filter sets.
To remove a folder:

1. Select Fortify > Project Configuration.
2. Click the Folders tab.
3. Fromthe Folders for Filter Set list, select a filter set that contains the folder you want to remove.

The folders in the selected filter set are listed.
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4. Next to Folders, select the folder, and then click -.
The folder is removed only from the selected filter set.

If the folder is a target of a folder filter, the Conflicts Occurred Removing Folder dialog box opens.

P

r=‘ Conflicts Occurred Removing Folder ... | 22 |

The folder Audited is the target of the following fitters:
i Analysis containg suspicious Then set folder to Audited

Retarget the filters: I - I

Retarget Fiters | | Delete Fiters | | Cancel

Do one of the following:

o To target the filter to a different folder, select a folder from the Retarget the filters list, and
then click Retarget Filters.

o To delete the filter, click Delete Filters, and then click Yes to confirm the deletion.

5. Click OK to close the Project Configuration dialog box.

The folder is no longer displayed as a tab.

Scan Results Reports

The following topics provide information about generating BIRT and legacy reports for your scan
results, and how to work with legacy Fortify report templates.

About BIRT Reports

The following table describes the BIRT reports available.

Report Template Description

CWE/SANS Top 25 = This report details findings related to the CWE/SANS Top 25 most dangerous
programming errors uncovered and provides information about where and
how to address the findings.

Developer This report, which is targeted at project managers and developers, contains all

Workbook of the information needed to understand and fix issues discovered during an
audit.

DISA CCI 2 This report provides a standard identifier for policy based requirements which

connect high-level policy expressions and low-level technical implementations.
The status of a CCl is considered "In Place" when there are no issues reported
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Report Template

DISA STIG

FISMA Compliance:
FIPS-200

OWASP Mobile
Top 10

OWASP Top 10

PCI DSS
Compliance:
Application
Security
Requirements

Description

for a given CCI. If the project is missing a Fortify Static Code Analyzer scan, or
the scan contains findings that have not been fixed, hidden or suppressed,
CCI-003187 is not considered "In Place." Similarly, if the project is missing a
Micro Focus Fortify Weblnspect scan, or the scan contains any critical findings,
CCI-000366 and CCI-000256 are not considered "In Place."

This report addresses DISA compliance STIG violations It includes information
about where and how to fix the issues, and describes the technical risks posed

by unremediated violations. The report also includes an estimate of the effort

required to fix, verify, and test the findings.

This report addresses FISMA compliance through FIPS-200 violations
detected. It provides information about where and how to fix the issues and
describes the technical risks posed by unremediated violations. The report also
includes an estimate of the effort required to fix, verify, and test the findings.

This report details the top ten OWASP mobile-related findings. It provides
information on where and how to fix specific issues and describes the technical
risk posed by the unremediated findings. The reports also provide estimates of
the effort required to fix, verify, and test the findings.

This report details the top ten OWASP-related findings. It provides
information about where and how to fix the issues and describes the technical
risks posed by unremediated violations. The reports also provides estimates of
the effort required to fix, verify, and test the findings.

This report summarizes the application security portions of PCI DSS. It
includes tests for 21 application security-related requirements across sections
3,4, 6,7,8,and 10 of PCI DSS and reports whether each requirement is either
“In Place” or “Not In Place.”

Generating BIRT Reports

To generate areport:

1. Select Fortify > Generate BIRT Report.
The Generate BIRT Report dialog box opens.
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(3] Generate BIRT Report | o || = | &
BIRT Report
Feport Template:
[ Developer Workbook -

[] ey Teminology

nclude the ‘Description of Key Tem

I
i
[

[] About Fortify Solutions

Frrtife Soh ticrns sactinm

0e the Ao ¥ Ll

lzsue Filter Settings

] Removed [] Suppressed [7] Hidden

Collapse |ssues [] Cnby My lssues

Fitter: Advanced...

Fomat: POF -

Location:  C:\MyFeports'ProjectAlSample1 Developer Workboolk p
Generate ] [ Cancel ]

From the Report Template menu, select the type of report you want.
If available for the femplate, select the template version.
4. Select the information you want to include in the report.

Note: Not all options are available for all report types.

a. Toinclude detailed descriptions of reported issues, select the Detailed Report check box.

b. To categorize issues by Fortify Priority instead of folder names, select the Categories By
Fortify Priority check box.

¢. Toinclude Description of Key Terminology in the report, select the Key Terminology check
box.

d. Toinclude the About Fortify Solutions section in the report, select the About
Fortify Solutions check box.

5. To filter information from the report, select the optional issue filter settings as follows:
¢ Click Removed to include removed issues in the report.

o Click Suppressed to include suppressed issues in the report.
¢ Click Hidden to include hidden issues in the report.
o Click Collapse Issues to collapse issues of the same sink and type into a single issue.

¢ Click Only My Issues to include only issues assigned to your user name.

Micro Focus Fortify Extension for Visual Studio (18.20) Page 47 of 70



User Guide
Chapter 2: Using the Fortify Extension for Visual Studio

¢ Click Advanced to build a search query to further filter the issues to include in the report. For
more information about the search modifiers, see "Search Modifiers" on page 29.

Click the Format menu to select the format for the report (PDF, HTML, DOC, or XLS).

Note: When you open the XLS file in Excel, you might get a warning that the file format and
the file extension do not match. You can safely open the file in Excel.

To specify an alternate location to save the report, click Browse and select a location.

8. Click Generate.

If a report with the same file name already exists, you are prompted to either:

o Click No to overwrite the existing report.

o Click Yes to have the report saved to a file with a sequential number appended to the file name
(for example: Samplel DISA STIG(1).pdf).

About Legacy Reports

The legacy reports include user-configurable report templates. Report templates provide several
optional sections and subsections that gather and present specific types of data. The following sections
provide information about the default reports and report templates, instructions on how to modify
existing reports, and how to create your own reports.

Running Legacy Reports

After you select the report template and report settings, you generate the report to view the results.
You can save report results as PDF, RTF, and XML files.

To runareport:

1.

N o U WD

Select Fortify > Generate Legacy Report.

The Generate Legacy Report dialog box opens.
From the Report list, select a report template.
(Optional) Change the report section settings.

Click Print Report.

Specify a file name and a location to save the report.
Select the report file format (PDF, RTF, or XML).
Click Save.

Opening Legacy Report Templates

To open a report template:

1

2.

Select Fortify > Generate Legacy Report.
The Generate Legacy Report dialog box opens.
Select a report template from the Report list.

The report template settings display in the Generate Legacy Report dialog box.
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Legacy Report Templates

This section provides information about how to select and edit a legacy report template. If you or
another user have edited or created additional legacy report templates, you might not see the default
report templates as described in this section.

The legacy report templates include:
o Fortify Developer Workbook— A comprehensive list of all categories of issues found and multiple
examples of each issue. It also gives a high-level summary of the number of issues in each category.

« Fortify Security Report—This report, which is designed for project managers, includes
comprehensive analysis information and high-level audit details (if the auditor provided these). The
Fortify Security Report also provides a high-level description and examples of categories that are of
the highest priority.

« Fortify Scan Summary—Provides high-level information based on the category of issues that Micro
Focus Fortify Static Code Analyzer found as well as a project summary and a detailed project
summary

« OWASP Top Ten <year>—Provides a high-level summary of vulnerabilities. These reports organize
vulnerabilities on the top ten issues identified by the Open Web Security Project (OWASP) in the
respective year. This report type includes report overview, issues broken down by OWASP top ten,
and results outline sections.

Selecting Legacy Report Sections
You can choose which sections to include in the report.
To select the sections to include in a report:

1. Select each section title check box in the list on the left side to include the section in the report.
2. Click a section title fo view the contents of the section.

The section details display in the right side of the dialog box. For details on how to edit each section, see
"Editing Legacy Report Subsections" below.

To remove a section from the report, clear the check box next to the section ftitle.

Editing Legacy Report Subsections

When you select a section title, you can edit the contents that display in the report. You can edit text,
add or change text variables, or customize the issues shown in a chart or results list. The following
sections describe how to perform these tasks:

Editing Text Subsections
To edit a text subsection:

1. Select the check box next to the subsection fitle to include this text in the report.
A description of the text is displayed below the subsection title.
2. Click Edit.
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The text box displays the text and variables to be included in the report.
3. Edit the text and text variables.

As you edit text subsections, you can insert variables that are defined when you run the report. These
variables are described in the following table.

Variable

SAUDIT_GUIDE_
SUMMARYS$

SCLASSPATH_
LISTINGS

SCOMMANDLINE_
ARGSS

SFILE_LISTINGS

SFILTERSET_
DETAILSS

SFILTERSET_NAMES

SFORTIFY_SCA_
VERSIONS

SLIBDIR_LISTINGS
$LOCS
SNUMBER_OF_FILESS

SPROJECT_BUILD_
LABELS

SPROJECT_NAMES

SPROPERTIESS

SRESULTS_
CERTIFICATIONS

SRESULTS_
CERTIFICATION_
SUMMARYS$

SRULEPACKSS

SRUN_INFOS

Description

List of filters created by answering Audit Guide questions

JAR files used during scan, one relative path per line

Complete list of command-line arguments (same format as project
summary)

List of files scanned, each file in the following format:
<relative_file path> # Lines # kb <timestamp>

List of filters in use by current filter set

Name of current filter set

Micro Focus Fortify Static Code Analyzer version

Libdirs specified during scan, one relative path per line
Total lines of code
Total number of files scanned

Build label of project

Build ID

Complete list of properties set during analysis phase (same format as
project summary)

Complete certification detail with list of validity on a per file basis (see
project summary)

Short certification description (same format as project summary)

Complete list of Rulepacks used during analysis (same format as project
summary)

Content from the Project Summary Runtime Information tab
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Variable

SSCAN_COMPUTER_

ID$

SSCAN_DATES
$SCAN_SUMMARY$
$SSCAN_TIMES
$SCAN_USER$S

$SOURCE_BASE_
PATHS

STOTAL_FINDINGSS

SVERSION_LABELS

SWARNINGSS

SWARNING_
SUMMARYS$

Description

Hostname of the machine on which the scan was performed

Date of analysis with the default formatting style for the locale

Summary of codebase scanned in format # files, # lines of code
Time of analysis phase

User name of the user who performed the scan

Source base path of codebase

Number of findings, not including suppressed or removed issues

Visual Studio displays build-label when each FPR file that Fortify Static
Code Analyzer generated passes build version with build-version

Complete list of warnings issued (same format as project summary)

Number of warnings found in scan

Editing Results List Subsections

To edit a result list subsection:

1. Select the check box next to the subsection title to include this text in the report.

A description of the results list is displayed below the subsection title.

2. Click the issues list heading to expand the options.

3. Select the attributes used to group the results list.

If you group by category, the recommendations, abstract, and explanation for the category are also
included in the report.

(Optional) Refine the issues shown in this subsection by using the search function. (See "Searching
for Issues" on page 28.)

5. Select or clear the Limit number of Issues in each group check box.

6. If you select the check box, type the number of issues to display per group.

Editing Chart Subsections

To edit a chart subsection:

1.

Micro Focus Fortify Extension for Visual Studio (18.20)

Select the check box next to the subsection title to include this text in the report. A chart
description is displayed below the subsection title.

Select the attributes to use to group issues in the chart.

You can refine the issues shown in this subsection by using the search function. (For information
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about search syntax, see "Searching for Issues" on page 28.)
3. Select the chart format (table, bar chart, or pie chart).

Saving Legacy Report Templates

You can save the current report settings as a new template that you can select at a later time to run
more reports.

To save settings as a report femplate:

1. Select Fortify > Generate Legacy Report.
The Generate Legacy Report dialog box opens.
2. Fromthe Report list, select a report template.
3. Make changes to the report section and subsection settings.
4. Click Save as New Template.

When you select the report template name from the Report list, the report settings are displayed in the
Generate Legacy Report dialog box.

Saving Changes to Legacy Report Templates

You can save changes to a report template so that your new settings are displayed as the default
settings for that femplate.

To save changes o a report template:

1. Select Fortify > Generate Legacy Report.
The Generate Legacy Reports dialog box opens.
2. Fromthe Report list, select the report template to save as the default report template.
3. (Optional) Make changes to the report section and subsection settings.
4. Click Save Settings as Default.

Editing Legacy Report Template XML Files

Report templates are saved as XML files. You can edit the XML files to make changes or to create new
report template files. When you edit the XML files, you can choose the sections and the contents of
each section to include in the report template.

The default location for the report template XML files is <sca_install_dir>\Core\config\reports.

You can also customize the logos to use in the reports by specifying paths or replacing header. jpg
and footer. jpgin this directory.
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Adding Legacy Report Sections

You can add report sections by editing the XML files. In the structure of the XML, the ReportSection
tag defines a new section. It includes a Tit1le tag for the section name, and it must include at least one
Subsection tag to define the section contents in the report. The following XML is the Results
Outline section of the Fortify Security Report:

<ReportSection enabled="false" optionalSubsections="true">
<Title>Results Outline</Title>
<SubSection enabled="true">
<Title>Overall number of results</Title>
<Description>Results count</Description>
<Text>The scan found $TOTAL_FINDINGS$ issues.</Text>
</SubSection>
<SubSection enabled="true">
<Title>Vulnerability Examples by Category</Title>
<Description>Results summary of the highest severity
issues.Vulnerability examples are provided by category.
</Description>
<Issuelisting limit="1" listing="true">
<Refinement>severity:(3.0,5.0] confidence:[4.0,5.0]</Refinement>
<Chart chartType="1list">
<Axis>Category</Axis>
</Chart>
</Issuelisting>
</SubSection>
</ReportSection>

In this example, the Results Outline section contains two subsections. The first is a text subsection
titled Overall number of results. The second subsection is aresults list titled Vulnerability
Examples by Category. A section can contain any combination of subsections.

Adding Report Subsections

In the report sections, you can add subsections or edit subsection content. Subsections can generate
text, results lists, or charts

Micro Focus Fortify Extension for Visual Studio (18.20) Page 53 of 70



User Guide
Chapter 2: Using the Fortify Extension for Visual Studio

Adding Text Subsections

In a text subsection, you can include the Title tag, the Description tag, and the Text tag. In the

Text tag, you can provide the default content although the user can edit the content before generating
areport. For a description of the text variables available to use in text subsections, see "Editing Legacy

Report Subsections" on page 49. The following XML is the Overall number of results subsection
in the Results Outline section:

<SubSection enabled="true">
<Title>Overall number of results</Title>
<Description>Results count</Description>
<Text>The scan found $TOTAL_ FINDINGS$ issues.</Text>
</SubSection>

In this example, the text subsection is titled Overall number of results. The textthat describes
the purpose of the text isResults count. The text in the text field that the user can edit before
running a report uses one variable named $TOTAL_FINDINGSS.

Adding Results List Subsections

In a results list subsection, you can include the Title tag, the Description tag, and the
Issuelistingtag.Inthe Issuelisting tag, you can define the default content for the limit and set

listingto true.You caninclude the Refinement tag either with or without a default statement
although the user can edit the content before they generate a report. To generate a results list, the

Chart tag attribute chartType is set to 1ist. You can also include the Axis tag. The following XML is
theVulnerabilities Examples by Category subsectionintheResults Outline section

<SubSection enabled="true">
<Title>Vulnerability Examples by Category</Title>
<Description>Results summary of the highest severity issues.
Vulnerability examples are provided by category.</Description>
<Issuelisting limit="1" listing="true">
<Refinement>severity:(3.0,5.0] confidence:[4.0,5.0]</Refinement>
<Chart chartType="1list">
<Axis>Category</Axis>
</Chart>
</Issuelisting>
</SubSection>

In this example, the results list subsection is fitled Vulnerability Examples by Category. The
text used to describe the purpose of the subsection is Results summary of the highest
severity issues. Vulnerability examples are provided by category. Thissubsection
lists (1isting=true) oneissue (1imit="1") per category (the value of the Axis tag) where there are
issues matching the statement severity:(3.0,5.0] confidence:[4.0,5.0] (the value of the
Refinement tag).
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Adding Charts Subsections

In a chart subsection, you can include the Title tag, the Description tag, and the Issuelisting
tag.In the Issuelisting tag, you can define the default content for the limit and set 1istingto
false. You caninclude the Refinement tag either with or without a default statement although the
user can edit the content before generating a report. To generate a pie chart, set the Chart tag
attribute chartType to pie. The options are table, pie, and bar. The user can change this setting
before generating the report. You can also define the Axis tag.

The following code shows an example of a charts subsection:

<SubSection enabled="true">
<Title>New Issues</Title>
<Description>A list of issues discovered since the previous
analysis</Description>
<Text>The following issues have been discovered since the
last scan:</Text>
<Issuelisting limit="-1" listing="false">
<Refinement />
<Chart chartType="pie">
<Axis>New Issue</Axis>
</Chart>
</Issuelisting>
</SubSection>

In this subsection, a chart (1imit="-1" listing="false") hasthe title New Issues and a text
section that contains The following issues have been discovered since the last scan
This chart includes all issues (the Refinement tag is empty) and groups the issues based on the value
of New Issue (the value of the Axis tag). A pie chart (chartType="pie")is displayed.

Working with Audit Projects

This section provides information about how to open an audit project, migrate audit data, merge audit
data, audit projects collaboratively, and upload audit results to Micro Focus Fortify Software Security
Center.

Opening Audit Projects

To open an audit project file:

1. Open asolution or project.

2. Select Fortify > Open Audit Project.
3. Browse to and select the FPR file.

4. Click Open.
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5. If the source code is not available in the FPR, you are prompted to select the root directory for your
project's source code. Select the root directory, and then click OK.

The Fortify Extension for Visual Studio displays the project in the auditing interface.

About Merging Audit Data

You can merge audit data into your project from another file. Audit data includes the custom tags and
comments that were added to an issue. Comments are merged into a chronological list, while the custom
tag values are updated.

Note: Issues are not merged. Only the newer scanned issues are shown. Issues in the older file that
are not in the newer file are marked as removed and hidden by default.

Make sure that the projects you merge contain the same analysis information, that the scan was on the
same source code (no missing libraries or files), the Micro Focus Fortify Static Code Analyzer options
were the same, and the scan was performed with the same set of Secure Coding Rulepacks and custom
Rulepacks.

Merging Audit Data

To merge audit projects:

1. Open an audit project in Visual Studio.
2. Select Fortify > Merge Audit Projects.
The Select Audit Project dialog box opens.
3. Select an audit project (FPR file), and then click Open.
The Merge dialog box opens.
4. To confirm the number of issues added or removed from the file, click OK.

Note: If the scan is identical, the process does not add or remove issues.

The audit project now contains all audit data from both files.

Performing a Collaborative Audit

You can audit a project on Micro Focus Fortify Software Security Center collaboratively with other
Fortify Software Security Center users.

To start a collaborative audit:

1. If necessary configure a connection to Fortify Software Security Center:
a. Select Fortify > Options.
b. Click Server Configuration.

¢. Under Software Security Center Configuration, specify the Server URL for Fortify Software
Security Center (for example, http://111.0.0.1:8181/ssc).
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5.
6.

d. If necessary, specify the proxy server and port number.

e. Click OK.

Select Fortify > Open Collaborative Audit.

If you already have an audit project open, close it.

If prompted, enter your Fortify Software Security Center login credentials:

a. Fromthe Login Method menu, select the login method set up for you on Fortify Software

Security Center.

b. To save your login information, select the Save Login Method check box.

The Fortify Extension for Visual Studio saves your login information for all future use of this
extension until you install a new Fortify Extension for Visual Studio.

c. Depending on the login method you selected, do one of the following:

Login Method

Username/Password

X.509 SSO

Kerberos SSO

Procedure

Type your Fortify Software Security Center username and
password.

Fortify Software Security Center must be configured to use X.509
Certification-based SSO.

Note: Your certificate must be located in the current user
certificate store and in the Personal store.

i. Click Browse for Certificate "=,
ii. Select the certificate for the sign-on, and then click OK.
Fortify Software Security Center must be configured to use

SPNEGO-based Kerberos authentication. No additional
information is required.

d. Click OK to connect to Fortify Software Security Center.

In the Download Collaborative Audit dialog box, select an application version, and then click Select.

The audit project file is downloaded from Fortify Software Security Center and opened in the
Fortify Extension for Visual Studio.

Audit the project as described in "Auditing Issues" on page 35.

When you have completed the audit, select Fortify > Upload Audit Project.

Note: If necessary, update your audit permission settings from Fortify Software Security Center by
selecting Fortify > Refresh Permissions.
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Uploading Results to Fortify Software Security Center

To upload results fo Micro Focus Fortify Software Security Center:

1. If necessary configure a connection to Fortify Software Security Cenfter:

a. Select Fortify > Options.

b. Click Server Configuration.

¢. Under Software Security Center Configuration, specify the Server URL for Fortify Software

Security Center (for example, http://111.0.0.1:8181/ssc).

d. If necessary, specify the proxy server and port number.

e. Click OK.
2. Select Fortify > Upload Audit Project.
3. If necessary, enter your Fortify Software Security Center credentials.

The Upload Audit Project dialog box lists the current applications.
4. Select an application version, and then click Select.

Note: If you are working on a collaborative audit for an application you just downloaded, then

the audit project is automatically uploaded to the same application version. You are not
prompted to select an application.

About Updating Security Content

To optimize the Fortify Extension for Visual Studio functionality to scan with Micro Focus Fortify Static
Code Analyzer, you must have complete and up-to-date security content. First configure how you plan
to obtain security content updates (see "Configuring Security Content Updates" on the next page).
Then you can obtain the latest security content by doing one of the following:

o "Updating Security Content" on the next page

o "Scheduling Automatic Security Content Updates" on the next page

o "Manually Updating Security Content" on page 60

Note: When you update security content, the previous security content files are overwritten.

You can also import custom rules from the Fortify Extension for Visual Studio (see "Importing Custom
Rules" on page 60).
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Configuring Security Content Updates

Before you update security content, configure the server information to use for security content
updates. To update security content manually (without an Internet connection or Micro Focus Fortify
Software Security Center), see "Manually Updating Security Content" on the next page.

To configure the security content update server:

1. Select Fortify > Options.
The Options dialog box opens to the Server Configuration section.
2. Under Security Content Update, select one of the following:
o To update security content from your Fortify Software Security Center instance, select the
Update Security Content from Software Security Center check box.

o To specify an update server from which to update security content, select the Use Custom
Server Settings check box.

3. If you selected the Use Custom Server Settings check box, do the following:
a. Inthe Server URL box, type the URL for the update server.

b. If required, in the Proxy Server and Port boxes, type the proxy server and port number,
respectively.

Updating Security Content

To update security content from the update server:

1. Select Fortify > Options.
2. Inthe left panel, select Security Content Management.
3. Click Update.
If new content is available, it is updated and listed under Installed Fortify Security Content.
4, Click OK.

Scheduling Automatic Security Content Updates

To schedule automatic security content updates:

1. Select Fortify > Options.

2. In the left panel, select Server Configuration.

3. Under Security Content Update, select the Update security content automatically check box.
4

. In the Update Frequency (Days) box, specify how often the security content is to be updated, and
then click OK.
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Manually Updating Security Content

You can manually update security content from a local ZIP file with the fortifyupdate utility.
To manually update the security content:

1. Open a command prompt, and then navigate to the <sca_install_dir>\bin directory.

2. Type fortifyupdate.cmd -import <zipfile>.

For more information about the fortifyupdate utility, see the Micro Focus Fortify Static Code Analyzer
User Guide.

Importing Custom Rules

You can import custom rules to use in your scans. Fortify Extension for Visual Studio imports custom
rulesto the<sca install dir>\Core\config\customrules directory.

Note: To import custom external metadata, place your external metadata file in the <sca_
install dir>\Core\config\CustomExternalMetadata directory.

To import custom rules:

1. Select Fortify > Options.
2. Inthe left panel, select Security Content Management.
3. Click Import.

The Select Security Content dialog box opens.

4. Browse to and select a *.xml or *.bin file to import.
The imported file is listed under Installed Custom Security Content.

5. Click OK to close the Options dialog box.

Integrating with a Bug Tracker Application

The Fortify Extension for Visual Studio provides a plugin interface to integrate with bug tracker
applications. This enables you to file bugs directly from the Fortify Extension for Visual Studio.

If you installed the samples with the Static Code Analyzer and Applications installation, an example
plugin exists for Bugzilla. You can select the bug tracker plugin with the dialog box that opens when
you file your first bug.

Filing Bugs to Team Foundation Server

The Fortify Extension for Visual Studio supports integration with bug tracker applications so that you
can file bugs directly to Team Foundation Server (TFS).
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To file abug to TFS:

1. Open an audit project in Visual Studio.

AN

In the Analysis Results window, select an issue.
In the Issue Auditing window, click the Summary tab, and then click File Bug.

If this is the first time you have filed a bug to TFS, the Select Bugtracker Plugin dialog box opens.
Do the following:

a. Select Team Foundation Server Plugin, and then click Select.

b. Inthe Connect to Team Foundation Server dialog box, select a server, and then click Connect.
Specify the following information for your TFS installation:

Project: <project_name>

Workltem Type: Bug

Click OK.

7. (Optional) In the Team Foundation Server Plugin dialog box, provide the information to file the

bug report.
Click File Bug.

Using the Debug Option

If you encounter any errors, you can enable the debug option to help troubleshoot.

To enable debugging:

1.

Navigate to the <sca_install_dir>\Core\config directory and open the
fortify.properties file.

You can either enable debug mode for all Fortify Software components or for specific components.
Remove the comment tag (#) fromin front of the property and set the value to true.

Property Description
#com.fortify.Debug=false If set to true, all the Fortify Software components run in
debug mode.

#com.fortify.VS.Debug=false |If setto true, the Fortify Extension for Visual Studio
runs in debug mode.

For help to diagnose the problem, send the log files to Micro Focus Fortify Customer Support. On
Windows systems, the log files are located in the following directories:

e C:\users\<username>\AppData\Local\Fortify\sca<SCAversion>\log

e C:\users\<username>\AppData\Local\Fortify\VS<VSversion>-<SCAversion>\log
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You can download audit results for your code from Micro Focus Fortify Software Security Center so
that you can resolve security-related issues in Visual Studio.

This section contains the following topics:

Connecting to Fortify Software Security Center ... . 62
Working with Applications . .. 62
WoorKing With ISSUES . 65

Connecting to Fortify Software Security Center

Before you can access the audit results on Micro Focus Fortify Software Security Center, you need to
configure your connection to Fortify Software Security Center.

To connect to Fortify Software Security Center:

1. Select Fortify > Remediation Options.
The Remediation Options window opens.

2. On the Server tab, enter the URL for your Fortify Software Security Center server, and then click
OK.

If you are running the server on your local machine with port 8180, leave the default URL
(http://localhost:8180/ssc). Otherwise, substitute your Fortify Software Security Center IP
address for localhost and your port number for 8186.
For information on how fo access audit results on Fortify Software Security Center, see "Connecting to
a Fortify Software Security Center Application" on the next page.

Working with Applications

Applications in Micro Focus Fortify Software Security Center provide the security issues related to a
specific application. Applications organize these issues into folders based on filters.

Folders contain logically defined sets of issues. For example, you can group all critical issues for a project
into a Critical folder. Likewise, you can group all low-priority issues for the same audit project into a Low
folder.

Filters determine which issues are visible in the user interface. The filters are organized into filter sets.
An issue template can contain definitions for multiple filter sets. Using multiple filter sets in an audit
project enables you to quickly change the sorting and visibility of issues.
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Connecting to a Fortify Software Security Center Application

After you have configured a connection to Micro Focus Fortify Software Security Center (see
"Connecting to Fortify Software Security Center" on the previous page), you can select an application.

To select an application:

1. Select Fortify > Connect to SSC.
2. If prompted, enter your Fortify Software Security Center login credentials:

a. Fromthe Login Method menu, select the login method set up for you on Fortify Software
Security Center.

b. To save your login information, select the Save Login Method check box.

The Fortify Extension for Visual Studio saves your login information for all future use of this
extension until you install a new Fortify Extension for Visual Studio.

¢. Depending on the login method you selected, do one of the following:

Login Method Procedure

Username/Password Type your Fortify Software Security Center username and
password.

X.509 SSO Fortify Software Security Center must be configured to use X.509

Certification-based SSO.

Note: Your certificate must be located in the current user
certificate store and in the Personal store.

i. Click Browse for Certificate "=,
ii. Select the cerfificate for the sign-on, and then click OK.

Kerberos SSO Fortify Software Security Center must be configured fo use
SPNEGO-based Kerberos authentication. No additional
information is required.

d. Click OK to connect to Fortify Software Security Cenfter.

3. Inthe Select Application Version dialog box, select the application version you want to open, and
then click OK.

The Fortify Extension for Visual Studio sends a request to Fortify Software Security Center and
downloads the results for the application version you selected.

Viewing and Selecting Issues in an Application

When you connect to a Micro Focus Fortify Software Security Center application, the Fortify Extension
for Visual Studio downloads the issues for that application version. Fortify Software Security Center
provides a number of default folder types. Your view might be different, depending on whether your
organization has created custom folders.
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1. Inthe Fortify Remediation view, click the Filter icon to the right of the Group By list, and
then select Filter Set.

Fortify Remediation

Group By [EEte -

lzssues For: <All Users>

Critical (110} | High (89) | Medium (39) | Low (361) | All (599)

-] Command Injection - [0/ 15] FS
-] Cross-Site Scripting - [0/ 45]

D Cross-5Site Scripting: Persistent - [0/ 4]

{:| Cross-5ite Scripting: Reflected - [0 /12]

1 T Mlamaceair Cile Toclorine 0 F11

.

2. Select afilter to apply:

o Select Security Auditor View to list all issues relevant to a security auditor.

o Select Quick View to list only issues in the Critical folder (these have a potentially high impact
and a high likelihood of occurring) and the High folder (these have a potentially high impact and
a low likelihood of occurring).

Note: You might see different filter sets depending on the filter sets associated with the
application.

3. From the Group By list, select a value to use to sort issues in all visible folders into groups.

The default grouping is Category. For a description of the Group By opftions, see "Grouping
Issues" on page 26.

4. From the Issues For list, select one of the following:
o <All Users>

o Your Fortify Software Security Center user name. This is the default.

5. Click one of the following category tabs (folders).

o The Critical tab contains issues that have a high impact and a high likelihood of exploitation.
Fortify recommends that you remediate critical issues immediately.

o The High tab contains issues that have a high impact and a low likelihood of exploitation. Fortify
recommends that you remediate high issues with the next patch release.

o The Medium tab contains issues that a have low impact and a high likelihood of exploitation.
Fortify recommends that you remediate medium issues as time permits.
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o The Low tab contains issues that have a low impact and a low likelihood of exploitation. Fortify
recommends that you remediate low issues as time permits (your organization can customize
this category).

e The All tab contains all issues.

The tabs display issues based on your Group By, Issues For, and Filter selections. After you
select a tab, the Fortify Extension for Visual Studio retrieves the issues from Fortify Software
Security Cenfter.

6. Select an issue to view.

Working with Issues

After you select an issue, the Fortify Extension for Visual Studio provides issue-specific content
organized in the Fortify Remediation window into the Issue Details, Recommendation, Description,
and the History tabs.

This section provides descriptions of these tabs and their components.

Issue Details Tab

The Issue Details tab provides a dashboard for issues.

Essue Details | Recommendation | Deseription | Histary

User | v FilePath: WEB-NFancjavaicomioriffsampleafriches/modelLoc
Analysiz: Mot Set e = . e

unvalidated inout. This call could allow on otfacker o medify

o3 - Aetion URL - /Shawl ocations.action N
#|) FindLocationsjavaddh - serCity(l)

(@) FindLecationsjava:Ed - Assignment to this.city

#{] FindLocationsjavacd] - Read this.cy

&l | FindLecationsjavadT - findiimByiddrase(l)

i= LocationServicejavail37 - Assignment te quenyStr

| LocaticnService java:l 39 - evecuteQuery(l) |

The following table lists and describes Issue Details tab.

Tab Element Description
User Select a name from this list to assign a user to the selected issue.
Analysis Displays the analysis type for the selected issue. To change the analysis type,

select an item from the list.

<custom_tagname> Any custom tags your organization has defined in Fortify Software Security
Center. If available, these are displayed below the Analysis list.
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Tab Element Description

If the audif results have been submitted to Audit Assistant in Micro Focus
Fortify Software Security Center, then in addition to any other custom tags,
the tab displays the following tags:

o AA_Prediction—Exploitability level that Audit Assistant assigned to the
issue. You cannot modify this tag value.

« AA_Confidence—Confidence level from Audit Assistant for the accuracy of
its AA_Prediction value. This is a percentage, expressed in values that range
from 0.000 to 1.000. For example, a value of 0.982 indicates a confidence
level of 98.2 percent. You cannot modify this tag value.

¢ AA_Training—Whether to include or exclude the issue from Audit
Assistant training. You can modify this value.

For more information about Audit Assistant, see the Micro Focus Fortify
Software Security Center User Guide.

File Path (top right) = The path to the location of the source file for the selected issue.

Issue Abstract Displays a summary of the selected issue.
(top right)

Analysis Evidence Lists the items of evidence that the analyzer uncovered. Evidence is presented
(bottom right) in the order it was discovered. For information about the Analysis Evidence
icons, see "Analysis Evidence Window" on page 18.

Comments Displays any comments added to the issue.

(bottom left) .
To add a comment to the selected issue:

1. Click Add Comment .~ .
2. Type a comment, and then click OK.

Recommendation Tab

The Recommendation tab provides suggestions and examples that show how to secure a vulnerability
or remedy a bad practice. The following table describes the tab sections.

Section Description

Recommendations = Describes possible solutions for the selected issue type. It can also include
examples and recommendations that your organization has defined.

Tips Provides useful information specific to the selected issue, including any custom
tips that your organization has defined

References Lists references for the recommendations provided, including any custom
references that your organization has defined
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Description Tab

The Description fab provides an abstract of the selected issue. It might also provide more detailed
explanations, including examples with descriptive text and code samples. The following table describes

the tab sections.

Section

Abstract/Custom
Abstract

Explanation/Custom
Explanation

Instance ID
Primary Rule ID

Priority Metadata
Values

Legacy Priority
Metadata Values

History Tab

Description

Displays a summary description of the selected issue, including custom
abstracts defined by your organization

Displays a description of the conditions under which an issue of the selected
type occurs. This includes a discussion of the vulnerability, the constructs
typically associated with it, ways in which it can be exploited, and the potential
ramifications of an attack. This section also provides custom explanations
defined by your organization.

Unique identifier for an issue
Primary rule that found the issue

Priority metadata values for an issue

Legacy priority metadata values for an issue

The tab History tab shows a history of audit actions, including details such as the time and date, and
the name of the user who modified the issue.

Customizing Issue Visibility

You can customize the Fortify Remediation window to determine which issues it displays.

1. Select Fortify > Remediation Options.
The Remediation Options dialog box opens.
2. Click the Issue Visibility tab.

3. Select or clear the following check boxes:

o To display all hidden issues, select Show Hidden Issues.

Note: The visibility filter settings in the issue template associated with the application
version determine which issues are hidden.

o To display all issues that were detected in the previous analysis, but no longer exist, select Show
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Removed Issues.

Note: Users who audit issues can suppress specific types of issues that are not considered
high priority or of immediate concern. For example, auditors can suppress issues that are
fixed, or issues that your organization plans not to fix.

e To display all suppressed issues, select Show Suppressed Issues.

4. Click OK.

Searching for Issues

You can use the search box below the issues list in the Analysis Results window to search for issues.
For detailed instructions about the search capabilities, see "Searching for Issues" on page 28.

Assigning Users to Issues

The User list contains all of the users for the application version, and also a blank value. Use the blank
value to unassign a user from an issue.

1. Fromtheissues list in the Fortify Remediation window, select an issue.

2. Select the Issue Details tab and select a user from the User menu.

The Fortify Extension for Visual Studio updates the application on the Micro Focus Fortify Software
Security Center server.

Assigning Tags to Issues

To assign tag values to an issue:

1. Fromtheissues list in the Fortify Remediation window, select an issue.

2. From the Analysis list on the Issue Details tab, select a value that reflects your assessment of this
issue.

3. If custom tags defined for the project exist, provide values for them.

For text-type custom tags, you can click Edit Text L) to view and edit long text strings. This tag
accepts up to 500 characters (HTML/XML tags and newlines are not allowed).

For date-type custom tags, type a valid date or click Select Date /10 select a date from a
calendar.
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Locating Issues in Source Code

Because the Fortify Extension for Visual Studio works as an extension to your Visual Studio IDE, you
can use it to locate security-related issues in your code. You must have the same project open in both
Visual Studio and the Fortify Extension for Visual Studio.

To locate an issue in the source code, do either of the following:

o Fromthe issues list in the Fortify Remediation window, select an issue.
o From the Issue Details tab, select an issue from the Analysis Evidence list.

The Fortify Extension for Visual Studio jumps to the line of code that contains the security-related issue
displayed in Visual Studio.
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Send Documentation Feedback

If you have comments about this document, you can contact the documentation feam by email. If an
email client is configured on this computer, click the link above and an email window opens with the
following information in the subject line:

Feedback on User Guide (Fortify Extension for Visual Studio 18.20)
Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and send
your feedback to FortifyDocTeam@microfocus.com.

We appreciate your feedback!
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